File:  [cvs.NetBSD.org] / pkgsrc / games / teeworlds / Makefile
Revision 1.6: download - view: text, annotated - select for diffs
Sun Jan 14 17:34:01 2018 UTC (6 years, 10 months ago) by rillig
Branches: MAIN
CVS tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, HEAD
games/*: fix alignment of variable values

pkglint -Wall -r --autofix --only aligned

After running the above command, three packages had to be adjusted
manually:

In maelstrom-x11, pkglint didn't see that a commented variable
assignment should have been re-aligned as well.

In netmaze, there was a single line that didn't align well with all the
others, but pkglint decided to adjust the whole paragraph to this single
line. The result would have been ok, but not good.

In tscp, there was a paragraph where some of the lines were indented
one space more than the others. This rule is useful when one variable
name is very long compared to the others, but not in this case.

# $NetBSD: Makefile,v 1.6 2018/01/14 17:34:01 rillig Exp $

DISTNAME=	teeworlds-0.6.3-src
PKGNAME=	${DISTNAME:S/-src//}
CATEGORIES=	games
MASTER_SITES=	http://downloads.teeworlds.com/

MAINTAINER=	fstd.lkml@gmail.com
HOMEPAGE=	https://www.teeworlds.com/
COMMENT=	Fast-paced retro multiplayer shooter
LICENSE=	zlib AND 2-clause-bsd AND modified-bsd AND cc-by-sa-v3.0

USE_LANGUAGES=	c c++

BUILD_DEPENDS+=	bam>=0.4.0:../../devel/bam

AUTO_MKDIRS=	yes

CPIO=	cpio

PYTHON_VERSIONS_INCOMPATIBLE=	34 35 36 # hardcoded to 2.7 in a patch

do-configure:
	set -e; cd ${WRKSRC}; bam config

do-build:
	set -e; cd ${WRKSRC}; bam server_release client_release

do-install:
	${INSTALL_GAME} ${WRKSRC}/teeworlds ${DESTDIR}${PREFIX}/bin/teeworlds
	${INSTALL_GAME} ${WRKSRC}/teeworlds_srv ${DESTDIR}${PREFIX}/bin/teeworlds_srv
	cd ${WRKSRC} && ${FIND} data | \
		${CPIO} -p ${DESTDIR}${PREFIX}/share/teeworlds
	cd ${DESTDIR}${PREFIX} && \
	${FIND} share/teeworlds -type f -print >${WRKDIR}/PLIST

.include "../../devel/SDL/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>