File:  [cvs.NetBSD.org] / pkgsrc / games / supertuxkart / Makefile
Revision 1.20: download - view: text, annotated - select for diffs
Sun Jan 14 17:34:01 2018 UTC (6 years, 10 months ago) by rillig
Branches: MAIN
CVS tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1, HEAD
games/*: fix alignment of variable values

pkglint -Wall -r --autofix --only aligned

After running the above command, three packages had to be adjusted
manually:

In maelstrom-x11, pkglint didn't see that a commented variable
assignment should have been re-aligned as well.

In netmaze, there was a single line that didn't align well with all the
others, but pkglint decided to adjust the whole paragraph to this single
line. The result would have been ok, but not good.

In tscp, there was a paragraph where some of the lines were indented
one space more than the others. This rule is useful when one variable
name is very long compared to the others, but not in this case.

# $NetBSD: Makefile,v 1.20 2018/01/14 17:34:01 rillig Exp $
#

DISTNAME=	supertuxkart-0.8.1-src
PKGNAME=	${DISTNAME:S/-src//}
PKGREVISION=	10
CATEGORIES=	games
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=supertuxkart/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://supertuxkart.sourceforge.net/
COMMENT=	Free 3D kart racing game
#LICENSE=	gnu-gpl-v3 AND Creative-Commons-Attribution AND Creative-Commons-BY-SA AND Creative-Commons-Sampling+ AND FreeArt License AND SoundSnap license AND Public Domain AND Image*After terms

WRKSRC=			${WRKDIR}/SuperTuxKart-0.8.1
USE_CMAKE=		yes
#USE_PKGLOCALEDIR=	yes
USE_LANGUAGES=		c c++
USE_TOOLS+=		gmake

CXXFLAGS+=	-DNO_IRR_USE_NON_SYSTEM_JPEG_LIB_=1
CXXFLAGS+=	-DNO_IRR_USE_NON_SYSTEM_LIB_PNG_=1
CXXFLAGS+=	-DNO_IRR_USE_NON_SYSTEM_ZLIB_=1
CXXFLAGS+=	-DNO_IRR_USE_NON_SYSTEM_BZLIB_=1

NOT_PAX_ASLR_SAFE+=	bin/supertuxkart
NOT_PAX_MPROTECT_SAFE+=	bin/supertuxkart

# Debug nob for STK
#CMAKE_ARGS+=	-DCMAKE_BUILD_TYPE=Debug

SUBST_CLASSES+=			dos_eol
SUBST_MESSAGE.dos_eol=		Removing DOS line-ends
SUBST_STAGE.dos_eol=		post-extract
SUBST_FILES.dos_eol=		lib/irrlicht/source/Irrlicht/Makefile
SUBST_FILES.dos_eol+=		lib/irrlicht/source/Irrlicht/os.cpp
SUBST_FILES.dos_eol+=		lib/irrlicht/source/Irrlicht/COSOperator.cpp
SUBST_FILES.dos_eol+=		lib/irrlicht/source/Irrlicht/CIrrDeviceLinux.cpp
SUBST_FILTER_CMD.dos_eol=	${TR} -d '\r'

CMAKE_ARGS+=	-DUSE_WIIUSE=OFF
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} != "Linux"
SUBST_CLASSES+=		js
SUBST_STAGE.js=		pre-configure
SUBST_MESSAGE.js=	Disable Linux joystick support.
SUBST_FILES.js+=	lib/irrlicht/include/IrrCompileConfig.h
SUBST_SED.js+=		-e '/define.*_IRR_COMPILE_WITH_JOYSTICK_EVENTS_/d'
.endif

# for irrlicht debugging
#pre-build:
#	cd ${WRKSRC}/lib/irrlicht/source/Irrlicht && \
#		${MAKE_ENV} DEBUG=1 make ${_MAKE_JOBS}

pre-build:
	cd ${WRKSRC}/lib/irrlicht/source/Irrlicht && \
		${MAKE_ENV} NDEBUG=1 make ${_MAKE_JOBS}

.include "../../archivers/bzip2/buildlink3.mk"
.include "../../audio/openal-soft/buildlink3.mk"
.include "../../audio/libvorbis/buildlink3.mk"
.include "../../converters/fribidi/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../games/plib/buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../multimedia/libogg/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../x11/libXxf86vm/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>