File:  [cvs.NetBSD.org] / pkgsrc / games / singularity / Makefile
Revision 1.24: download - view: text, annotated - select for diffs
Mon Oct 12 21:51:59 2020 UTC (4 years, 6 months ago) by bacon
Branches: MAIN
CVS tags: HEAD
math/blas, math/lapack: Install interchangeable BLAS system

Install the new interchangeable BLAS system created by Thomas Orgis,
currently supporting Netlib BLAS/LAPACK, OpenBLAS, cblas, lapacke, and
Apple's Accelerate.framework.  This system allows the user to select any
BLAS implementation without modifying packages or using package options, by
setting PKGSRC_BLAS_TYPES in mk.conf. See mk/blas.buildlink3.mk for details.

This commit should not alter behavior of existing packages as the system
defaults to Netlib BLAS/LAPACK, which until now has been the only supported
implementation.

Details:

Add new mk/blas.buildlink3.mk for inclusion in dependent packages
Install compatible Netlib math/blas and math/lapack packages
Update math/blas and math/lapack MAINTAINER approved by adam@
OpenBLAS, cblas, and lapacke will follow in separate commits
Update direct dependents to use mk/blas.buildlink3.mk
Perform recursive revbump

# $NetBSD: Makefile,v 1.24 2020/10/12 21:51:59 bacon Exp $

DISTNAME=		singularity-0.30c-src
PKGNAME=		${DISTNAME:S/-src//}
PKGREVISION=		3
CATEGORIES=		games
MASTER_SITES=		http://endgame-singularity.googlecode.com/files/

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://www.emhsoft.com/singularity/
COMMENT=		Endgame: Singularity game

WRKSRC=			${WRKDIR}/${PKGNAME_NOREV}

INSTALLATION_DIRS=	bin share/doc/singularity
INSTALLATION_DIRS+=	share/singularity/code
INSTALLATION_DIRS+=	share/singularity/code/graphics
INSTALLATION_DIRS+=	share/singularity/code/screens
INSTALLATION_DIRS+=	share/singularity/data/fonts
INSTALLATION_DIRS+=	share/singularity/data/images
INSTALLATION_DIRS+=	share/singularity/data/sounds
INSTALLATION_DIRS+=	share/singularity/music

do-build:
	${ECHO} "#!/bin/sh" > ${WRKSRC}/singularity
	${ECHO} "cd ${PREFIX}/share/singularity" >> ${WRKSRC}/singularity
	${ECHO} "${PYTHONBIN} singularity.py" >> ${WRKSRC}/singularity

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/singularity ${DESTDIR}${PREFIX}/bin
	${INSTALL_DATA} ${WRKSRC}/singularity.py ${DESTDIR}${PREFIX}/share/singularity
	${INSTALL_DATA} ${WRKSRC}/code/*.py \
		${DESTDIR}${PREFIX}/share/singularity/code
	${INSTALL_DATA} ${WRKSRC}/code/graphics/*.py \
		${DESTDIR}${PREFIX}/share/singularity/code/graphics
	${INSTALL_DATA} ${WRKSRC}/code/screens/*.py \
		${DESTDIR}${PREFIX}/share/singularity/code/screens
	${INSTALL_DATA} ${WRKSRC}/data/*.* \
		${DESTDIR}${PREFIX}/share/singularity/data
	${INSTALL_DATA} ${WRKSRC}/data/fonts/*.* \
		${DESTDIR}${PREFIX}/share/singularity/data/fonts
	${INSTALL_DATA} ${WRKSRC}/data/images/*.* \
		${DESTDIR}${PREFIX}/share/singularity/data/images
	${INSTALL_DATA} ${WRKSRC}/data/sounds/*.* \
		${DESTDIR}${PREFIX}/share/singularity/data/sounds
	${INSTALL_DATA} ${WRKSRC}/README.txt \
		${DESTDIR}${PREFIX}/share/doc/singularity

.include "../../devel/py-game/buildlink3.mk"
.include "../../graphics/SDL_image/buildlink3.mk"
.include "../../math/py-numpy/buildlink3.mk"
.include "../../lang/python/extension.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>