[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / games / scummvm

File: [cvs.NetBSD.org] / pkgsrc / games / scummvm / Makefile (download)

Revision 1.3, Tue Dec 10 12:48:46 2002 UTC (21 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: netbsd-1-6-1-base, netbsd-1-6-1
Changes since 1.2: +10 -6 lines

Update to 0.3.0b. Based on update supplied by Adam Ciarcinski, with some
changes by me.
Changes:
- fix major race condition resulting in extremely frequent crashes on
  MorphOS/PocketPC
- massive cleanup work for iMUSE. Sam and Max music now plays correctly
- many bugfixes for Zak256, + sound and music support
- music support for Simon the Sorcerer on any platform with real MIDI
- experimental support for Indy3 (VGA) - Indiana Jones + Last Crusade
- completed support for Monkey1 VGA Floppy, The Dig
- added akos16 implementation for The Dig and Full Throttle costumes
- added digital iMUSE implementation for The Dig and Full Throttle music.
- Loom CD speech+music syncronisation improved greatly
- added midi-emulation via adlib, for platforms without sequencer support
- code seperation of various engine parts into several libraries
- several fixes to prevent Simon the Sorcerer crashing and hanging
- hundreds of bugfixes for many other games
- new SMUSH video engine, for Full Throttle and The Dig
- new in-game GUI
- launcher dialog

# $NetBSD: Makefile,v 1.3 2002/12/10 12:48:46 wiz Exp $

DISTNAME=	scummvm_0.3.0b-src
PKGNAME=	scummvm-0.3.0
CATEGORIES=	games
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=scummvm/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	packages@netbsd.org
HOMEPAGE=	http://scummvm.sourceforge.net/
COMMENT=	LucasArts Script Creation Utility for Maniac Mansion

USE_BUILDLINK2=	yes
USE_GMAKE=	yes
USE_X11=	yes
WRKSRC=		${WRKDIR}/${PKGNAME_NOREV}
HAS_CONFIGURE=	yes

do-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/scummvm
	${INSTALL_PROGRAM} ${WRKSRC}/scummvm ${PREFIX}/bin
	${INSTALL_MAN} ${WRKSRC}/scummvm.6 ${PREFIX}/man/man6
	${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/scummvm

.include "../../devel/SDL/buildlink2.mk"
.include "../../audio/mad/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"