[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / games / rtcw

File: [cvs.NetBSD.org] / pkgsrc / games / rtcw / Attic / Makefile (download)

Revision 1.10, Sat Mar 4 21:29:43 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.9: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.10 2006/03/04 21:29:43 jlam Exp $

DISTNAME=	wolf-linux-1.33.x86
PKGNAME=	rtcw-1.33
PKGREVISION=	1
CATEGORIES=	games
MASTER_SITES=	ftp://ftp.idsoftware.com/idstuff/wolf/linux/
EXTRACT_SUFX=	.run

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://games.activision.com/games/wolfenstein/
COMMENT=	Return to Castle Wolfenstein for Linux

ONLY_FOR_PLATFORM=	*-*-i386
NOT_FOR_PLATFORM=	NetBSD-*-*

CHECK_SHLIBS=		no
NO_BUILD=		yes
RTCWDIR=		${PREFIX}/lib/lokigames/rtcw
RESTRICTED=		"Size; the data set is much too big"
NO_SRC_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_FTP=		${RESTRICTED}
NO_SRC_ON_FTP=		${RESTRICTED}
EXTRACT_CMD=	${SED} '1,178d' ${DOWNLOADED_DISTFILE} | ${GTAR} xzf - \
		    -C ${WRKSRC}
USE_TOOLS+=	gtar

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} != "Linux"
DEPENDS+=       suse_base>=6.3:../../emulators/${SUSE_DIR_PREFIX}_base
.include "../../emulators/suse_linux/Makefile.application"
.else
.include "../../mk/x11.buildlink3.mk"
.endif

pre-extract:
	${MKDIR} ${WRKSRC}

do-install:
	${INSTALL_DATA_DIR} ${RTCWDIR}
	cd ${WRKSRC} && ${PAX} -rw -p am . ${RTCWDIR}

.include "../../mk/bsd.pkg.mk"