File:  [cvs.NetBSD.org] / pkgsrc / games / quakedata / Makefile
Revision 1.28: download - view: text, annotated - select for diffs
Sun Jan 14 17:34:01 2018 UTC (6 years, 10 months ago) by rillig
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, HEAD
games/*: fix alignment of variable values

pkglint -Wall -r --autofix --only aligned

After running the above command, three packages had to be adjusted
manually:

In maelstrom-x11, pkglint didn't see that a commented variable
assignment should have been re-aligned as well.

In netmaze, there was a single line that didn't align well with all the
others, but pkglint decided to adjust the whole paragraph to this single
line. The result would have been ok, but not good.

In tscp, there was a paragraph where some of the lines were indented
one space more than the others. This rule is useful when one variable
name is very long compared to the others, but not in this case.

# $NetBSD: Makefile,v 1.28 2018/01/14 17:34:01 rillig Exp $

DISTNAME=	quake106
PKGNAME=	quakedata-1.0
PKGREVISION=	1
CATEGORIES=	games
MASTER_SITES=	ftp://ftp.fu-berlin.de/pc/msdos/games/idgames/idstuff/quake/
MASTER_SITES+=	ftp://ftp.idsoftware.com/idstuff/quake/
EXTRACT_SUFX=	.zip

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://www.idsoftware.com/
COMMENT=	Game data files for Quake
LICENSE=	quakedata-license

RESTRICTED=		This software is shareware.
NO_SRC_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_FTP=		${RESTRICTED}

BUILD_DEPENDS+=	lha-[0-9]*:../../archivers/lha

EXTRACT_ELEMENTS=	resource.*

WRKSRC=		${WRKDIR}
NO_BUILD=	YES
USE_TOOLS+=	lha

post-extract:
	cd ${WRKSRC} && ${CAT} resource.dat resource.1 > resource.exe
	cd ${WRKDIR} && ${LHA} xfq resource.exe id1/pak0.pak

do-install:
	${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/quake/id1
	${INSTALL_DATA} ${WRKSRC}/id1/pak0.pak \
		${DESTDIR}${PREFIX}/share/quake/id1

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>