File:  [cvs.NetBSD.org] / pkgsrc / games / puzzles / Makefile
Revision 1.56: download - view: text, annotated - select for diffs
Sun Jan 14 17:34:01 2018 UTC (6 years, 10 months ago) by rillig
Branches: MAIN
CVS tags: HEAD
games/*: fix alignment of variable values

pkglint -Wall -r --autofix --only aligned

After running the above command, three packages had to be adjusted
manually:

In maelstrom-x11, pkglint didn't see that a commented variable
assignment should have been re-aligned as well.

In netmaze, there was a single line that didn't align well with all the
others, but pkglint decided to adjust the whole paragraph to this single
line. The result would have been ok, but not good.

In tscp, there was a paragraph where some of the lines were indented
one space more than the others. This rule is useful when one variable
name is very long compared to the others, but not in this case.

# $NetBSD: Makefile,v 1.56 2018/01/14 17:34:01 rillig Exp $

DISTNAME=	puzzles
PKGNAME=	puzzles-20160429
PKGREVISION=	2
CATEGORIES=	games
# distfile changes every day
MASTER_SITES=	# https://www.chiark.greenend.org.uk/~sgtatham/puzzles/
DIST_SUBDIR=	${PKGNAME_NOREV}

MAINTAINER=	wiz@NetBSD.org
HOMEPAGE=	https://www.chiark.greenend.org.uk/~sgtatham/puzzles/
COMMENT=	Collection of small one-player puzzle games by Simon Tatham
LICENSE=	mit

INSTALLATION_DIRS=	bin share/doc/puzzles

WRKSRC=		${WRKDIR}/puzzles-20160429.b31155b
USE_TOOLS+=	gmake pkg-config

BUILDLINK_TRANSFORM+=	rm:-Werror
MAKE_FLAGS=		prefix=${PREFIX}
MAKE_FLAGS=		gamesdir=${PREFIX}/bin
MAKE_FILE=		Makefile.gtk
CFLAGS+=		-DREVISION=${DISTNAME:S/puzzles-r//}

SUBST_CLASSES+=		ldflags
SUBST_SED.ldflags+=	-e 's/$$(CC)/$$(CC) $$(LDFLAGS)/g'
SUBST_FILES.ldflags+=	Makefile.gtk
SUBST_MESSAGE.ldflags=	Honoring LDFLAGS.
SUBST_STAGE.ldflags=	pre-build

post-install:
	${INSTALL_DATA} ${WRKSRC}/puzzles.txt \
		${DESTDIR}${PREFIX}/share/doc/puzzles

.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>