File:  [cvs.NetBSD.org] / pkgsrc / games / openttd-data / Makefile
Revision 1.7: download - view: text, annotated - select for diffs
Sun Jan 14 17:34:00 2018 UTC (6 years, 10 months ago) by rillig
Branches: MAIN
CVS tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, HEAD
games/*: fix alignment of variable values

pkglint -Wall -r --autofix --only aligned

After running the above command, three packages had to be adjusted
manually:

In maelstrom-x11, pkglint didn't see that a commented variable
assignment should have been re-aligned as well.

In netmaze, there was a single line that didn't align well with all the
others, but pkglint decided to adjust the whole paragraph to this single
line. The result would have been ok, but not good.

In tscp, there was a paragraph where some of the lines were indented
one space more than the others. This rule is useful when one variable
name is very long compared to the others, but not in this case.

# $NetBSD: Makefile,v 1.7 2018/01/14 17:34:00 rillig Exp $

GFXVER=					0.5.2
PKGNAME=				openttd-data-${GFXVER}
CATEGORIES=				games x11
MASTER_SITES=				http://binaries.openttd.org/extra
DISTFILES=				opengfx-${GFXVER}-all.zip
DISTFILES+=				openmsx-0.3.1-all.zip
DISTFILES+=				opensfx-0.2.3-all.zip
SITES.opengfx-${GFXVER}-all.zip=	${MASTER_SITES:Q}/opengfx/${GFXVER}/
SITES.openmsx-0.3.1-all.zip=		${MASTER_SITES:Q}/openmsx/0.3.1/
SITES.opensfx-0.2.3-all.zip=		${MASTER_SITES:Q}/opensfx/0.2.3/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.openttd.org/
COMMENT=	Free data files for OpenTTD
LICENSE=	gnu-gpl-v2

NO_BUILD=	yes
NO_CONFIGURE=	yes

INSTALLATION_DIRS=	share/openttd/data
INSTALLATION_DIRS+=	share/openttd/gm

USE_TOOLS+=	tar

post-extract:
	cd ${WRKDIR} && tar xvf opengfx-${GFXVER}.tar

do-install:
	${INSTALL_DATA} ${WRKDIR}/opengfx-${GFXVER}/*.grf \
		${DESTDIR}${PREFIX}/share/openttd/data
	${INSTALL_DATA} ${WRKDIR}/opengfx-${GFXVER}/*.obg \
		${DESTDIR}${PREFIX}/share/openttd/data
	${INSTALL_DATA} ${WRKDIR}/openmsx-0.3.1/*.mid \
		${DESTDIR}${PREFIX}/share/openttd/gm
	${INSTALL_DATA} ${WRKDIR}/openmsx-0.3.1/*.obm \
		${DESTDIR}${PREFIX}/share/openttd/gm
	${INSTALL_DATA} ${WRKDIR}/opensfx-0.2.3/*.cat \
		${DESTDIR}${PREFIX}/share/openttd/data
	${INSTALL_DATA} ${WRKDIR}/opensfx-0.2.3/*.obs \
		${DESTDIR}${PREFIX}/share/openttd/data

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>