The NetBSD Project

CVS log for pkgsrc/games/neverball/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / games / neverball

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2010Q4-base


Revision 1.22 / (download) - annotate - [select for diffs], Thu Dec 23 11:44:31 2010 UTC (13 years, 3 months ago) by dsainty
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base, pkgsrc-2010Q4
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

Mechanically replace references to graphics/jpeg with the suitable
alternative from mk/jpeg.buildlink3.mk

This allows selection of an alternative jpeg library (namely the x86 MMX,
SSE, SSE2 accelerated libjpeg-turbo) via JPEG_DEFAULT=libjpeg-turbo, and
follows the current standard model for alternatives (fam, motif, fuse etc).

The mechanical edits were applied via the following script:

#!/bin/sh
for d in */*; do
  [ -d "$d" ] || continue
  for i in "$d/"Makefile* "$d/"*.mk; do
    case "$i" in *.orig|*"*"*) continue;; esac
    out="$d/x"
    sed -e 's;graphics/jpeg/buildlink3\.mk;mk/jpeg.buildlink3.mk;g' \
        -e 's;BUILDLINK_PREFIX\.jpeg;JPEGBASE;g' \
        < "$i" > "$out"
    if cmp -s "$i" "$out"; then
      rm -f "$out"
    else
      echo "Edited $i"
      mv -f "$i" "$i.orig" && mv "$out" "$i"
    fi
  done
done

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>