[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / games / nethack-lib

File: [cvs.NetBSD.org] / pkgsrc / games / nethack-lib / Makefile (download)

Revision 1.20, Sat Aug 20 19:16:21 2005 UTC (18 years, 8 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3
Changes since 1.19: +4 -3 lines

Use REQD_DIRS instead of MAKE_DIRS for directories under ${PREFIX} so
that these directories will be conditionally removed (based on reference
counts), regardless of the value of PKG_CONFIG.  Bump the PKGREVISION
for packages that were modified as a result.

# $NetBSD: Makefile,v 1.20 2005/08/20 19:16:21 jlam Exp $
#

.include		"../nethack-lib/Makefile.common"

PKGNAME=		nethack-lib-${NETHACK_VERSION}
PKGREVISION=		1

COMMENT=		Data files for Nethack

HAS_CONFIGURE=		yes
CONFIGURE_SCRIPT=	./sys/unix/setup.sh
BUILD_TARGET=		datastuff
INSTALL_TARGET=		manpages install-dat

USE_PKGINSTALL=		yes

CONF_FILES_PERMS+=	/dev/null ${PREFIX}/share/${NETHACK_DIR}/record \
			${ROOT_USER} games 664
CONF_FILES_PERMS+=	/dev/null ${PREFIX}/share/${NETHACK_DIR}/logfile \
			${ROOT_USER} games 664

REQD_DIRS_PERMS+=	${PREFIX}/share/${NETHACK_DIR}			\
			${ROOT_USER} games 775
REQD_DIRS_PERMS+=	${PREFIX}/share/${NETHACK_DIR}/save		\
			${ROOT_USER} games 770

.include "../../mk/bsd.pkg.mk"