[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / games / gnome2-games

File: [cvs.NetBSD.org] / pkgsrc / games / gnome2-games / Attic / Makefile (download)

Revision 1.67, Thu Apr 6 06:22:00 2006 UTC (18 years ago) by reed
Branch: MAIN
Changes since 1.66: +5 -5 lines

Over 1200 files touched but no revisions bumped :)

RECOMMENDED is removed. It becomes ABI_DEPENDS.

BUILDLINK_RECOMMENDED.foo becomes BUILDLINK_ABI_DEPENDS.foo.

BUILDLINK_DEPENDS.foo becomes BUILDLINK_API_DEPENDS.foo.

BUILDLINK_DEPENDS does not change.

IGNORE_RECOMMENDED (which defaulted to "no") becomes USE_ABI_DEPENDS
which defaults to "yes".

Added to obsolete.mk checking for IGNORE_RECOMMENDED.

I did not manually go through and fix any aesthetic tab/spacing issues.

I have tested the above patch on DragonFly building and packaging
subversion and pkglint and their many dependencies.

I have also tested USE_ABI_DEPENDS=no on my NetBSD workstation (where I
have used IGNORE_RECOMMENDED for a long time). I have been an active user
of IGNORE_RECOMMENDED since it was available.

As suggested, I removed the documentation sentences suggesting bumping for
"security" issues.

As discussed on tech-pkg.

I will commit to revbump, pkglint, pkg_install, createbuildlink separately.

Note that if you use wip, it will fail!  I will commit to pkgsrc-wip
later (within day).

# $NetBSD: Makefile,v 1.67 2006/04/06 06:22:00 reed Exp $

DISTNAME=		gnome-games-2.14.0
CATEGORIES=		games gnome
MASTER_SITES=		${MASTER_SITE_GNOME:=sources/gnome-games/2.14/}
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://www.gnome.org/
COMMENT=		GNOME2 games collection

CONFLICTS=		xbill-[0-9]*

BUILD_USES_MSGFMT=	yes

USE_DIRS+=		gnome2-1.5
USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		gmake pkg-config
USE_CONFIG_WRAPPER=	yes
USE_LANGUAGES=		c c++
USE_LIBTOOL=		yes
USE_MSGFMT_PLURALS=	yes

GNU_CONFIGURE=		yes
CONFIGURE_ENV+=		PKGLOCALEDIR=${PKGLOCALEDIR:Q}
CONFIGURE_ARGS+=	--localstatedir=${VARBASE:Q}
# This package installs files in sysconfdir but does not read them directly,
# so the following configuration argument is safe.
CONFIGURE_ARGS+=	--sysconfdir=${EGDIR:Q}

EGDIR=			${PREFIX}/share/examples/gnome2-games
CONF_FILES=
.for conffile in	sound/events/gnibbles.soundlist \
			sound/events/gnobots2.soundlist \
			sound/events/iagno.soundlist
CONF_FILES+=		${EGDIR}/${conffile} ${PKG_SYSCONFDIR}/${conffile}
.endfor

FILES_SUBST+=		INSTALL=${INSTALL:Q}

GCONF2_SCHEMAS=		aisleriot.schemas
GCONF2_SCHEMAS+=	blackjack.schemas
GCONF2_SCHEMAS+=	gataxx.schemas
GCONF2_SCHEMAS+=	glines.schemas
GCONF2_SCHEMAS+=	gnect.schemas
GCONF2_SCHEMAS+=	gnibbles.schemas
GCONF2_SCHEMAS+=	gnobots2.schemas
GCONF2_SCHEMAS+=	gnometris.schemas
GCONF2_SCHEMAS+=	gnomine.schemas
GCONF2_SCHEMAS+=	gnotski.schemas
GCONF2_SCHEMAS+=	gnotravex.schemas
GCONF2_SCHEMAS+=	gtali.schemas
GCONF2_SCHEMAS+=	iagno.schemas
GCONF2_SCHEMAS+=	libgnomegames.schemas
GCONF2_SCHEMAS+=	mahjongg.schemas
GCONF2_SCHEMAS+=	same-gnome.schemas

PYTHON_PATCH_SCRIPTS=	libgames-support/games-server.py

BUILDLINK_API_DEPENDS.glib2+=	glib2>=2.6.3
BUILDLINK_API_DEPENDS.howl+=	howl>=0.9.6
BUILDLINK_API_DEPENDS.libgnome+=	libgnome>=2.10.0
BUILDLINK_API_DEPENDS.librsvg2+=	librsvg2>=2.12.6

.include "../../audio/esound/buildlink3.mk"
.include "../../devel/GConf2/schemas.mk"
.include "../../devel/GConf2-ui/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/libglade2/buildlink3.mk"
.include "../../devel/libgnome/buildlink3.mk"
.include "../../devel/libgnomeui/buildlink3.mk"
.include "../../graphics/cairo/buildlink3.mk"
.include "../../graphics/librsvg2/buildlink3.mk"
.include "../../lang/guile/buildlink3.mk"
.include "../../net/howl/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../textproc/intltool/buildlink3.mk"
.include "../../textproc/scrollkeeper/omf.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"