[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / games / gbrainy

File: [cvs.NetBSD.org] / pkgsrc / games / gbrainy / Makefile (download)

Revision 1.106, Sun May 2 10:24:48 2021 UTC (2 years, 7 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.105: +2 -4 lines

*: Use the tools framework for itstool

Now it should be more obvious when a package needs it as a dependency,
as it will fail loudly if it isn't declared as a tool.

While here, some duplicate dependencies on itstool were removed from the
MATE packages

# $NetBSD: Makefile,v 1.106 2021/05/02 10:24:48 nia Exp $

DISTNAME=	gbrainy-2.4.1
PKGNAME=	gbrainy-2.41
PKGREVISION=	7
CATEGORIES=	games
MASTER_SITES=	https://gent.softcatala.org/jmas/gbrainy/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://wiki.gnome.org/Apps/gbrainy
COMMENT=	Brain teaser game and trainer
LICENSE=	gnu-gpl-v2

MAKE_JOBS_SAFE=	no

GNU_CONFIGURE=	yes
USE_LIBTOOL=	yes
USE_LANGUAGES=	c
USE_TOOLS+=	gmake intltool pkg-config bash:run
USE_TOOLS+=	msgfmt msgmerge xgettext itstool

BUILDLINK_API_DEPENDS.cairo+=	cairo>=1.2.0

REPLACE_BASH=		src/Clients/Classical/gbrainy.in
# mono-style, pkgsrc infrastructure doesn't change anything in it.
#PKGCONFIG_OVERRIDE=	data/gbrainy.pc.in

.include "../../devel/glib2/buildlink3.mk"
.include "../../graphics/librsvg/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../lang/mono/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/gtk-sharp3/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"