[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / games / freeciv-share

File: [cvs.NetBSD.org] / pkgsrc / games / freeciv-share / Makefile.common (download)

Revision 1.20, Wed Aug 24 10:36:02 2005 UTC (18 years, 7 months ago) by adam
Branch: MAIN
Changes since 1.19: +14 -3 lines

Changes 2.0.4:
 - Fix some buffer underruns on the terrain array (this bug could have
   been the cause of arbitrary crashes on some platforms).
 - Don't automatically pop up the city dialog when in observer mode.
 - Treat an alt-left click the same as a middle click, to allow two-button
   mice to work on windows (GTK-2 client).
 - Fix a bug - when a city was transferred/conquered twice the client
   sometimes wouldn't get an update about the second exchange.
 - Fix the behavior of Granary and Pyramids in the Civ2 compatibility ruleset.
 - Fix Pyramids so they are no longer cumulative with Granary.
 - Fix a minor bug that prevented 2.0 savegames from working properly with
   1.14 Freeciv.

Changes 2.0.3:
 - Fix some bugs that show up on 64-bit machines.
 - Fix some bugs with future techs in some situations.
 - Fix some bugs that allowed naval units onto land.
 - Fix a bug that could crash the server when a player picked their nation.
 - Fix a bug with player info not being updated after an alliance is broken.
 - Fix a bug with happiness of a unit's home city when borders change.
 - Fix a bug with happiness of a unit's home city when the unit moves.
 - Fix some bugs with nation starting positions in scenarios.
 - Fix a bug when running the server without stdin input.
 - Don't allow teams to be changed when loading a game.
 - Don't allow observers to vote.
 - Fix a bug with the fallback when generator 3, startpos 3 fails.
 - Fix a crash in the help dialog (when looking at Engineers).
 - Don't popup the caravan dialogs when in observer mode.
 - Fix a crash in goto mode when the mouse is near the map overview window.
 - Fix a bug when a diplomat is killed while the diplomat dialog window is
   in the process of opening.
 - Fix a bug with the diplomat dialog window for spies when you don't have
   an embassy.

# $NetBSD: Makefile.common,v 1.20 2005/08/24 10:36:02 adam Exp $

DISTNAME=	freeciv-${FC_VERS}
FC_VERS=	2.0.4
CATEGORIES=	games
MASTER_SITES=	ftp://ftp.freeciv.org/pub/freeciv/stable/ \
		http://www.freeciv.org/ftp/stable/ \
		ftp://ftp.freeciv.org/pub/freeciv/beta/ \
		http://www.freeciv.org/ftp/beta/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	tech-pkg@NetBSD.org
HOMEPAGE=	http://www.freeciv.org/

BUILD_USES_MSGFMT=	yes
USE_PKGLOCALEDIR=	yes
GNU_CONFIGURE=		yes

DISTINFO_FILE=		${.CURDIR}/../../games/freeciv-share/distinfo
PATCHDIR=		${.CURDIR}/../../games/freeciv-share/patches

PYTHON_PATCH_SCRIPTS=	${WRKSRC}/common/generate_packets.py

SUBST_CLASSES=		data
SUBST_STAGE.data=	post-patch
SUBST_FILES.data=	data/Makefile.in
SUBST_SED.data+=	-e "s|@CLIENT_FALSE@|@MAKE_DATA_FALSE@|g"
SUBST_SED.data+=	-e "s|@CLIENT_TRUE@|@MAKE_DATA_TRUE@|g"
SUBST_SED.data+=	-e "s|@SERVER_FALSE@|@MAKE_DATA_FALSE@|g"
SUBST_SED.data+=	-e "s|@SERVER_TRUE@|@MAKE_DATA_TRUE@|g"
SUBST_MESSAGE.data=	"Fixing installation of data files."

.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../lang/python/application.mk"