[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / games / freeciv-server

File: [cvs.NetBSD.org] / pkgsrc / games / freeciv-server / Makefile (download)

Revision 1.54, Mon Jul 1 04:08:11 2019 UTC (4 years, 5 months ago) by ryoon
Branch: MAIN
Changes since 1.53: +2 -2 lines

Recursive revbump from boost-1.70.0

# $NetBSD: Makefile,v 1.54 2019/07/01 04:08:11 ryoon Exp $

PKGNAME=	${DISTNAME:S/-/-server-/}
PKGREVISION=	9
COMMENT=	Freeciv game server

DEPENDS+=	freeciv-share>=${FC_VERS}:../../games/freeciv-share

USE_TOOLS+=	automake autoconf

pre-configure:
	cd ${WRKSRC} && autoreconf -i

CONFIGURE_ARGS+=	--disable-client
CONFIGURE_ARGS+=	--disable-fcmp
CONFIGURE_ARGS+=	--disable-make-data
CONFIGURE_ARGS+=	--with-readline

# Uses rl_filename_completion_function() which was introduced in readline-4.2
BUILDLINK_API_DEPENDS.readline+=	readline>=4.2

.include "../../games/freeciv-share/suppress_installation.mk"

.include "../../games/freeciv-share/Makefile.common"

.include "../../archivers/bzip2/buildlink3.mk"
.include "../../devel/readline/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/bsd.pkg.mk"