The NetBSD Project

CVS log for pkgsrc/games/chocolate-doom/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / games / chocolate-doom

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.16: download - view: text, markup, annotated - select for diffs
Wed Feb 12 06:44:51 2025 UTC (2 months, 2 weeks ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, HEAD
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -1 lines
*: Recursive revbump from audio/flac-1.5.0

Revision 1.15: download - view: text, markup, annotated - select for diffs
Fri Aug 9 11:35:11 2024 UTC (8 months, 2 weeks ago) by micha
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +7 -12 lines
games/chocolate-doom: Update to 3.1.0

3.1.0 (2024-08-01)

General
=======

* Drag and drop loading of WAD, Dehacked and demo files is now supported on
  Windows - simply drag the files onto chocolate-doom.exe (thanks Fabian).
* WAD file autoloading was added - WAD and DEH files can be copied into
  an autoload folder to be automatically included on every game start.
* Music pack configuration has been significantly simplified. By simply
  copying .flac/.ogg music files into a folder they will be automatically
  detected by filename and used.
* Music packs can now be used with OPL as a fallback, and music pack
  config files can have any name ending in '.cfg'.
* MP3 music packs are now supported.
* Network synchronization now uses a PID controller by default, which
  makes games more smooth and more stable, especially for Internet play.
* UDP hole punching is now used to make servers behind NAT gateways
  automatically accessible to the Internet.
* OPL emulation now uses Nuked OPL3 v1.8 (thanks nukeykt)
  Allow simultaneous PC speaker emulation and OPL emulation
  (thanks Michael Day).
* The setup tool now uses "Romero Blue" as a background (see the wiki:
  https://doomwiki.org/wiki/Romero_Blue for more info).
* The 0 and 5 keys on the number pad can now be bound independently
  of any other keyboard key (thanks BlooD2ool).
* With aspect ratio correction disabled, the game can scale to any
  arbitrary size and remove all black borders in full screen mode.
  (thanks chungy)
* The executable's location is now checked when looking for IWADs.
* The IWAD files installed by Steam-on-Linux are now detected (thanks
  chungy).
* It's now possible to use -response to load response files.
* Default savegame name now includes the WAD filename (thanks Fabian).
* Mouse movement is no longer read when the game window is inactive
  (thanks Julia Nechaevskaya).
* Chocolate Doom now by default generates a "pet name" for the user
  to respect privacy (thanks Jon!)
* The Freedoom single-player IWAD files are now officially supported,
  since recent versions changed all levels to be vanilla compatible.
* Add native support for the FluidSynth midi synthesizer.
* Add a fsynth_gain config key to fine tune the FluidSynth output level
  (thanks Fabian).
* Redesign of native MIDI support in Windows (thanks ceski and Roman Fomin):
  Emulates DMX MPU-401 feature set by default, change with winmm_complevel.
  MIDI device reset between songs using "GM System On", change with
  winmm_reset_type.
  Configurable delay after reset for legacy MIDI hardware (e.g. Roland
  SC-55), change with winmm_reset_delay.
* Add improved gamepad support via the SDL_GameController interface. This
  includes support for analog triggers, modern dual-stick default bindings
  (based on Unity Doom), descriptive button names for common controller
  types and configurable dead zones for stick axes. (Michael Day).
* All games now have shiny new icons!
* The -display parameter was added to specify the display number on which
  to show the screen (thanks Robin Emeršič).

Build systems
=============

* SDL2_mixer and SDL2_net can now be optionally disabled to increase
  portability to systems that might not support audio or networking
  (thanks turol).
* Travis CI was replaced with GitHub Actions (thanks Michael Francis).
* mingw CI was added for automatic Windows-building (thanks turol).
* A cpp-linter CI was added to improve the quality and formatting of code
  (thanks turol).
* The --disable-zpool autoconf argument for disabling memory pooling was
  added to make debugging easier (thanks turol).
* Python 2 has been deprecated and Python 3 is now used exclusively
  (thanks Fabian).

Refactorings
============

* CMake project files have been added, replacing the Microsoft Visual
  Studio and Code::Blocks files. CMake maintains support for multiple
  IDEs and versions thereof, and reduces developer overhead when updating
  Chocolate Doom (huge thanks to AlexMax for this work).
* Source code has been retrofitted to fix many compiler warnings and
  add const annotations to many variables (thanks turol).
* Several functions have been hardened against incomplete reads and
  error conditions, and made safer (thanks turol).
* Man page generation has been reworked to use autoconf macro
  substitution, making it eaiser for downstream forks to change the
  project name (thanks Jon).
* We now print a meaningful error message when a savegame cannot be
  loaded (thanks Zodomaniac, chungy).
  There's now a log file feature for the network code to aid in tracking
  down multiplayer bugs.
* AppData files were updated to the AppStream standard (thanks Mike).
* Many abuses of the extern keyword have been cleaned up to prevent
  undefined behavior (thanks turol).
* Install of bash completion scripts was fixed (thanks Mike Swanson).

Bug fixes
=========

* Fixed an exception thrown by the Windows kernel when debugging with
  GDB (thanks AXDOOMER).
* Loop metadata now works properly with music packs on Windows.
  Mouse movement is ignored when the game window isn't active (thanks
  Julia Nechaevskaya).
* A bug was fixed where music would not play after pausing on an
  intermission screen (thanks Julia Nechaevskaya).
* Timeouts when connecting to a network server were fixed (thanks
  @bradc6).
* A long-standing bug where some visplane overflows caused crashes was
  fixed (thanks Michael Francis).
* A multiplayer deadlock bug where clients would stop sending tics after
  missing tics from the server was fixed. There are both client- and
  server- side fixes to fix the problem when playing with older versions
  (thanks MadDog and Mortrixs for help tracking this down).
* The macOS launcher now quits automatically when all windows are closed.
* The mouse speed calibration thermometer was fixed.
* Some improvements have been made to PC speaker emulation to better match
  Vanilla (thanks NY00123).
* Filenames and paths with non-latin characters now work on Windows
  (thanks Roman Fomin).
* Properly handle orphan carriage returns when parsing deh files
  (thanks Michael Day).

Doom
====

* Doom 1.2 demo support was added (thanks James Canete!)
  Map33 intermission screen and map33-map35 automap names are
  emulated (thanks CapnClever).
* We now exit gracefully when player starts are missing (thanks Michael
  Francis).
* We now exit gracefully on levels with a boss brain and no boss spitter
  things (thanks Jason Benaim).
* It's now possible to play multiplayer with gameversion=1.2.
* When the game hits the limit for the number of wall scrollers, a count
  of the number of scrollers is now displayed (thanks Jon).
* Sector special 17 (random light flicker) is now accurately emulated to
  only appear in gameversion > 1.2 (thanks tpoppins).
* Fixed mouse events causing unwanted key presses (thanks Michael Day).
* French Doom II files doom2f.wad and french.deh are now automatically
  detected (thanks Acts19quiz).
* Mouse buttons are now bindable to run (thanks Archenoth).
* The "Sky never changes in Doom II" bug is now accurately emulated
  (thanks Michael Francis).
* Mouse buttons are now bindable to turn left/right (thanks Fabian).
* Fix possible undefined behavior and accurately emulate vanilla when
  -skill parameter is given a negative value (thanks Henrique Jorge).

Heretic
=======

* P_FindNextHighestFloor was changed to match vanilla behavior (thanks
  AXDOOMER).
* WAD hash table is now generated for speed (thanks Michael Francis).
* HHE level name replacements now apply on the intermission screen
  (thanks ETTiNGRiNDER).
* Mouse buttons are now bindable to scroll through inventory and
  "use artifact" (thanks Michael Day).
* Mouse buttons are now bindable to run (thanks Archenoth).
* Multiplayer demo playback was fixed (thanks Ryan Krafnick).
* The GOG.com release is now detected (thanks Mike Swanson).
* Mouse buttons are now bindable to turn left/right (thanks Fabian).
* Fix NULL backsector crash (thanks kitchen-ace and Julia Nechaevskaya).

Hexen
=====

* ACS code has been hardened against potential security vulnerabilities.
* WAD hash table is now generated for speed (thanks AXDOOMER).
* Mouse buttons are now bindable to scroll through inventory and
 "use artifact" (thanks Michael Day).
* Mouse buttons are now bindable to run (thanks Archenoth).
* Multiplayer demo playback was fixed (thanks Ryan Krafnick).
* The GOG.com release is now detected (thanks Mike Swanson).
* Mouse buttons are now bindable to turn left/right (thanks Fabian).
* Fixed demo desyncs in P_LookForPlayers (thanks Michael Day)
* Add support for two different v1.1 variants through -gameversion
  argument (thank NY00123).

Strife
======

* Sehacked replacements of the "empty slot" string now work.
* VOICES.WAD is now found in a case-insensitive way
  (thanks Michael Francis).
* PC speaker sound effects are now supported (thanks ceski).
* Mouse buttons are now bindable to turn left/right (thanks Fabian).
* Fixed demo desyncs in P_LookForPlayers (thanks Michael Day)
* Fix possible undefined behavior and accurately emulate vanilla when
  -skill parameter is given a negative value (thanks Henrique Jorge).

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sat Apr 6 08:05:24 2024 UTC (12 months, 3 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -2 lines
* recursive bump for libxkbcommon 1.7.0

Marc Baudoin reported problems with using old binary packages
with the new libkxbcommon, so force everything to 1.7.0

Revision 1.13: download - view: text, markup, annotated - select for diffs
Tue Jan 30 14:21:52 2024 UTC (14 months, 4 weeks ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
*: Recursive revbump from audio/pulseaudio-17.0

Revision 1.12: download - view: text, markup, annotated - select for diffs
Mon Aug 14 05:24:26 2023 UTC (20 months, 2 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
*: recursive bump for Python 3.11 as new default

Revision 1.11: download - view: text, markup, annotated - select for diffs
Sat May 6 19:09:18 2023 UTC (23 months, 3 weeks ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2 lines
*: Recursive revbump from audio/libopus 1.4

Revision 1.10: download - view: text, markup, annotated - select for diffs
Sun Sep 11 12:51:38 2022 UTC (2 years, 7 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2 lines
*: bump PKGREVISION for flac shlib bump

Revision 1.9: download - view: text, markup, annotated - select for diffs
Thu Aug 11 05:08:24 2022 UTC (2 years, 8 months ago) by gutteridge
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
Bump all dependent packages of wayland (belatedly)

The package changed with the addition of its libepoll-shim dependency.
Otherwise, we can get:
ERROR: libepoll-shim>=0.0.20210418 is not installed; can't buildlink files.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Mon Mar 28 10:44:06 2022 UTC (3 years, 1 month ago) by tnn
Branches: MAIN
CVS tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines
g*/*: revbump(1) for libsndfile

Revision 1.7: download - view: text, markup, annotated - select for diffs
Wed Dec 8 16:04:25 2021 UTC (3 years, 4 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
revbump for icu and libffi

Revision 1.6: download - view: text, markup, annotated - select for diffs
Wed Sep 8 21:05:04 2021 UTC (3 years, 7 months ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
Recursive revbump for audio/jack

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Aug 18 17:57:49 2020 UTC (4 years, 8 months ago) by leot
Branches: MAIN
CVS tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -1 lines
*: revbump for libsndfile

Revision 1.4: download - view: text, markup, annotated - select for diffs
Fri Jun 26 09:03:57 2020 UTC (4 years, 10 months ago) by micha
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -3 lines
games/chocolate-doom: Update to 3.0.1

Security update to fix CVE-2020-14983.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sun Mar 8 16:49:34 2020 UTC (5 years, 1 month ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
*: recursive bump for libffi

Revision 1.2: download - view: text, markup, annotated - select for diffs
Fri Aug 30 22:08:36 2019 UTC (5 years, 8 months ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +14 -2 lines
chocolate-doom: install icons to the right directory

Revision 1.1: download - view: text, markup, annotated - select for diffs
Fri Aug 30 17:33:25 2019 UTC (5 years, 8 months ago) by micha
Branches: MAIN
chocolate-doom: Imported version 3.0.0

OK from yhardy@.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>