File:  [cvs.NetBSD.org] / pkgsrc / games / armagetronad / Makefile.common
Revision 1.3: download - view: text, annotated - select for diffs
Sun Jan 14 17:33:57 2018 UTC (6 years, 10 months ago) by rillig
Branches: MAIN
CVS tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, HEAD
games/*: fix alignment of variable values

pkglint -Wall -r --autofix --only aligned

After running the above command, three packages had to be adjusted
manually:

In maelstrom-x11, pkglint didn't see that a commented variable
assignment should have been re-aligned as well.

In netmaze, there was a single line that didn't align well with all the
others, but pkglint decided to adjust the whole paragraph to this single
line. The result would have been ok, but not good.

In tscp, there was a paragraph where some of the lines were indented
one space more than the others. This rule is useful when one variable
name is very long compared to the others, but not in this case.

# $NetBSD: Makefile.common,v 1.3 2018/01/14 17:33:57 rillig Exp $
#
# used by games/armagetronad/Makefile
# used by games/armagetronad-server/Makefile

DISTNAME=	armagetronad-0.2.8.3.3.src
CATEGORIES=	games
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=armagetronad/}

HOMEPAGE=	http://www.armagetronad.org/
LICENSE=	gnu-gpl-v2

WRKSRC=		${WRKDIR}/${DISTNAME:S/.src//}

DISTINFO_FILE=	${.CURDIR}/../../games/armagetronad/distinfo
PATCHDIR=	${.CURDIR}/../../games/armagetronad/patches

GNU_CONFIGURE=		yes
USE_LANGUAGES=		c c++
USE_TOOLS+=		bash gmake
REPLACE_PYTHON+=	language/update.py

SUBST_CLASSES+=		bash
SUBST_MESSAGE.bash=	Set proper BASH path.
SUBST_STAGE.bash=	pre-configure
SUBST_FILES.bash=	batch/Makefile.am
SUBST_FILES.bash+=	batch/Makefile.in
SUBST_SED.bash=		-e 's,`which bash`,${BASH},'

CONFIGURE_ARGS+=	--disable-sysinstall
CONFIGURE_ARGS+=	--disable-uninstall
CONFIGURE_ARGS+=	--disable-useradd
# This sanitizes paths
CONFIGURE_ARGS+=	--disable-games

.include "../../textproc/libxml2/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"

CVSweb <webmaster@jp.NetBSD.org>