[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / fonts / sgi-fonts

File: [cvs.NetBSD.org] / pkgsrc / fonts / sgi-fonts / Makefile (download)

Revision 1.10, Sat Mar 4 21:29:40 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.9: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.10 2006/03/04 21:29:40 jlam Exp $
#

DISTNAME=	sgi-fonts-1.0-457.src
PKGNAME=	sgi-fonts-1.0.457
PKGREVISION=	2
CATEGORIES=	fonts
MASTER_SITES=	http://public.planetmirror.com/pub/suse/i386/8.2/suse/src/
EXTRACT_SUFX=	.rpm

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://oss.sgi.com/projects/sgi_propack/
COMMENT=	Linux compatibility package for SGI fonts

BUILD_DEPENDS+=	rpm2pkg>=1.3:../../pkgtools/rpm2pkg

WRKSRC=		${WRKDIR}/sgi-fonts

USE_IMAKE=	YES
USE_TOOLS+=	bdftopcf bzcat gtar
FONTS_DIRS.x11+=	${PREFIX}/lib/X11/fonts/misc/sgi
REQD_DIRS+=		${PREFIX}/lib/X11/fonts/misc/sgi

do-extract:
	${LOCALBASE}/sbin/rpm2pkg -d ${WRKDIR} ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES}
	cd ${WRKDIR} && bzcat sgi-fonts.tar.bz2 | ${GTAR} xf -

.include "../../mk/bsd.pkg.mk"