[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / fonts / roboto-fonts

File: [cvs.NetBSD.org] / pkgsrc / fonts / roboto-fonts / Makefile (download)

Revision 1.6, Sat Jul 4 16:18:33 2015 UTC (8 years, 2 months ago) by joerg
Branch: MAIN
Changes since 1.5: +1 -2 lines

Remove USE_X11BASE and X11PREFIX.

# $NetBSD: Makefile,v 1.6 2015/07/04 16:18:33 joerg Exp $
#

DISTNAME=	RobotoTTF
PKGNAME=	roboto-fonts-20140716
CATEGORIES=	fonts
MASTER_SITES=	http://material-design.storage.googleapis.com/downloads/
EXTRACT_SUFX=	.zip

MAINTAINER=	ryoon@NetBSD.org
HOMEPAGE=	http://www.google.com/design/spec/style/typography.html
COMMENT=	Roboto font family from Google's Android 4
LICENSE=	apache-2.0

DIST_SUBDIR=	${PKGNAME_NOREV}

WRKSRC=		${WRKDIR}

USE_LANGUAGES=	# none
NO_BUILD=	yes

FONTDIR=	${PREFIX}/share/fonts/X11/TTF
FONTS_DIRS.ttf=	${FONTDIR}

INSTALLATION_DIRS=	share/fonts/X11/TTF

INSTALL_FONTS=	Roboto-Black.ttf \
		Roboto-BlackItalic.ttf \
		Roboto-Bold.ttf \
		Roboto-BoldItalic.ttf \
		Roboto-Italic.ttf \
		Roboto-Light.ttf \
		Roboto-LightItalic.ttf \
		Roboto-Medium.ttf \
		Roboto-MediumItalic.ttf \
		Roboto-Regular.ttf \
		Roboto-Thin.ttf \
		Roboto-ThinItalic.ttf \
		RobotoCondensed-Bold.ttf \
		RobotoCondensed-BoldItalic.ttf \
		RobotoCondensed-Italic.ttf \
		RobotoCondensed-Light.ttf \
		RobotoCondensed-LightItalic.ttf

do-install:
.for i in ${INSTALL_FONTS}
	${INSTALL_DATA} ${WRKSRC}/${i} ${DESTDIR}${FONTDIR}
.endfor

.include "../../mk/bsd.pkg.mk"