File:
[cvs.NetBSD.org] /
pkgsrc /
fonts /
kanjistrokeorders-ttf /
Makefile
Revision
1.4:
download - view:
text,
annotated -
select for diffs
Wed Oct 3 18:28:25 2012 UTC (12 years, 2 months ago) by
asau
Branches:
MAIN
CVS tags:
pkgsrc-2013Q4-base,
pkgsrc-2013Q4,
pkgsrc-2013Q3-base,
pkgsrc-2013Q3,
pkgsrc-2013Q2-base,
pkgsrc-2013Q2,
pkgsrc-2013Q1-base,
pkgsrc-2013Q1,
pkgsrc-2012Q4-base,
pkgsrc-2012Q4,
HEAD
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
# $NetBSD: Makefile,v 1.4 2012/10/03 18:28:25 asau Exp $
#
DISTNAME= KanjiStrokeOrders_v${KSOVER}
PKGNAME= ${DISTNAME:tl:S/_v/-ttf-/}
CATEGORIES= fonts japanese
MASTER_SITES= https://sites.google.com/site/nihilistorguk/
EXTRACT_SUFX= .zip
MAINTAINER= ryoon@NetBSD.org
HOMEPAGE= https://sites.google.com/site/nihilistorguk/
COMMENT= Japanese Kanji characters stroke order font
LICENSE= modified-bsd
# Force using "curl" for fetching the distribution file. It is only available
# over HTTPS and "curl" is the only fetch program which always supports HTTPS.
FETCH_USING= curl
USE_X11BASE= YES
NO_CONFIGURE= YES
NO_BUILD= YES
KSOVER= 3.000
DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
INSTALLATION_DIRS= lib/X11/fonts/TTF \
${DOCSDIR}
FONTDIR= ${PREFIX}/lib/X11/fonts/TTF
FONTS_DIRS.ttf= ${FONTDIR}
INSTALL_FONTS= KanjiStrokeOrders_v${KSOVER}.ttf
INSTALL_DOCS= KSO_Excel_Sample.pdf \
KSO_PPT_Sample.pdf \
copyright.txt \
readme_en_v${KSOVER}.txt
WRKSRC= ${WRKDIR}
USE_LANGUAGES= # none
do-install:
.for f in ${INSTALL_FONTS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DESTDIR}${FONTDIR}
.endfor
.for f in ${INSTALL_DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DESTDIR}${DOCSDIR}
.endfor
.include "../../mk/bsd.pkg.mk"
CVSweb <webmaster@jp.NetBSD.org>