[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / fonts / intlfonts

File: [cvs.NetBSD.org] / pkgsrc / fonts / intlfonts / Makefile (download)

Revision 1.34, Sun Jun 1 16:35:34 2014 UTC (9 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.33: +3 -3 lines

Move fonts from lib/X11/fonts to share/fonts/X11.

As discussed on tech-pkg.

Bump PKGREVISION.

# $NetBSD: Makefile,v 1.34 2014/06/01 16:35:34 wiz Exp $

DISTNAME=	intlfonts-1.2.1
PKGREVISION=	6
CATEGORIES=	fonts x11
MASTER_SITES=	${MASTER_SITE_GNU:=intlfonts/intlfonts-1.2.1-split/}
# not redundant here -- needed in the DISTFILES line below
EXTRACT_SUFX=	.tar.gz
DISTFILES=	${FONT_SETS:=${EXTRACT_SUFX}} ${MISC_FILES}

MAINTAINER=	pkgsrc-users@NetBSD.org
COMMENT=	Free X11 fonts (BDF format) for all characters that Emacs can handle

FONT_SETS=	Asian		\
		Chinese		\
		Ethiopic	\
		European	\
		Japanese	\
		Misc

USE_TOOLS+=	bdftopcf

# Use the X font set for Korean, as there isn't anything better
FONT_SETS+=	Korean.X

# These are extra files that not many folks will likely need or want
# They are all bigger than 24 dots -- you'll only want them if you
# want to display text in really big fonts.
#
EXTRA_FONTS=	Chinese.BIG	\
		European.BIG	\
		Japanese.BIG

# Type1/TrueType fonts for Latin1, Thai and Vietnamese
# XXX need "fonts.scale" for them
#
EXTRA_FONTS+=	Type1		\
		TrueType
CONFIGURE_ARGS+=	--with-type1 --with-truetype

MISC_FILES=	README.split

DIST_SUBDIR=	${PKGNAME_NOREV}
EXTRACT_ONLY=	${FONT_SETS:=${EXTRACT_SUFX}}

GNU_CONFIGURE=	yes
CONFIGURE_ARGS+=--with-fontdir=${FONTS_DIR} \
		--enable-compress=gzip
INSTALL_MAKE_FLAGS+=	fontdir=${DESTDIR}${FONTS_DIR}

FONTS_DIR=	${PREFIX}/share/fonts/X11/intlfonts

FONTS_DIRS.x11+=	${FONTS_DIR}
FONTS_DIRS.x11+=	${FONTS_DIR}/bdf
FONTS_DIRS.type1+=	${FONTS_DIR}/Type1
FONTS_DIRS.ttf+=	${FONTS_DIR}/TrueType
REQD_DIRS+=		${FONTS_DIR}
REQD_DIRS+=		${FONTS_DIR}/bdf
REQD_DIRS+=		${FONTS_DIR}/Type1
REQD_DIRS+=		${FONTS_DIR}/TrueType

.include "../../mk/bsd.prefs.mk"

.if !defined(NO_EXTRA_FONTS)
FONT_SETS+=	${EXTRA_FONTS}
PLIST_SRC=	PLIST PLIST.extrafonts
.endif

post-extract:
.for file in ${MISC_FILES}
	${CP} ${_DISTDIR}/${file} ${WRKSRC}
.endfor

.include "../../mk/bsd.pkg.mk"