File:
[cvs.NetBSD.org] /
pkgsrc /
fonts /
ghostscript-fonts /
Makefile
Revision
1.18:
download - view:
text,
annotated -
select for diffs
Mon Mar 10 12:34:10 2008 UTC (17 years, 1 month ago) by
wiz
Branches:
MAIN
CVS tags:
pkgsrc-2010Q1-base,
pkgsrc-2010Q1,
pkgsrc-2009Q4-base,
pkgsrc-2009Q4,
pkgsrc-2009Q3-base,
pkgsrc-2009Q3,
pkgsrc-2009Q2-base,
pkgsrc-2009Q2,
pkgsrc-2009Q1-base,
pkgsrc-2009Q1,
pkgsrc-2008Q4-base,
pkgsrc-2008Q4,
pkgsrc-2008Q3-base,
pkgsrc-2008Q3,
pkgsrc-2008Q2-base,
pkgsrc-2008Q2,
pkgsrc-2008Q1-base,
pkgsrc-2008Q1,
cwrapper,
cube-native-xorg-base,
cube-native-xorg,
HEAD
Try removing share/ghostscript directory during uninstall.
Bump PKGREVISION.
# $NetBSD: Makefile,v 1.18 2008/03/10 12:34:10 wiz Exp $
DISTNAME= ghostscript-fonts-8.11
PKGREVISION= 2
CATEGORIES= fonts
MASTER_SITES+= ${MASTER_SITE_SOURCEFORGE:=ghostscript/} \
ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/fonts/
DISTFILES= ${GS_FONTS_STD} ${GS_FONTS_OTHER}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://gs-fonts.sourceforge.net/
COMMENT= Postscript fonts for Aladdin Ghostscript
PKG_DESTDIR_SUPPORT= user-destdir
# Note: the following two are special files. In the 5.50 directory
# on the FTP site, there are symlinks:
# ghostscript-fonts-other-5.50.tar.gz ->
# ../fonts/ghostscript-fonts-other-4.40.tar.gz
# To avoid unnecessarily downloading distfiles, do not change these
# when upgrading the port unless the symlinks/files really change.
#
GS_FONTS_STD= ghostscript-fonts-std-8.11.tar.gz
GS_FONTS_OTHER= ghostscript-fonts-other-6.0.tar.gz
CONFLICTS= ghostscript-[0-5]* ghostscript-x11-[0-5]*
PKG_INSTALLATION_TYPES= overwrite pkgviews
DIST_SUBDIR= ghostscript
NO_CONFIGURE= YES
NO_BUILD= YES
WRKSRC= ${WRKDIR}/fonts
FONTS_DIR= ${PREFIX}/share/ghostscript/fonts
INSTALLATION_DIRS= share/ghostscript/fonts
REQD_DIRS+= share/ghostscript
do-install:
for ext in afm gsf pfa pfb pfm; \
do \
for f in ${WRKSRC}/*.$${ext}; \
do \
${INSTALL_DATA} $${f} ${DESTDIR}${FONTS_DIR}; \
done; \
done
${INSTALL_DATA} ${WRKSRC}/fonts.dir ${DESTDIR}${FONTS_DIR}
${INSTALL_DATA} ${WRKSRC}/fonts.scale ${DESTDIR}${FONTS_DIR}
${INSTALL_DATA} ${FILESDIR}/fonts.alias ${DESTDIR}${FONTS_DIR}
.include "../../mk/bsd.pkg.mk"
CVSweb <webmaster@jp.NetBSD.org>