The NetBSD Project

CVS log for pkgsrc/fonts/fontconfig/buildlink3.mk

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / fonts / fontconfig

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.39 / (download) - annotate - [select for diffs], Mon Aug 17 20:17:25 2020 UTC (15 months, 2 weeks ago) by leot
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, HEAD
Changes since 1.38: +2 -2 lines
Diff to previous 1.38 (colored)

*: revbump after fontconfig bl3 changes (libuuid removal)

Revision 1.38 / (download) - annotate - [select for diffs], Mon Aug 17 15:23:28 2020 UTC (15 months, 2 weeks ago) by leot
Branch: MAIN
Changes since 1.37: +1 -2 lines
Diff to previous 1.37 (colored)

fontconfig: remove libuuid bl3 inclusion in buildlink3.mk

libuuid is marked as a private dependency and it is an implementation
detail.

On some platforms (e.g. NetBSD) by including libuuid bl3 fonts/fontconfig was
unconditionally installed due that.

Problem originally analyzed by <wiz> in:

 <https://mail-index.NetBSD.org/tech-pkg/2019/06/19/msg021438.html>

And change proposed on tech-pkg@:

 <https://mail-index.NetBSD.org/tech-pkg/2020/07/13/msg023550.html>

Thanks to <wiz> also for reviews, suggestions and discussions!

Revision 1.37 / (download) - annotate - [select for diffs], Mon Sep 9 12:22:03 2019 UTC (2 years, 2 months ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.36: +2 -2 lines
Diff to previous 1.36 (colored)

fonts/fontconfig: Bump bl3 API_dEPENDS to 2.11.91

If the base fontconfig is old, and some but not all fontconfig-using
packages need newer, we end up with some binaries having two different
fontconfigs.  Adjust fontconfig's API_DEPENDS to 2.11.91, because
pango needs at least that.  This means that pkgsrc fontconfig will
always be used on netbsd-8.

The only sound approach appears to be a hard choice of system vs
pkgsrc fontconfig, without per-package overrides, but that's a bigger
step.  We could also consider changing API_DEPENDS to match the pkgsrc
fontconfig, so base is only used if newer.

(Needs a revbump.)

As discussed on tech-pkg.

Revision 1.36 / (download) - annotate - [select for diffs], Fri Aug 31 09:06:07 2018 UTC (3 years, 3 months ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.35: +2 -1 lines
Diff to previous 1.35 (colored)

fontconfig: needs libbz2

Revision 1.35 / (download) - annotate - [select for diffs], Sat Mar 31 04:30:33 2018 UTC (3 years, 8 months ago) by schmonz
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.34: +2 -1 lines
Diff to previous 1.34 (colored)

Since fontconfig depends on devel/gettext-lib (as of 2.13.0nb1),
anything depending on fontconfig does too. Add it to buildlink3.mk.
This is a high-impact change to commit during the freeze, but seems both
correct and necessary, and has wiz@'s OK.

Revision 1.34 / (download) - annotate - [select for diffs], Mon Mar 12 11:15:32 2018 UTC (3 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.33: +3 -2 lines
Diff to previous 1.33 (colored)

Recursive bumps for fontconfig and libzip dependency changes.

Revision 1.33 / (download) - annotate - [select for diffs], Tue Jun 4 22:16:02 2013 UTC (8 years, 6 months ago) by tron
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.32: +2 -2 lines
Diff to previous 1.32 (colored)

Try to fix the fallout caused by the fix for PR pkg/47882. Part 3:

Recursively bump package revisions again after the "freetype2" and
"fontconfig" handling was fixed.

Revision 1.32 / (download) - annotate - [select for diffs], Tue Jun 4 08:04:21 2013 UTC (8 years, 6 months ago) by tron
Branch: MAIN
Changes since 1.31: +2 -2 lines
Diff to previous 1.31 (colored)

The API dependency shouldn't contain a package revision.

Revision 1.31 / (download) - annotate - [select for diffs], Mon Jun 3 15:18:40 2013 UTC (8 years, 6 months ago) by tron
Branch: MAIN
Changes since 1.30: +2 -2 lines
Diff to previous 1.30 (colored)

Bump the required API version as well to enforce the new version
at build time.

Revision 1.30 / (download) - annotate - [select for diffs], Mon Jun 3 10:04:56 2013 UTC (8 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.29: +2 -2 lines
Diff to previous 1.29 (colored)

Bump freetype2 and fontconfig dependencies to current pkgsrc versions,
to address issues with NetBSD-6(and earlier)'s fontconfig not being
new enough for pango.

While doing that, also bump freetype2 dependency to current pkgsrc
version.

Suggested by tron in PR 47882

Revision 1.29 / (download) - annotate - [select for diffs], Tue Jul 31 18:12:28 2012 UTC (9 years, 4 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.28: +1 -2 lines
Diff to previous 1.28 (colored)

update to 2.10.1
changes:
* FC_GLOBAL_ADVANCE now deprecated
* Disable non-Unicode SFNT names by default (Use --enable-iconv to
  enable it)
* Available config files has been moved to
  /usr/share/fontconfig/conf.avail
* Warns multiple values of <test>s and <family>s in <match> and <alias>
* Add XDG Base Directory Specification support
* Add FC_LANG environment variable for default substitute language.
* Add more options to configure the installation paths
* Add "namelang" object to obtain the localized name of the family,
  style and fullname.
* Unicode 6.1 support
* CACHEDIR.TAG support
* Fix several build issues with older gcc, MinGW, Win32.
* Fix a fail of creating caches on some filesystems
* Fix memory leaks
* Add/Update orthography files
* Improve documents
* and more bug fixes and enhancements.

pkgsrc changes: some cleanup - install only useful stuff to /etc

Revision 1.28 / (download) - annotate - [select for diffs], Mon May 7 01:53:29 2012 UTC (9 years, 7 months ago) by dholland
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

Set BUILDLINK_ABI_DEPENDS correctly (with +=, not ?=)
It turns out there were a lot of these.

Revision 1.27 / (download) - annotate - [select for diffs], Tue Nov 1 06:01:12 2011 UTC (10 years, 1 month ago) by sbd
Branch: MAIN
CVS Tags: pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4
Changes since 1.26: +2 -1 lines
Diff to previous 1.26 (colored)

Recursive bump for graphics/freetype2 buildlink addition.

Revision 1.26 / (download) - annotate - [select for diffs], Fri Mar 20 19:24:34 2009 UTC (12 years, 8 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1
Changes since 1.25: +6 -13 lines
Diff to previous 1.25 (colored)

Simply and speed up buildlink3.mk files and processing.
This changes the buildlink3.mk files to use an include guard for the
recursive include. The use of BUILDLINK_DEPTH, BUILDLINK_DEPENDS,
BUILDLINK_PACKAGES and BUILDLINK_ORDER is handled by a single new
variable BUILDLINK_TREE. Each buildlink3.mk file adds a pair of
enter/exit marker, which can be used to reconstruct the tree and
to determine first level includes. Avoiding := for large variables
(BUILDLINK_ORDER) speeds up parse time as += has linear complexity.
The include guard reduces system time by avoiding reading files over and
over again. For complex packages this reduces both %user and %sys time to
half of the former time.

Revision 1.25 / (download) - annotate - [select for diffs], Tue Oct 16 18:12:56 2007 UTC (14 years, 1 month ago) by reed
Branch: MAIN
CVS Tags: pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.24: +2 -3 lines
Diff to previous 1.24 (colored)

The ABI and API changed in 2.4.2.
So get rid of BUILDLINK_ABI_DEPENDS.fontconfig.
And increase BUILDLINK_API_DEPENDS.fontconfig to fontconfig>=2.4.2.

Noticed this when using a binary package for qt4-libs built on
different system:

/usr/pkg/qt4/lib/libQtGui.so: undefined reference to `FcFreeTypeQueryFace'

I am not bumping the PKGREVISIONs for all the dependents, since the
upgrade to fontconfig 2.4.2 happened ten months ago.

Revision 1.24 / (download) - annotate - [select for diffs], Sat Jul 8 23:10:49 2006 UTC (15 years, 5 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

Change the format of BUILDLINK_ORDER to contain depth information as well,
and add a new helper target and script, "show-buildlink3", that outputs
a listing of the buildlink3.mk files included as well as the depth at
which they are included.

For example, "make show-buildlink3" in fonts/Xft2 displays:

	zlib
	fontconfig
	    iconv
	    zlib
	    freetype2
	    expat
	freetype2
	Xrender
	    renderproto

Revision 1.23 / (download) - annotate - [select for diffs], Sat Jul 8 22:39:16 2006 UTC (15 years, 5 months ago) by jlam
Branch: MAIN
Changes since 1.22: +2 -1 lines
Diff to previous 1.22 (colored)

Track information in a new variable BUILDLINK_ORDER that informs us
of the order in which buildlink3.mk files are (recursively) included
by a package Makefile.

Revision 1.22 / (download) - annotate - [select for diffs], Wed Apr 12 10:27:15 2006 UTC (15 years, 7 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2006Q2-base, pkgsrc-2006Q2
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

Aligned the last line of the buildlink3.mk files with the first line, so
that they look nicer.

Revision 1.21 / (download) - annotate - [select for diffs], Thu Apr 6 06:21:59 2006 UTC (15 years, 8 months ago) by reed
Branch: MAIN
Changes since 1.20: +3 -3 lines
Diff to previous 1.20 (colored)

Over 1200 files touched but no revisions bumped :)

RECOMMENDED is removed. It becomes ABI_DEPENDS.

BUILDLINK_RECOMMENDED.foo becomes BUILDLINK_ABI_DEPENDS.foo.

BUILDLINK_DEPENDS.foo becomes BUILDLINK_API_DEPENDS.foo.

BUILDLINK_DEPENDS does not change.

IGNORE_RECOMMENDED (which defaulted to "no") becomes USE_ABI_DEPENDS
which defaults to "yes".

Added to obsolete.mk checking for IGNORE_RECOMMENDED.

I did not manually go through and fix any aesthetic tab/spacing issues.

I have tested the above patch on DragonFly building and packaging
subversion and pkglint and their many dependencies.

I have also tested USE_ABI_DEPENDS=no on my NetBSD workstation (where I
have used IGNORE_RECOMMENDED for a long time). I have been an active user
of IGNORE_RECOMMENDED since it was available.

As suggested, I removed the documentation sentences suggesting bumping for
"security" issues.

As discussed on tech-pkg.

I will commit to revbump, pkglint, pkg_install, createbuildlink separately.

Note that if you use wip, it will fail!  I will commit to pkgsrc-wip
later (within day).

Revision 1.20 / (download) - annotate - [select for diffs], Sun Feb 5 23:09:09 2006 UTC (15 years, 10 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

Recursive revision bump / recommended bump for gettext ABI change.

Revision 1.19 / (download) - annotate - [select for diffs], Tue Jan 24 07:32:07 2006 UTC (15 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.18: +2 -2 lines
Diff to previous 1.18 (colored)

Bump BUILDLINK_RECOMMENDED of textproc/expat to 2.0.0 because
of the shlib major bump.
PKGREVISION++ for the dependencies.

Revision 1.18 / (download) - annotate - [select for diffs], Thu Apr 21 17:40:19 2005 UTC (16 years, 7 months ago) by kristerw
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4, pkgsrc-2005Q3-base, pkgsrc-2005Q3, pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.17: +2 -1 lines
Diff to previous 1.17 (colored)

Include converters/libiconv/buildlink3.mk.

Revision 1.17 / (download) - annotate - [select for diffs], Sun Oct 3 00:14:42 2004 UTC (17 years, 2 months ago) by tv
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1, pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.16: +2 -1 lines
Diff to previous 1.16 (colored)

Libtool fix for PR pkg/26633, and other issues.  Update libtool to 1.5.10
in the process.  (More information on tech-pkg.)

Bump PKGREVISION and BUILDLINK_DEPENDS of all packages using libtool and
installing .la files.

Bump PKGREVISION (only) of all packages depending directly on the above
via a buildlink3 include.

Revision 1.16 / (download) - annotate - [select for diffs], Thu Mar 18 09:12:11 2004 UTC (17 years, 8 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3, pkgsrc-2004Q2-base, pkgsrc-2004Q2, pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.15: +2 -3 lines
Diff to previous 1.15 (colored)

Fix serious bug where BUILDLINK_PACKAGES wasn't being ordered properly
by moving the inclusion of buildlink3.mk files outside of the protected
region.  This bug would be seen by users that have set PREFER_PKGSRC
or PREFER_NATIVE to non-default values.

BUILDLINK_PACKAGES should be ordered so that for any package in the
list, that package doesn't depend on any packages to the left of it
in the list.  This ordering property is used to check for builtin
packages in the correct order.  The problem was that including a
buildlink3.mk file for <pkg> correctly ensured that <pkg> was removed
from BUILDLINK_PACKAGES and appended to the end.  However, since the
inclusion of any other buildlink3.mk files within that buildlink3.mk
was in a region that was protected against multiple inclusion, those
dependencies weren't also moved to the end of BUILDLINK_PACKAGES.

Revision 1.15 / (download) - annotate - [select for diffs], Wed Mar 10 17:57:14 2004 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.14: +11 -109 lines
Diff to previous 1.14 (colored)

Split out the code that deals with checking whether the software is
built-in or not into a separate builtin.mk file.  The code to deal
checking for built-in software is much simpler to deal with in pkgsrc.

The buildlink3.mk file for a package will be of the usual format
regardless of the package, which makes it simpler for packagers to
update a package.

The builtin.mk file for a package must define a single yes/no variable
USE_BUILTIN.<pkg> that is used by bsd.buildlink3.mk to decide whether
to use the built-in software or to use the pkgsrc software.

Revision 1.14 / (download) - annotate - [select for diffs], Thu Feb 19 19:12:26 2004 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.13: +3 -5 lines
Diff to previous 1.13 (colored)

Add BUILDLINK_DEPENDS.<pkg> for dependencies in a section that is invoked
only if we're not using the built-in versions of the package.

Revision 1.13 / (download) - annotate - [select for diffs], Thu Feb 19 18:51:01 2004 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.12: +8 -5 lines
Diff to previous 1.12 (colored)

Move the settings, which force the use of builtin versions of dependencies
if the builtin version of the package is being used, into a global
location so that they're always executed.

Revision 1.12 / (download) - annotate - [select for diffs], Wed Feb 18 16:53:52 2004 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.11: +8 -4 lines
Diff to previous 1.11 (colored)

If we're using the built-in version of the software, then we must also
be using built-in versions of any other software pulled in via
buildlink3.mk files.

Revision 1.11 / (download) - annotate - [select for diffs], Wed Feb 18 16:35:27 2004 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.10: +18 -16 lines
Diff to previous 1.10 (colored)

Reorder some lines so that BUILDLINK_USE_BUILTIN.<pkg> set in the
environment overrides all other settings.

Revision 1.10 / (download) - annotate - [select for diffs], Wed Feb 18 14:58:37 2004 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

fontconfig had a really weird version numbering system.  Version 2.0 is
practically verbatim with the "1.0.1" release that's in XFree86 4.3.x.
There have in fact been only function additions to the fontconfig API
since 2.0, so fontconfig has never actually had a bump in the shared
library major.  Therefore, allow "fontconfig>=1.0.1" as the base
requirement.

Revision 1.9 / (download) - annotate - [select for diffs], Tue Feb 17 16:27:54 2004 UTC (17 years, 9 months ago) by jmmv
Branch: MAIN
Changes since 1.8: +2 -1 lines
Diff to previous 1.8 (colored)

When using the native version of this library, symlink the .pc file into
the buildlink directory so that pkg-config can find it.  Ok'ed by jlam@.

Revision 1.8 / (download) - annotate - [select for diffs], Tue Feb 17 14:44:10 2004 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Missing a "=" in the ">=".

Revision 1.7 / (download) - annotate - [select for diffs], Tue Feb 17 09:13:33 2004 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.6: +6 -4 lines
Diff to previous 1.6 (colored)

Don't include other buildlink3.mk files if we're just checking whether the
software is built-in.

Revision 1.6 / (download) - annotate - [select for diffs], Mon Feb 16 22:47:23 2004 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

fontconfig is in the "fonts" category.

Revision 1.5 / (download) - annotate - [select for diffs], Mon Feb 16 19:24:14 2004 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

Typo.

Revision 1.4 / (download) - annotate - [select for diffs], Mon Feb 16 19:16:59 2004 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.3: +97 -8 lines
Diff to previous 1.3 (colored)

Do the dance to check the version of the XFree86-provided fontconfig.
Also correct the list of buildlink2.mk files included by
fontconfig/buildlink2.mk.

Revision 1.3 / (download) - annotate - [select for diffs], Mon Feb 9 20:20:43 2004 UTC (17 years, 10 months ago) by reed
Branch: MAIN
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Raise BUILDLINK_DEPENDS.freetype2 to at least 2.1.3.
Even 2.0.9 is not good enough for newer fontconfig; for example,
gtk2 won't buildlink correctly (and will use older X version of
include/freetype2/freetype/ftbdf.h) and libfontconfig needs
FT_Get_BDF_Property which is not defined.

No PKGREVISION bump is needed, because would not even build in
first place.

Revision 1.2 / (download) - annotate - [select for diffs], Sat Jan 24 03:26:46 2004 UTC (17 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

Append to BUILDLINK_DEPENDS.<pkg> instead of setting a default value.  In
the normal case when BUILDLINK_DEPENDS.<pkg> isn't specified, it receives
a value only once due to the multiple inclusion protection in the
bulldlink3.mk files.  In the case where a package includes several
buildlink3.mk files that each want a slightly different version of another
dependency, having BUILDLINK_DEPENDS.<pkg> be a list allows for the
strictest <pkg> dependency to be matched.

Revision 1.1 / (download) - annotate - [select for diffs], Sat Jan 24 01:57:01 2004 UTC (17 years, 10 months ago) by jlam
Branch: MAIN

bl3ify

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>