The NetBSD Project

CVS log for pkgsrc/finance/py-stripe/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / finance / py-stripe

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.58 / (download) - annotate - [select for diffs], Tue Jun 6 12:41:22 2023 UTC (6 months ago) by riastradh
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, HEAD
Changes since 1.57: +2 -2 lines
Diff to previous 1.57 (colored)

Mass-change BUILD_DEPENDS to TOOL_DEPENDS outside mk/.

Almost all uses, if not all of them, are wrong, according to the
semantics of BUILD_DEPENDS (packages built for target available for
use _by_ tools at build-time) and TOOL_DEPEPNDS (packages built for
host available for use _as_ tools at build-time).

No change to BUILD_DEPENDS as used correctly inside buildlink3.

As proposed on tech-pkg:
https://mail-index.netbsd.org/tech-pkg/2023/06/03/msg027632.html

Revision 1.57 / (download) - annotate - [select for diffs], Thu Oct 13 08:49:12 2022 UTC (13 months, 4 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.56: +2 -2 lines
Diff to previous 1.56 (colored)

py-stripe: updated to 4.2.0

4.2.0 - 2022-09-23
* API Updates
  * Add `upcoming_lines` method to the `Invoice` resource.
  * Update links in documentation to be absolute.
* Add abstract methods for SearchableAPIResource

Revision 1.56 / (download) - annotate - [select for diffs], Mon Aug 22 06:50:21 2022 UTC (15 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.55: +3 -2 lines
Diff to previous 1.55 (colored)

py-stripe: updated to 4.1.0

4.1.0 - 2022-08-19
* API Updates
  * Add support for new resource `CustomerCashBalanceTransaction`
* Add a support section to the readme
* Fix test TestCharge.test_is_saveable().

Revision 1.55 / (download) - annotate - [select for diffs], Fri Aug 19 13:30:17 2022 UTC (15 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.54: +3 -4 lines
Diff to previous 1.54 (colored)

py-stripe: updated to 4.0.2

4.0.2 - 2022-08-03
* Fix issue where auto_paging_iter failed on nested list objects.

4.0.1 - 2022-08-02
* Fix incorrect handling of additional request parameters
  * Fixes issue where using special parameter like `api_key`, `idempotency_key`, `stripe_version`, `stripe_account`, `headers` can cause a `Received unknown parameter error`.

4.0.0 - 2022-08-02

Breaking changes that arose during code generation of the library that we postponed for the next major version. For changes to the SDK, read more detailed description at https://github.com/stripe/stripe-python/wiki/Migration-guide-for-v4. For changes to the Stripe products, read more at https://stripe.com/docs/upgrades#2022-08-01.

"ãú ï" symbol highlights breaking changes.

* API Updates
* Next major release changes
* API Updates. Add Price.create tests.
* API Updates. Use auto-generation for credit_note and invoice methods.

ãú ï Removed
- Removed deprecated `AlipayAccount`, `BitcoinReceiver`, `BitcoinTransaction`, `IssuerFraudRecord`, `Recipient`, `RecipientTransfer`, and  `ThreeDSecure` classes.
- Removed deprecated `Charge.update_dispute` and `Charge.close_dispute` methods that were using legacy REST API endpoint. Prefer [Dispute.modify](https://stripe.com/docs/api/disputes/update?lang=python) and [Dispute.close](https://stripe.com/docs/api/disputes/close?lang=python)
- Removed deprecated `Card.details` method and `CardDetails` resource. The REST API endpoint is not longer supported.
- Removed the deprecated `Source.source_transactions` method. Prefer `SubscriptionItem.list_source_transactions`
- Removed the deprecated `SubscriptionItem.usage_record_summaries` method. Prefer `SubscriptionItem.list_usage_record_summaries`
- Removed the deprecated `Charge.refund` method. Prefer [Refund.create](https://stripe.com/docs/api/refunds/create)

ãú ï Changed
- To be consistent with other resource methods, `ApplicationFee.refund` returns an instance of `ApplicationFee` and doesn't mutate the instance of `ApplicationFee`.
- To be consistent with other resource methods, the `Customer.delete_discount` no longer resets the `discount` property to `None` and returns the deleted discount instead. If you were relying on this behavior, reset the discount property manually:
- The `LineItem` resource now inherits from `StripeObject` as it has no methods of it's own.
- To be consistent with other resource methods, the `Subscription.delete_discount` returns an instance of deleted discount and doesn't mutate the instance of `Subscription`.
- Update the CA certificate bundle.
- Request sending logic unified across standard and custom methods (https://github.com/stripe/stripe-python/pull/832)

Revision 1.54 / (download) - annotate - [select for diffs], Fri Jul 8 14:32:11 2022 UTC (17 months ago) by wiz
Branch: MAIN
Changes since 1.53: +9 -5 lines
Diff to previous 1.53 (colored)

py-stripe: update to 3.5.0.

## 3.5.0 - 2022-06-30
* [#831](https://github.com/stripe/stripe-python/pull/831) API Updates
  * Add support for `deliver_card`, `fail_card`, `return_card`, and `ship_card` test helper methods on resource `Issuing.Card`
  * Switch from using `instance_url` to computing method path in place for custom methods.
  * Switch from using explicit class methods for test helpers instead of using meta-programming.

## 3.4.0 - 2022-06-17
* [#824](https://github.com/stripe/stripe-python/pull/824) API Updates
  * Add support for `fund_cash_balance` test helper method on resource `Customer`
* [#823](https://github.com/stripe/stripe-python/pull/823) Trigger workflows on beta branches

## 3.3.0 - 2022-06-08
* [#818](https://github.com/stripe/stripe-python/pull/818) fix: Update cash balance methods to no longer require nested ID.

## 3.2.0 - 2022-05-23
* [#812](https://github.com/stripe/stripe-python/pull/812) API Updates
  * Add support for new resource `Apps.Secret`

## 3.1.0 - 2022-05-19
* [#810](https://github.com/stripe/stripe-python/pull/810) API Updates
  * Add support for new resources `Treasury.CreditReversal`, `Treasury.DebitReversal`, `Treasury.FinancialAccountFeatures`, `Treasury.FinancialAccount`, `Treasury.FlowDetails`, `Treasury.InboundTransfer`, `Treasury.OutboundPayment`, `Treasury.OutboundTransfer`, `Treasury.ReceivedCredit`, `Treasury.ReceivedDebit`, `Treasury.TransactionEntry`, and `Treasury.Transaction`
  * Add support for `retrieve_payment_method` method on resource `Customer`
  * Add support for `list_owners` and `list` methods on resource `FinancialConnections.Account`
* [#719](https://github.com/stripe/stripe-python/pull/719) Set daemon attribute instead of using setDaemon method that was deprecated in Python 3.10
* [#767](https://github.com/stripe/stripe-python/pull/767) Bump vendored six to 1.16.0
* [#806](https://github.com/stripe/stripe-python/pull/806) Start testing on pypy-3.8
* [#811](https://github.com/stripe/stripe-python/pull/811) Add sanitize_id method


## 3.0.0 - 2022-05-09
* [#809](https://github.com/stripe/stripe-python/pull/809) Release of major version v3.0.0. The [migration guide](https://github.com/stripe/stripe-python/wiki/Migration-Guide-for-v3) contains more information.
  (ãú ï = breaking changes):
  * ãú ï Replace the legacy `Order` API with the new `Order` API.
    * New methods: `cancel`, `list_line_items`, `reopen`, and `submit`
    * Removed methods: `pay` and `return_order`
    * Removed resources: `OrderItem` and `OrderReturn`
  * ãú ï Rename `financial_connections.account.refresh` to `financial_connections.refresh_account`
  * Add support for `amount_discount`, `amount_tax`, and `product` on `LineItem`

## 2.76.0 - 2022-05-05
* [#808](https://github.com/stripe/stripe-python/pull/808) API Updates
  * Add support for new resources `FinancialConnections.AccountOwner`, `FinancialConnections.AccountOwnership`, `FinancialConnections.Account`, and `FinancialConnections.Session`

## 2.75.0 - 2022-05-03
* [#805](https://github.com/stripe/stripe-python/pull/805) API Updates
  * Add support for new resource `CashBalance`

Revision 1.53 / (download) - annotate - [select for diffs], Sun Apr 24 17:11:31 2022 UTC (19 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.52: +2 -2 lines
Diff to previous 1.52 (colored)

py-stripe: updated to 2.74.0

2.74.0
* API Updates
  * Add support for `expire` test helper method on resource `Refund`

Revision 1.52 / (download) - annotate - [select for diffs], Thu Apr 21 07:54:15 2022 UTC (19 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.51: +2 -2 lines
Diff to previous 1.51 (colored)

py-stripe: updated to 2.73.0

2.73.0 - 2022-04-18
* API Updates
  * Add support for new resources `FundingInstructions` and `Terminal.Configuration`

Revision 1.51 / (download) - annotate - [select for diffs], Mon Apr 18 10:59:58 2022 UTC (19 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.50: +2 -2 lines
Diff to previous 1.50 (colored)

py-stripe: updated to 2.72.0

2.72.0
API Updates
- Add support for increment_authorization method on resource PaymentIntent

Revision 1.50 / (download) - annotate - [select for diffs], Mon Apr 11 16:35:27 2022 UTC (20 months ago) by adam
Branch: MAIN
Changes since 1.49: +2 -2 lines
Diff to previous 1.49 (colored)

py-stripe: updated to 2.71.0

2.71.0 - 2022-04-08
* API Updates
  * Add support for `apply_customer_balance` method on resource `PaymentIntent`

Revision 1.49 / (download) - annotate - [select for diffs], Thu Mar 31 07:24:00 2022 UTC (20 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.48: +2 -2 lines
Diff to previous 1.48 (colored)

py-stripe: updated to 2.70.0

2.70.0 - 2022-03-30
* API Updates
  * Add support for `cancel_action`, `process_payment_intent`, `process_setup_intent`, and `set_reader_display` methods on resource `Terminal.Reader`

Revision 1.48 / (download) - annotate - [select for diffs], Wed Mar 30 07:14:50 2022 UTC (20 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.47: +2 -2 lines
Diff to previous 1.47 (colored)

py-stripe: updated to 2.69.0

2.69.0 - 2022-03-29
* API Updates
  * Add support for Search API
    * Add support for `search` method on resources `Charge`, `Customer`, `Invoice`, `PaymentIntent`, `Price`, `Product`, and `Subscription`
* Pin click dependency to 8.0.4 to avoid breakage in black
* Add infrastructure for test-helper methods
* Revert Orders to use qualified name for upload_api_base

2.68.0 - 2022-03-23
* API Updates
  * Add support for `cancel` method on resource `Refund`
* Add support for SearchResult.

Revision 1.47 / (download) - annotate - [select for diffs], Tue Mar 15 06:01:19 2022 UTC (20 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.46: +2 -2 lines
Diff to previous 1.46 (colored)

py-stripe: updated to 2.67.0

2.67.0
* Add support for new resource `TestHelpers.TestClock`

Revision 1.46 / (download) - annotate - [select for diffs], Sun Feb 27 09:05:25 2022 UTC (21 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.45: +2 -2 lines
Diff to previous 1.45 (colored)

py-stripe: updated to 2.66.0

2.66.0:
Add support for `verify_microdeposits` method on resources `PaymentIntent` and `SetupIntent`

Revision 1.45 / (download) - annotate - [select for diffs], Sun Jan 23 19:14:56 2022 UTC (22 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.44: +2 -3 lines
Diff to previous 1.44 (colored)

py-stripe: updated to 2.65.0

2.65.0
* API Updates
* Add support for new resource `PaymentLink`
* Start testing Python 3.10

Revision 1.44 / (download) - annotate - [select for diffs], Tue Jan 4 20:53:54 2022 UTC (23 months ago) by wiz
Branch: MAIN
Changes since 1.43: +2 -1 lines
Diff to previous 1.43 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.43 / (download) - annotate - [select for diffs], Thu Dec 30 20:41:18 2021 UTC (23 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.42: +2 -2 lines
Diff to previous 1.42 (colored)

py-stripe: updated to 2.64.0

2.64.0
Update class custom methods to save list object parameters.
Introduce custom listing methods on objects.
Clarify metadata deletion message.

Revision 1.42 / (download) - annotate - [select for diffs], Wed Nov 17 13:51:55 2021 UTC (2 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.41: +2 -2 lines
Diff to previous 1.41 (colored)

py-stripe: updated to 2.63.0

2.63.0
* Add support for new resource `ShippingRate`

Revision 1.41 / (download) - annotate - [select for diffs], Fri Nov 12 10:22:57 2021 UTC (2 years ago) by adam
Branch: MAIN
Changes since 1.40: +2 -2 lines
Diff to previous 1.40 (colored)

py-stripe: updated to 2.62.0

2.62.0:
* Add support for `expire` method on resource `Checkout.Session`

Revision 1.40 / (download) - annotate - [select for diffs], Tue Oct 12 09:27:46 2021 UTC (2 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.39: +2 -2 lines
Diff to previous 1.39 (colored)

py-stripe: updated to 2.61.0

2.61.0
* API Updates
* Add support for `list_payment_methods` method on resource `Customer`
* Stop sending raw exception message as part of Stripe user agent.

Revision 1.39 / (download) - annotate - [select for diffs], Fri Jul 16 06:40:15 2021 UTC (2 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.38: +2 -2 lines
Diff to previous 1.38 (colored)

py-stripe: updated to 2.60.0

2.60.0:
* Add support for `list_computed_upfront_line_items` method on resource `Quote`

Revision 1.38 / (download) - annotate - [select for diffs], Sat Jul 10 05:44:21 2021 UTC (2 years, 5 months ago) by adam
Branch: MAIN
Changes since 1.37: +2 -2 lines
Diff to previous 1.37 (colored)

py-stripe: updated to 2.59.0

2.59.0:
Add support for new `Quote` API.

Revision 1.37 / (download) - annotate - [select for diffs], Sat Jun 5 07:09:27 2021 UTC (2 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.36: +2 -2 lines
Diff to previous 1.36 (colored)

py-stripe: updated to 2.58.0

2.58.0:
* Add support for new `TaxCode` API.

Revision 1.36 / (download) - annotate - [select for diffs], Thu May 20 12:56:01 2021 UTC (2 years, 6 months ago) by adam
Branch: MAIN
Changes since 1.35: +2 -2 lines
Diff to previous 1.35 (colored)

py-stripe: updated to 2.57.0

2.57.0
* Add support for Identity VerificationSession and VerificationReport APIs

Revision 1.35 / (download) - annotate - [select for diffs], Tue Feb 23 11:43:30 2021 UTC (2 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.34: +2 -2 lines
Diff to previous 1.34 (colored)

py-stripe: updated to 2.56.0

2.56.0
Add support for the Billing Portal Configuration API

Revision 1.34 / (download) - annotate - [select for diffs], Sun Feb 7 12:39:59 2021 UTC (2 years, 10 months ago) by adam
Branch: MAIN
Changes since 1.33: +2 -2 lines
Diff to previous 1.33 (colored)

py-stripe: updated to 2.55.2

2.55.2:
Fix CA bundle path issue

Revision 1.33 / (download) - annotate - [select for diffs], Wed Dec 2 19:58:14 2020 UTC (3 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.32: +3 -3 lines
Diff to previous 1.32 (colored)

py-stripe: updated to 2.55.1

2.55.1:
Fix issue where StripeObjects in lists would not be converted to dicts
Start testing Python 3.9
Include the examples in the built sources

Revision 1.32 / (download) - annotate - [select for diffs], Thu Oct 15 13:44:39 2020 UTC (3 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.31: +2 -2 lines
Diff to previous 1.31 (colored)

py-stripe: updated to 2.55.0

2.55.0:
Add support for the Payout Reverse API

Revision 1.31 / (download) - annotate - [select for diffs], Wed Sep 30 06:52:40 2020 UTC (3 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.30: +2 -2 lines
Diff to previous 1.30 (colored)

py-stripe: updated to 2.54.0

2.54.0:
Add support for the `SetupAttempt` resource and List API

Revision 1.30 / (download) - annotate - [select for diffs], Tue Sep 29 18:45:33 2020 UTC (3 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.29: +2 -2 lines
Diff to previous 1.29 (colored)

py-stripe: updated to 2.53.0

2.53.0:
Unknown changes

Revision 1.29 / (download) - annotate - [select for diffs], Tue Sep 8 17:44:37 2020 UTC (3 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.28: +2 -2 lines
Diff to previous 1.28 (colored)

py-stripe: updated to 2.51.0

2.51.0:
Add support for the Issuing Dispute Submit API

Revision 1.28 / (download) - annotate - [select for diffs], Fri Aug 21 07:55:10 2020 UTC (3 years, 3 months ago) by adam
Branch: MAIN
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

py-stripe: updated to 2.50.0

2.50.0
* Add support for the `PromotionCode` resource and APIs

Revision 1.27 / (download) - annotate - [select for diffs], Tue Jul 21 21:20:35 2020 UTC (3 years, 4 months ago) by adam
Branch: MAIN
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

py-stripe: updated to 2.49.0

2.49.0:
Support stripe.File.create(stripe_version='...')

Revision 1.26 / (download) - annotate - [select for diffs], Sat May 16 17:42:42 2020 UTC (3 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.25: +4 -2 lines
Diff to previous 1.25 (colored)

pytest from versioned depends

Revision 1.25 / (download) - annotate - [select for diffs], Tue May 12 06:51:27 2020 UTC (3 years, 7 months ago) by adam
Branch: MAIN
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

py-stripe: updated to 2.48.0

2.48.0:
Add support for the `LineItem` resource and APIs

Revision 1.24 / (download) - annotate - [select for diffs], Thu Apr 30 06:42:19 2020 UTC (3 years, 7 months ago) by adam
Branch: MAIN
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

py-stripe: updated to 2.47.0

2.47.0:
Add support for the `Price` resource and APIs

Revision 1.23 / (download) - annotate - [select for diffs], Thu Apr 23 05:53:33 2020 UTC (3 years, 7 months ago) by adam
Branch: MAIN
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

py-stripe: updated to 2.46.0

2.46.0:
Add support for `billing_portal` namespace and `Session` resource and APIs

Revision 1.22 / (download) - annotate - [select for diffs], Sat Apr 11 07:41:48 2020 UTC (3 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

py-stripe: updated to 2.45.0

2.45.0:
Add support for Express links in `authorize_url` for `OAuth`

Revision 1.21 / (download) - annotate - [select for diffs], Tue Mar 24 07:01:39 2020 UTC (3 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

py-stripe: updated to 2.44.0

2.44.0:
Allow overriding API key in OAuth methods

Revision 1.20 / (download) - annotate - [select for diffs], Tue Mar 3 19:04:40 2020 UTC (3 years, 9 months ago) by adam
Branch: MAIN
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

py-stripe: updated to 2.43.0

2.43.0:
* Add support for listing Checkout `Session`

Revision 1.19 / (download) - annotate - [select for diffs], Sat Feb 1 20:21:25 2020 UTC (3 years, 10 months ago) by adam
Branch: MAIN
Changes since 1.18: +2 -2 lines
Diff to previous 1.18 (colored)

py-stripe: updated to 2.42.0

2.42.0:
* Add support for `CreditNoteLineItem`
* Pin black version
* Start testing Python 3.8

Revision 1.18 / (download) - annotate - [select for diffs], Wed Jan 8 11:19:03 2020 UTC (3 years, 11 months ago) by adam
Branch: MAIN
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

py-stripe: updated to 2.41.1

2.41.1:
* Fix uploading files with Unicode names (Python 2.7)
* Update Python API docs inline link
* Update `proxy.py`

2.41.0:
* Add support for `CreditNote` preview

2.40.0:
* Add list_usage_record_summaries and list_source_transactions

2.39.0:
* Add support for `Mandate`

2.38.0:
* Add support for reverse pagination
* Contributor Convenant

2.37.2:
* Implement support for stripe-should-retry and retry-after headers

2.37.1:
* Check that `error` is a dict before trying to use it to create a `StripeError`

2.37.0:
* Add `ErrorObject` to `StripeError` exceptions
* Pass `CFLAGS` and `LDFLAGS` when running tests

2.36.2:
* Use `OrderedDict` to maintain key order in API requests and responses

2.36.1:
* Use `ListObject` properties as default values in request methods

2.36.0:
* Add support for header parameters in `ListObject` request methods

Revision 1.17 / (download) - annotate - [select for diffs], Mon Aug 26 14:26:43 2019 UTC (4 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

py-stripe: updated to 2.35.1

2.35.1:
* Fix automatic retries of failed requests
* Clarify what `max_network_retries` does

2.35.0:
* Add `SubscriptionItem.create_usage_record` method

2.34.0:
* Remove subscription schedule revisions
  - This is technically a breaking change. We've chosen to release it as a minor vesion bump because the associated API is unused.

2.33.2:
* Add support for passing full objects instead of IDs to custom methods
* Bump vendored six to latest version

2.33.1:
* Fix `del` statement to not raise `KeyError`

2.33.0:
* Listing `BalanceTransaction` objects now uses `/v1/balance_transactions` instead of `/v1/balance/history`

2.32.1:
* Fix argument name conflict

2.32.0:
* Add support for the `SetupIntent` resource and APIs

2.31.0:
* Enable request latency telemetry by default

2.30.1:
* Fix support for `CustomerBalanceTransaction`

2.30.0:
* Add support for `CustomerBalanceTransaction` resource and APIs

2.29.4:
* Remove Poetry and reinstate `setup.py`

2.29.3:
Version 2.29.2 was non-functional due to a bugged `version.py` file. This release is identical to 2.29.2 save for the version number.

2.29.2:
* Replace pipenv with poetry

2.29.1:
* Verify signatures before deserializing events

2.29.0:
* Add support for `radar.early_fraud_warning` resource

2.28.2:
* Fix a few more code quality issues

2.28.1:
* Fix a few code quality issues

2.28.0:
* Add support for the `Capability` resource and APIs

Revision 1.16 / (download) - annotate - [select for diffs], Thu Apr 25 05:06:20 2019 UTC (4 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

py-stripe: updated to 2.27.0

2.27.0:
* Add support for the TaxRate resource and APIs

2.26.0:
* Add support for the TaxId resource and APIs

2.25.0:
* Add support for the CreditNote resource and APIs

2.24.1:
* Fix encoding of nested parameters in multipart requests

2.24.0:
* Add delete class method on deletable API resources
* Add class methods for all custom API requests (e.g. Charge.capture)

2.23.0:
* Add support for the PaymentMethod resource and APIs
* Add support for retrieving a Checkout Session
* Add support for deleting a Terminal Location and Reader

2.22.0:
* Add stripe.util.convert_to_dict method for converting StripeObject instances to regular dicts

2.21.0:
* Add support for subscription schedules

2.20.3:
* Fix client telemetry implementation

2.20.2:
* Fix session initialization for multi-threaded environments

2.20.1:
* Make RequestsClient thread-safe

2.20.0:
* Reuse the default HTTP client by default

2.19.0:
* Rename CheckoutSession to Session and move it under the checkout namespace. This is a breaking change, but we've reached out to affected merchants and all new merchants would use the new approach.

2.18.1:
* Properly serialize individual on Account objects

Revision 1.15 / (download) - annotate - [select for diffs], Tue Jan 15 19:14:07 2019 UTC (4 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.14: +8 -4 lines
Diff to previous 1.14 (colored)

py-stripe: updated to 2.18.0

2.18.0:
* Add configurable telemetry to gather information on client-side request latency

2.17.0:
* Add support for Checkout sessions

2.16.0:
* Add support for account links

2.15.0:
* Add support for providing custom CA certificate bundle

2.14.0:
* Add support for Review for Radar

2.13.0:
* Add support for ValueList and ValueListItem for Radar

2.12.1:
* Make StripeResponse a new-style class

2.12.0:
* Add new API endpoints for the Invoice resource.

2.11.1:
* Bump minimum requests version to 2.20.0 (for [CVE-2018-18074](https://nvd.nist.gov/vuln/detail/CVE-2018-18074))

2.11.0:
* Add support for the Person resource
* Add support for the WebhookEndpoint resource

2.10.1:
* Correct behavior of stripe.max_network_retries if it's reset after initial use

2.10.0:
* Add support for Stripe Terminal

2.9.0:
* Rename FileUpload to File

2.8.1:
* Don't URL-encode square brackets
* Integer-index encode all arrays

2.8.0:
* Add support for automatic network retries

2.7.0:
* Add support for reporting resources

2.6.0:
* Add support for usage record summaries

2.5.0:
* Remove unsupported Bitcoin endpoints (this is technically a breaking change, but we're releasing as a minor version because none of these APIs were usable anyway)

2.4.0:
* Add cancel support for topups
* Add support for file links

2.3.0:
* Add support for Sigma scheduled query run objects

2.2.0:
* Add support for Stripe Issuing

2.1.0:
* Add InvoiceLineItem class

2.0.3:
* Internal improvements to ApiResource.class_url

2.0.2:
* Avoid duplicate dependency on requests with Python 2.7

2.0.1:
* Fix setup.py

2.0.0:
Major version release. List of backwards incompatible changes to watch out for:
* The minimum Python versions are now 2.7 / 3.4. If you're using Python 2.6 or 3.3, consider upgrading to a more recent version.
* Stripe exception classes should now be accessed via stripe.error rather than just stripe
* Some older deprecated methods have been removed
* Trying to detach an unattached source will now raise a stripe.error.InvalidRequestError exception instead of a NotImplementedError exception

Pull requests included in this release:
* Drop support for Python 2.6 and 3.3
* Use py.test for tests
* Remove deprecated code
* Remove util.json and use json module directly everywhere
* Update setup.py and test flow
* Use pipenv
* Change exception when detaching unattached sources from NotImplementedError to stripe.error.InvalidRequestError

Revision 1.14 / (download) - annotate - [select for diffs], Thu Oct 12 08:06:47 2017 UTC (6 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

py-stripe: update to 1.67.0

1.67.0:
* Rename source `delete` to `detach` (and deprecate the former)

Revision 1.13 / (download) - annotate - [select for diffs], Tue Oct 10 12:23:24 2017 UTC (6 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

py-stripe: update to 1.66.0

1.66.0:
* Support length reads on list objects

Revision 1.12 / (download) - annotate - [select for diffs], Sat Sep 16 19:26:51 2017 UTC (6 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Reset maintainer

Revision 1.11 / (download) - annotate - [select for diffs], Sat Jul 9 13:03:47 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.10: +1 -6 lines
Diff to previous 1.10 (colored)

Remove python33: adapt all packages that refer to it.

Revision 1.10 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:32 2016 UTC (7 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

Switch to MASTER_SITES_PYPI.

Revision 1.9 / (download) - annotate - [select for diffs], Wed Apr 1 03:13:10 2015 UTC (8 years, 8 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

=== 1.22.1 2015-03-30
* Pass `stripe_account` to Balance.retrieve
=== 1.22.0 2015-03-22
* Added methods for updating and saving arrays of objects
=== 1.21.0 2015-02-19
* Added Bitcoin Receiver update and delete methods
=== 1.20.2 2015-01-21
* Remove support for top-level bitcoin transactions
=== 1.20.1 2015-01-07
* Adding bitcoin receiver and transaction objects
=== 1.20.0 2014-12-23
* Adding support for file uploads resource

Revision 1.8 / (download) - annotate - [select for diffs], Sun Oct 26 23:46:15 2014 UTC (9 years, 1 month ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Updated to latest stable, 1.19.1. Removed blacklist files from PLIST From
CHANGELOG:

=== 1.19.1 2014-10-23
* Application Fee refunds now a list instead of array

Revision 1.7 / (download) - annotate - [select for diffs], Thu Aug 7 02:05:28 2014 UTC (9 years, 4 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

=== 1.19.0 2014-07-26

* Application Fee refunds now a list instead of array

Revision 1.6 / (download) - annotate - [select for diffs], Wed Jul 16 12:19:57 2014 UTC (9 years, 4 months ago) by rodent
Branch: MAIN
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

=== 1.18.0 2014-06-17

* Add metadata for disputes and refunds

Revision 1.5 / (download) - annotate - [select for diffs], Sun Jun 15 15:34:12 2014 UTC (9 years, 5 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

=== 1.17.0 2014-06-10
* Remove official support for Python 2.5

Revision 1.4 / (download) - annotate - [select for diffs], Sun Jun 1 01:06:24 2014 UTC (9 years, 6 months ago) by rodent
Branch: MAIN
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

=== 1.16.0 2014-05-28

* Support for canceling transfers

=== 1.15.1 2014-05-21

* Support cards for recipients.

=== 1.14.1 2014-05-19

* Disable loading the ssl module on the Google App Engine dev server.

Revision 1.3 / (download) - annotate - [select for diffs], Sat May 3 13:23:52 2014 UTC (9 years, 7 months ago) by rodent
Branch: MAIN
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Updated to latest version 1.14.0. No changelog, but there's a certificate
blacklist feature and testing thereof now.

Revision 1.2 / (download) - annotate - [select for diffs], Mon Apr 7 00:39:08 2014 UTC (9 years, 8 months ago) by rodent
Branch: MAIN
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

Update to latest release, 1.12.2. From CHANGELOG:

=== 1.12.2 2014-03-13

* Fix syntax errors in setup.py metadata

=== 1.12.1 2014-03-13

* Added license and other metadata in setup.py
* Fix `__repr__` in Python 3
* Support pickling of responses

Revision 1.1 / (download) - annotate - [select for diffs], Thu Feb 20 00:08:13 2014 UTC (9 years, 9 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1

Import py27-stripe-1.12.0 as finance/py-stripe.

Stripe python bindings.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>