The NetBSD Project

CVS log for pkgsrc/finance/py-python-bitcoinlib/Attic/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / finance / py-python-bitcoinlib

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.6, Mon Nov 25 18:24:49 2019 UTC (4 years ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.5: +1 -1 lines
FILE REMOVED

py-bitcoinlib: updated to 0.10.2

v0.10.2
Note: this will be the last release of python-bitcoinlib with Python 2.7 compatibility.

New RPC generatetoaddress(self,numblocks,addr).
Fixed Python 2.7 incompatibility.
Various OpenSSL fixes, including a memory leak.

v0.10.1
Identical in every way to v0.10.0, but re-uploaded under a new version to fix a PyPi issue.

v0.10.0
Minor breaking change: RPC port for regtest updated to the new v0.16.0 default.

Other changes:
Now looks for .cookie files in the datadir, if specified.
Authentication in a RPC service_url is now parsed.
Implemented bip-0037 version message.
contrib/verify-commits/ removed for now due to breakage.

v0.9.0
Now supports segwit, which breaks the API in minor ways from v0.8.0. This version introduces lots of new API functionality related to this, such as the new CScriptWitness, CTxInWitness, CTxWitness, new segwit-specific logic in SignatureHash() etc.

v0.8.0
Major breaking API change!

While this interim release doesn't by itself include segwit support, it does change the name of the CTransaction/CMutableTransaction method GetHash() to GetTxid() to prepare for a future segwit-enabled release. Incorrect calls to GetHash() will now raise a AttributeError exception with an explanation.

Since this release doesn't yet include segwit support, you will need to set the Bitcoin Core -rpcserialversion=0 option, either as a command line argument, or in your bitcoin.conf file. Otherwise the RPC interface will return segwit-serialized transactions that this release's RPC support doesn't understand.

Other changes:
Cookie file RPC authentication is now supported.
msg_header now correctly uses CBlockHeader rather than CBlock.
RPC getbalance now supports include_watchonly
RPC unlockwallet is now supported

v0.7.0
Breaking API changes:
The 'cooked' CScript iterator now returns OP_0 for the empty binary string rather than b''

The alias JSONRPCException = JSONRPCError has been removed. This alias was added for compatibility with v0.4.0 of python-bitcoinlib.

Where appropriate, RPC_INVALID_ADDRESS_OR_KEY errors are now caught properly, which means that rather than raising IndexError, RPC commands such as getblock may raise JSONRPCError instead. For instance during initial startup previously python-bitcoinlib would incorrectly raise IndexError rather than letting the callee know that RPC was unusable. Along those lines, JSONRPCError subclasses have been added for some (but not all!) of the types of RPC errors Bitcoin Core returns.

Bugfixes:
Fixed a spurious AttributeError when bitcoin.rpc.Proxy() fails.

v0.6.1
New features:
getblockheader RPC call now supports the verbose option; there's no other way to get the block height, among other things, from the RPC interface.
subtoaddress and sendmany RPC calls now support comment and subtractfeefromamount arguments.

v0.6.0
Breaking API changes:
RPC over SSL support removed to match Bitcoin Core's removal of RPC SSL support in v0.12.0 If you need this, use an alternative such as a stunnel or a SSH tunnel.

Removed SCRIPT_VERIFY constants bitcoin.core.script, leaving just the constants in bitcoin.core.scripteval; being singletons the redundant constants were broken anyway.

SCRIPT_VERIFY_EVEN_S renamed to SCRIPT_VERIFY_LOW_S to match Bitcoin Core's naming

SCRIPT_VERIFY_NOCACHE removed as Bitcoin Core no longer has it (and we never did anything with it anyway)

v0.5.1
Various small bugfixes; see git history.

New features:
New RPC calls: fundrawtransaction, generate, getblockheader
OP_CHECKLOCKTIMEVERIFY opcode constant

v0.5.0
Major fix: Fixed OpenSSL related crashes on OSX and Arch Linux. Big thanks to everyone who helped fix this!

Breaking API changes:
Proxy no longer has __getattr__ to support arbitrary methods. Use RawProxy or Proxy.call instead. This allows new wrappers to be added safely. See docstrings for details.
New features:

New RPC calls: getbestblockhash, getblockcount, getmininginfo
Signing and verification of Bitcoin Core compatible messages. (w/ pubkey recovery)
Tox tests
Sphinx docs

Notable bugfixes:
getinfo() now works where disablewallet=1

v0.4.0
Major fix: OpenSSL 1.0.1k rejects non-canonical DER signatures, which Bitcoin Core does not, so we now canonicalize signatures prior to passing them to OpenSSL. Secondly we now only generate low-S DER signatures as per BIP62.

API changes that might break compatibility with existing code:

MAX_MONEY is now a core chain parameter
MainParams now inherits from CoreMainParams rather than CoreChainParams
str() now returns hash:n format; previously was same as repr()
RawProxy() no longer has _connection parameter

Notable bugfixes:
MsgSerializable.to_bytes() no longer clobbers testnet params
HTTPS RPC connections now use port 443 as default
No longer assumes bitcoin.conf specifes rpcuser

New features:
New RPC calls: dumpprivkey, importaddress
Added P2P support for msg_notfound and msg_reject
Added support for IPv6 addr messages

Revision 1.5 / (download) - annotate - [select for diffs], Tue Nov 3 00:12:13 2015 UTC (8 years, 1 month ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.4: +2 -1 lines
Diff to previous 1.4 (colored)

Add SHA512 digests for distfiles for finance category

Existing SHA1 digests verified, all found to be the same on the
machine holding the existing distfiles (morden).  Existing SHA1
digests retained for now as an audit trail.

Revision 1.4 / (download) - annotate - [select for diffs], Wed Apr 1 02:53:12 2015 UTC (8 years, 8 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.3: +4 -4 lines
Diff to previous 1.3 (colored)

Update to 0.3.0. No nicely condensed changelog for stickler package
managers to love. From the repo:

Merge pull request #59
Merge pull request #50
Encourage running unittests on py3 as well
Fix release notes __all__ formatting

Revision 1.3 / (download) - annotate - [select for diffs], Sun Oct 5 20:21:30 2014 UTC (9 years, 1 month ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.2: +4 -4 lines
Diff to previous 1.2 (colored)

v0.2.1

    Improve bitcoin address handling. P2SH and P2PKH addresses now get their own classes - P2SHBitcoinAddress and P2PKHBitcoinAddress respectively - and P2PKH can now convert scriptPubKeys containing non-canonical pushes as well as bare checksig to addresses.
    .deserialize() methods now fail if there is extra data left over.
    Various other small bugfixes.
    License is now LGPL v3 or later.

v0.2.0

Major change: CTransaction, CBlock, etc. now come in immutable (default) and mutable forms. In most cases mutable and immutable can be used interchangeably; when that is not possible methods are provided to create new (im)mutable objects from (im)mutable ones efficiently.

Other changes:

    New BIP70 payment protocol example. (Derren Desouza)
    Rework of message serialization. Note that this may not represent the final form of P2P support, which is still in flux. (Florian Schmaus)
    Various bugfixes

Finally starting this release, git tags will be of the form 'python-bitcoinlib-(version)', replacing the less specific '(version)' form previously used.

Revision 1.2 / (download) - annotate - [select for diffs], Tue May 13 02:39:11 2014 UTC (9 years, 6 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.1: +4 -4 lines
Diff to previous 1.1 (colored)

Package was uploaded to pypi. Thus, we can simplify the Makefile. Change in
this version was:

Fix CECKey.sign() handling of invalid hashes

Revision 1.1 / (download) - annotate - [select for diffs], Thu May 8 10:14:10 2014 UTC (9 years, 6 months ago) by rodent
Branch: MAIN

Import py27-python-bitcoinlib-0.1 as finance/py-python-bitcoinlib.

This Python2/3 library provides an easy interface to the bitcoin data structures
and protocol. The approach is low-level and "ground up", with a focus on
providing tools to manipulate the internals of how Bitcoin works.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>