File:  [cvs.NetBSD.org] / pkgsrc / finance / py-braintree / Makefile
Revision 1.53: download - view: text, annotated - select for diffs
Fri Jan 12 13:20:52 2024 UTC (13 months ago) by adam
Branches: MAIN
CVS tags: HEAD
py-braintree: updated to 4.26.0

4.26.0

Remove usage of standard library deprecated cgi module. Note: this will break integrations on versions of Python below 3.2. However, this is NOT a breaking change to this library, due to our current support of Python 3.5+.
Add PackageDetails class.
Add packages to Transaction attributes.
Add package_tracking method to TransactionGateway to make request to add tracking information to transactions.
Add process_debit_as_credit to credit_card field in options field during Transaction create.
Deprecate three_d_secure_token in favor of three_d_secure_authentication_id
Add upc_code, upc_type, and image_url to line_items in transaction
Deprecate venmo_sdk_session and venmo_sdk_payment_method_code

# $NetBSD: Makefile,v 1.53 2024/01/12 13:20:52 adam Exp $

DISTNAME=	braintree-4.26.0
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	finance python
MASTER_SITES=	${MASTER_SITE_PYPI:=b/braintree/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/braintree/braintree_python
COMMENT=	Braintree Python Library
LICENSE=	mit

TOOL_DEPENDS+=	${PYPKGPREFIX}-setuptools-[0-9]*:../../devel/py-setuptools
TOOL_DEPENDS+=	${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
DEPENDS+=	${PYPKGPREFIX}-requests>=0.11.1:../../devel/py-requests

USE_LANGUAGES=	# none

PYTHON_VERSIONS_INCOMPATIBLE=	27

.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>