File:  [cvs.NetBSD.org] / pkgsrc / finance / gnucash / Makefile
Revision 1.347: download - view: text, annotated - select for diffs
Fri Apr 5 11:12:27 2024 UTC (9 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: HEAD
gnucash: update to 5.6.

5.6  - 31 March 2024
The following bugs have been fixed:

    Bug 798946 - start/end of current/last quarter have off-by-one error
    Bug 799093 - Cannot reconcile since v5.4
    Bug 799179 - SLR won't allow change from "Reminder" to any other state
    Bug 799210 - Bad encoding of accented chars in account names in
                 "Import CSV" wizard
    Bug 799213 - SIGSEGV caused by revising an auto completed transaction
    Bug 799222 - Crash when changing the parent of an account that has had two
                 or more levels of sub-accounts auto-created using the register
                 in the current session.
    Bug 799224 - Import of QIF gets Bug detected during duplicates (partial
                 fix: If the new-splits object is null, it means the new
                 account tree from the current import has no splits. Therefore
                 the (apply min|max dates) will fail. Omitting the date query
                 is a simple fix to prevent crashing. This is a partial fix
                 because the crash is likely a symptom of another bug which
                 causes the new account-tree to be empty.
    Bug 799225 - QIF Importer Crashes Silently after "Start Import" Button:
                 Don't allow a QIF investment transaction without an action
                 (buy/sell/etc)
    Bug 799246 - import matcher will rename incorrect splits

Other repairs or enhancements not marked as bugs:

    Numeric parsing and string handling improvements in the Engine and XML
        backend.
    [gnc-dense-cal.c] sx popup: show date in preference (cf.locale) format
        because the date format preference is user-facing and customisable.
        It's jarring if the preference is dd/mm/yyyy and the display shows
        mm/dd/yyyy in accordance to the locale.
    Correct misleading description about creating Scheduled Transaction.
    Date parsing efficiency improvements.
    Update minumum Python version to 3.8, made necessary by updating the C API
        in the Python bindings.
    Replace deprecated distutils.sysconfig with sysconfig. distutils is not
        present in Python 3.12.2.
    Query user via dialog for date when creating a reverse transaction.
    More C++ conversions
    Avoid deprecation warning for -py3 in swig >= 4.1
    [gnc-commodities.cpp] gnc_new_iso_codes is a std::unordered_map
    Replace some naked for loops with C++ algorithms
    Convert gnc-commodity to C++ and make GncQuoteSources a C++ class.
    [test-commodities.cpp] add some tests for gnc_quote_sources
    Remove the SLR status sort as it is too confusing
    Allow sorting of the transaction column in the Since Last Run dialog by
        schedule name or occurrence date. To sort by schedule name, a schedule
        name is first selected and then the column header is pressed to change
        order. To sort by occurrence date, a date is selected and then the
        column header is pressed to change order based on the date of the
        first occurrence. A tool tip has been added to indicate the sort order
        being used.
    [gtest-gnc-numeric] add operator comparisons with example int64 numbers
    [assistant-stock-transaction] store & retrieve associated account as
        metadata
    Update Form/Schedule line references for 2023 for the US Income Tax Report
    Update another gnucash-help to gnucash-manual
    [invoice.scm] centralize layout components into layout-key-list instead of
        maintaining 2 assoc lists.
    [invoice.scm] normalize header section generators, changing the functions
        to require 1 options argument only
    Update invoice.scm: Add spacing for long Invoice ID's (Displayed as
        "Reference" on the Invoice)

New and Updated Translations: Croatian, Dutch, English (Australia),
    English (New Zealand), English (United Kingdom), French, German,
    Hebrew, Hungarian, Indonesian, Japanese, Norwegian Bokmål, Polish,
    Portuguese, Slovak, Spanish, Swedish

# $NetBSD: Makefile,v 1.347 2024/04/05 11:12:27 wiz Exp $

DISTNAME=		gnucash-5.6
CATEGORIES=		finance
MASTER_SITES=		${MASTER_SITE_GITHUB:=gnucash/}
GITHUB_RELEASE=		${PKGVERSION_NOREV}
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		wiz@NetBSD.org
HOMEPAGE=		http://www.gnucash.org/
COMMENT=		Personal or business finance management program
LICENSE=		gnu-gpl-v3

DEPENDS+=		guile30-slib>=3.2.1:../../devel/guile30-slib
DEPENDS+=		dconf-[0-9]*:../../devel/dconf

USE_LANGUAGES=		c c++
USE_LIBTOOL=		yes
INFO_FILES=		yes
USE_TOOLS+=		bash perl:run pkg-config
USE_TOOLS+=		gmake

USE_CXX_FEATURES=	c++17

# build failure in test-tx_import and a couple test failures
# https://bugzilla.gnome.org/show_bug.cgi?id=795251
TEST_TARGET=		check

# too fragile
BUILDLINK_TRANSFORM+=	rm:-Werror

LDFLAGS+=		${COMPILER_RPATH_FLAG}${PREFIX}/lib/gnucash
CXXFLAGS+=		-Wno-deprecated-declarations
# https://bugs.gnucash.org/show_bug.cgi?id=797039
CFLAGS+=		-Wno-char-subscripts

MAKE_ENV+=		GUILE_AUTO_COMPILE=0
CMAKE_ARGS+=		-DWITH_AQBANKING=OFF
CMAKE_ARGS+=		-DPERL_EXECUTABLE=${PERL5}
CMAKE_ARGS+=		-DCOMPILE_GSCHEMAS=OFF

# test status as of 5.4.1
# after 'make install'
# 89% tests passed, 14 tests failed out of 129
TEST_ENV+=		LD_LIBRARY_PATH=${WRKSRC}/lib
REPLACE_PERL+=		common/gnc-test-env.pl
REPLACE_PERL+=		libgnucash/backend/xml/test/grab-types.pl
REPLACE_PERL+=		util/elegant-sort.pl

PLIST_SRC=		PLIST

PKG_SYSCONFSUBDIR=	gnucash
CONF_FILES+=		${PREFIX}/share/examples/gnucash/environment ${PKG_SYSCONFDIR}/environment
INSTALLATION_DIRS=	share/examples/gnucash

.include "../../mk/bsd.prefs.mk"

post-install:
	${MV} ${DESTDIR}${PREFIX}/etc/gnucash/environment ${DESTDIR}${PREFIX}/share/examples/gnucash/environment

.include "options.mk"

.include "../../devel/cmake/build.mk"
BUILDLINK_API_DEPENDS.glib2+=	glib2>=2.56.1
.include "../../devel/glib2/schemas.mk"
.include "../../devel/glib2/buildlink3.mk"
BUILDLINK_API_DEPENDS.boost-headers+=   boost-headers>=1.67
.include "../../devel/boost-headers/buildlink3.mk"
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../devel/gettext-tools/msgfmt-desktop.mk"
BUILDLINK_API_DEPENDS.googletest+=	googletest>=1.8.0
.include "../../devel/googletest/buildlink3.mk"
.include "../../devel/swig4/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../graphics/gdk-pixbuf2/buildlink3.mk"
.include "../../lang/guile30/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../textproc/icu/buildlink3.mk"
BUILDLINK_API_DEPENDS.libxml2+=	libxml2>=2.9.4
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../textproc/libxslt/buildlink3.mk"
BUILDLINK_API_DEPENDS.webkit-gtk+=	webkit-gtk>=2.14.1
.include "../../www/webkit-gtk/buildlink3.mk"
BUILDLINK_API_DEPENDS.gtk3+=	gtk3+>=3.22.30
.include "../../x11/gtk3/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>