[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / finance / gnucash

File: [cvs.NetBSD.org] / pkgsrc / finance / gnucash / Makefile (download)

Revision 1.1.1.1 (vendor branch), Mon Dec 11 13:53:26 2000 UTC (23 years, 4 months ago) by wiz
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines

Moved misc/emma, misc/gnucash, misc/tclticker, misc/xfinans, misc/xinvest,
and x11/xquote to new finance category; only change is addition of 'finance'
to CATEGORIES in the Makefiles.

# $NetBSD: Makefile,v 1.1.1.1 2000/12/11 13:53:26 wiz Exp $
#

DISTNAME=		gnucash-1.4.8
CATEGORIES=		finance
MASTER_SITES=		http://www.linas.org/pub/gnucash/gnucash/sources/stable/ \
			ftp://ftp.gnucash.org/pub/gnucash/sources/stable/ \
			${MASTER_SITE_SOURCEFORGE:=gnucash/}

MAINTAINER=		drankin@bohemians.lexington.ky.us
HOMEPAGE=		http://www.gnucash.org/

DEPENDS+=		gnome-libs>=1.0.40:../../x11/gnome-libs
DEPENDS+=		gettext>=0.10.35nb1:../../devel/gettext
DEPENDS+=		eperl-2.2.14:../../textproc/eperl
DEPENDS+=		g-wrap>=0.9.5:../../devel/g-wrap
DEPENDS+=		guile-slib-2c8:../../devel/guile-slib
DEPENDS+=		libperl-5.*:../../lang/libperl
DEPENDS+=		swig-1.1p5:../../devel/swig
DEPENDS+=		libxml>=1.8.7:../../textproc/libxml

USE_GMAKE=		# defined
USE_PERL5=		# defined
USE_X11=		# defined

USE_LIBTOOL=		# defined
LTCONFIG_OVERRIDE+=	${WRKSRC}/ltconfig

GNU_CONFIGURE=		# defined
CONFIGURE_ARGS+=	--with-guile-config=${LOCALBASE}/bin/guile-config
CONFIGURE_ARGS+=	--without-motif --without-included-gettext
CONFIGURE_ARGS+=	--with-perl-includes=${PERL5_ARCHLIB}

CONFIGURE_ENV+=		LOCALBASE="${LOCALBASE}"
CONFIGURE_ENV+=		CPPFLAGS="${CPPFLAGS}"
CPPFLAGS+=		-I${LOCALBASE}/include

.include "../../mk/bsd.pkg.mk"