[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / finance / bitcoin

Annotation of pkgsrc/finance/bitcoin/Makefile, Revision 1.5

1.5     ! nia         1: # $NetBSD: Makefile,v 1.4 2018/08/16 18:54:43 adam Exp $
1.1       khorben     2:
                      3: DISTNAME=      bitcoin-0.16.1
1.5     ! nia         4: PKGREVISION=   3
1.1       khorben     5: CATEGORIES=    finance
                      6: MASTER_SITES=  ${MASTER_SITE_GITHUB:=bitcoin/}
                      7: GITHUB_TAG=    v${PKGVERSION_NOREV}
                      8:
1.2       khorben     9: MAINTAINER=    khorben@defora.org
1.1       khorben    10: HOMEPAGE=      https://github.com/bitcoin/bitcoin/
                     11: COMMENT=       P2P electronic cash system
                     12: LICENSE=       mit
                     13:
                     14: USE_LIBTOOL=   yes
                     15: USE_TOOLS+=    gmake pkg-config autoconf aclocal autoheader automake
                     16: AUTO_MKDIRS=   yes
                     17: GNU_CONFIGURE= yes
                     18:
                     19: USE_LANGUAGES= c c++
                     20: # bitcoin-core requires c++11 (but does not need manual --std=c++11).
                     21:
                     22: # TODO: File bug upstream - configure should add this where it is
                     23: # needed.  Without -fPIC, linking of test_bitcoin fails.
                     24: CFLAGS+=       -fPIC
                     25:
                     26: # configure does not look in PREFIX for boost unless instructed.
                     27: CONFIGURE_ARGS+=       --with-boost=${BUILDLINK_PREFIX.boost-libs}
                     28:
                     29: CONFIGURE_ARGS+=       --enable-hardening
                     30:
                     31: # pkgsrc's db4 package installs as db4_, but bitcoin looks for db_.
                     32: BUILDLINK_TRANSFORM+=  l:db_cxx:db4_cxx
                     33:
                     34: TEST_TARGET=   check
                     35:
                     36: PLIST_VARS+=   qt
                     37:
                     38: RCD_SCRIPTS=           bitcoind
                     39: BUILD_DEFS+=           VARBASE
                     40: OWN_DIRS=              ${VARBASE}/bitcoin
                     41: EGDIR=                 ${PREFIX}/share/examples/bitcoin
                     42: CONF_FILES=            ${EGDIR}/bitcoin.conf ${PKG_SYSCONFDIR}/bitcoin.conf
                     43: CONF_FILES_PERMS=      ${EGDIR}/bitcoin.conf ${PKG_SYSCONFDIR}/bitcoin.conf ${REAL_ROOT_USER} ${REAL_ROOT_GROUP} 0644
                     44:
                     45: # This is currently unnecessary, but it seems likely we will find a
                     46: # file that references /usr when ${PREFIX} is appropriate.
                     47: SUBST_CLASSES+=                pkg
                     48: SUBST_STAGE.pkg=       post-patch
                     49: SUBST_SED.pkg=         -e "s|/usr/|${PREFIX}/|g"
                     50: SUBST_MESSAGE.pkg=     Fixing /usr references to ${PREFIX}.
                     51:
                     52: # bitcoin does not actually have releases; only snapshots of the
                     53: # repository from which a release would have been made.  Remedially
                     54: # create configure.in and similar.
                     55: pre-configure:
                     56:        cd ${WRKSRC} && ./autogen.sh
                     57:
                     58: # TODO: Decide if secp256k1 and univalue are supposed to be installed,
                     59: # and if so where, or if they should be linked with privately.
                     60: INSTALL_DIRS=  ${BUILD_DIRS} src/secp256k1 src/univalue
                     61:
                     62: # Install the Debian example config file.
                     63: post-install:
                     64:        ${INSTALL_DATA} -m 644 ${WRKSRC}/contrib/debian/examples/bitcoin.conf ${DESTDIR}${EGDIR}
                     65:
                     66: .include "options.mk"
                     67:
                     68: .include "../../sysutils/desktop-file-utils/desktopdb.mk"
                     69: .include "../../databases/db4/buildlink3.mk"
                     70: .include "../../devel/boost-libs/buildlink3.mk"
                     71: .include "../../devel/libevent/buildlink3.mk"
                     72: .include "../../security/openssl/buildlink3.mk"
                     73: .include "../../mk/dlopen.buildlink3.mk"
                     74: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>