[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / finance / bitcoin

Annotation of pkgsrc/finance/bitcoin/Makefile, Revision 1.2

1.2     ! khorben     1: # $NetBSD: Makefile,v 1.1 2018/07/08 11:13:45 khorben Exp $
1.1       khorben     2:
                      3: DISTNAME=      bitcoin-0.16.1
                      4: CATEGORIES=    finance
                      5: MASTER_SITES=  ${MASTER_SITE_GITHUB:=bitcoin/}
                      6: GITHUB_TAG=    v${PKGVERSION_NOREV}
                      7:
1.2     ! khorben     8: MAINTAINER=    khorben@defora.org
1.1       khorben     9: HOMEPAGE=      https://github.com/bitcoin/bitcoin/
                     10: COMMENT=       P2P electronic cash system
                     11: LICENSE=       mit
                     12:
                     13: USE_LIBTOOL=   yes
                     14: USE_TOOLS+=    gmake pkg-config autoconf aclocal autoheader automake
                     15: AUTO_MKDIRS=   yes
                     16: GNU_CONFIGURE= yes
                     17:
                     18: USE_LANGUAGES= c c++
                     19: # bitcoin-core requires c++11 (but does not need manual --std=c++11).
                     20:
                     21: # TODO: File bug upstream - configure should add this where it is
                     22: # needed.  Without -fPIC, linking of test_bitcoin fails.
                     23: CFLAGS+=       -fPIC
                     24:
                     25: # configure does not look in PREFIX for boost unless instructed.
                     26: CONFIGURE_ARGS+=       --with-boost=${BUILDLINK_PREFIX.boost-libs}
                     27:
                     28: CONFIGURE_ARGS+=       --enable-hardening
                     29:
                     30: # pkgsrc's db4 package installs as db4_, but bitcoin looks for db_.
                     31: BUILDLINK_TRANSFORM+=  l:db_cxx:db4_cxx
                     32:
                     33: TEST_TARGET=   check
                     34:
                     35: PLIST_VARS+=   qt
                     36:
                     37: RCD_SCRIPTS=           bitcoind
                     38: BUILD_DEFS+=           VARBASE
                     39: OWN_DIRS=              ${VARBASE}/bitcoin
                     40: EGDIR=                 ${PREFIX}/share/examples/bitcoin
                     41: CONF_FILES=            ${EGDIR}/bitcoin.conf ${PKG_SYSCONFDIR}/bitcoin.conf
                     42: CONF_FILES_PERMS=      ${EGDIR}/bitcoin.conf ${PKG_SYSCONFDIR}/bitcoin.conf ${REAL_ROOT_USER} ${REAL_ROOT_GROUP} 0644
                     43:
                     44: # This is currently unnecessary, but it seems likely we will find a
                     45: # file that references /usr when ${PREFIX} is appropriate.
                     46: SUBST_CLASSES+=                pkg
                     47: SUBST_STAGE.pkg=       post-patch
                     48: SUBST_SED.pkg=         -e "s|/usr/|${PREFIX}/|g"
                     49: SUBST_MESSAGE.pkg=     Fixing /usr references to ${PREFIX}.
                     50:
                     51: # bitcoin does not actually have releases; only snapshots of the
                     52: # repository from which a release would have been made.  Remedially
                     53: # create configure.in and similar.
                     54: pre-configure:
                     55:        cd ${WRKSRC} && ./autogen.sh
                     56:
                     57: # TODO: Decide if secp256k1 and univalue are supposed to be installed,
                     58: # and if so where, or if they should be linked with privately.
                     59: INSTALL_DIRS=  ${BUILD_DIRS} src/secp256k1 src/univalue
                     60:
                     61: # Install the Debian example config file.
                     62: post-install:
                     63:        ${INSTALL_DATA} -m 644 ${WRKSRC}/contrib/debian/examples/bitcoin.conf ${DESTDIR}${EGDIR}
                     64:
                     65: .include "options.mk"
                     66:
                     67: .include "../../sysutils/desktop-file-utils/desktopdb.mk"
                     68: .include "../../databases/db4/buildlink3.mk"
                     69: .include "../../devel/boost-libs/buildlink3.mk"
                     70: .include "../../devel/libevent/buildlink3.mk"
                     71: .include "../../security/openssl/buildlink3.mk"
                     72: .include "../../mk/dlopen.buildlink3.mk"
                     73: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>