[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / filesystems / libntfs

File: [cvs.NetBSD.org] / pkgsrc / filesystems / libntfs / Makefile.common (download)

Revision 1.2, Tue Nov 10 17:45:22 2015 UTC (8 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.1: +2 -2 lines

Changes 2015.3.14:

Changes to NTFS-3G:
-------------------
Fixed inserting a new ACL after wiping out by chkdsk
Fixed Windows-type inheritance
Fixed ignoring the umask mount option when permissions are used
Fixed checking permissions when Posix ACLs are compiled in but not enabled
Disabled option remove_hiberfile on read-only mounts
Implemented an extended attribute to get/set EAs
Avoid full runlist updating in more situations
Update ctime after setting an ACL
Use MFT record 15 for the first extent to MFT:DATA
Ignore the sloppy mount option (-s)
Implemented FITRIM (fstrim) ioctl
Reengineered the compression algorithm

Changes to ntfsprogs:
---------------------
Return success from ntfsprogs utilities with options ãàÅ×ersion and the like
Implemented configure option ãàÅÆnable-quarantined for non functional utilities
Added manuals for ntfsdecrypt, ntfswipe, ntfstruncate and ntfsfallocate

# $NetBSD: Makefile.common,v 1.2 2015/11/10 17:45:22 adam Exp $
# used by filesystems/fuse-ntfs-3g/Makefile
# used by sysutils/ntfsprogs/Makefile

DISTNAME=	ntfs-3g_ntfsprogs-2015.3.14
CATEGORIES=	sysutils
MASTER_SITES=	http://tuxera.com/opensource/
EXTRACT_SUFX=	.tgz

MAINTAINER?=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.tuxera.com/community/ntfs-3g-download/
LICENSE=	gnu-gpl-v2

DISTINFO_FILE=	${.CURDIR}/../../filesystems/libntfs/distinfo
PATCHDIR=	${.CURDIR}/../../filesystems/libntfs/patches

USE_LANGUAGES=		c c++
USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--enable-posix-acls
CONFIGURE_ARGS+=	--enable-xattr-mappings