[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / filesystems / fuse-ntfs-3g

File: [cvs.NetBSD.org] / pkgsrc / filesystems / fuse-ntfs-3g / Makefile (download)

Revision 1.19, Tue Nov 10 17:45:22 2015 UTC (8 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.18: +14 -1 lines

Changes 2015.3.14:

Changes to NTFS-3G:
-------------------
Fixed inserting a new ACL after wiping out by chkdsk
Fixed Windows-type inheritance
Fixed ignoring the umask mount option when permissions are used
Fixed checking permissions when Posix ACLs are compiled in but not enabled
Disabled option remove_hiberfile on read-only mounts
Implemented an extended attribute to get/set EAs
Avoid full runlist updating in more situations
Update ctime after setting an ACL
Use MFT record 15 for the first extent to MFT:DATA
Ignore the sloppy mount option (-s)
Implemented FITRIM (fstrim) ioctl
Reengineered the compression algorithm

Changes to ntfsprogs:
---------------------
Return success from ntfsprogs utilities with options ãàÅ×ersion and the like
Implemented configure option ãàÅÆnable-quarantined for non functional utilities
Added manuals for ntfsdecrypt, ntfswipe, ntfstruncate and ntfsfallocate

# $NetBSD: Makefile,v 1.19 2015/11/10 17:45:22 adam Exp $

.include "../../filesystems/libntfs/Makefile.common"

PKGNAME=	fuse-${DISTNAME:S/_ntfsprogs//}
CATEGORIES=	filesystems

COMMENT=	NTFS driver with read and write support

CONFIGURE_ARGS+=	--disable-ntfsprogs
CONFIGURE_ARGS+=	--enable-mount-helper

BUILD_DIRS=		src

USE_TOOLS+=	pkg-config

PLIST_VARS+=	lowntfs
.include "../../mk/bsd.prefs.mk"
SUBST_CLASSES+=		lowntfs
SUBST_MESSAGE.lowntfs=	Dealing with lowntfs.
SUBST_STAGE.lowntfs=	pre-configure
SUBST_FILES.lowntfs=	src/Makefile.in
.if ${OPSYS} == "NetBSD"
SUBST_SED.lowntfs=	-e 's,@ENABLE_LOWNTFS@,\#,'
.else
SUBST_SED.lowntfs=	-e 's,@ENABLE_LOWNTFS@,,'
PLIST.lowntfs=		yes
.endif

.include "../../filesystems/libntfs/buildlink3.mk"
.include "../../mk/fuse.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"