[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / emulators / wine

Annotation of pkgsrc/emulators/wine/Makefile, Revision 1.174

1.174   ! jperkin     1: # $NetBSD: Makefile,v 1.173 2013/01/26 21:36:23 adam Exp $
1.56      adam        2:
1.161     adam        3: DISTNAME=      wine-1.2.3
1.174   ! jperkin     4: PKGREVISION=   11
1.56      adam        5: CATEGORIES=    emulators
1.111     adam        6: MASTER_SITES=  http://ibiblio.org/pub/linux/system/emulators/wine/ \
                      7:                ${MASTER_SITE_SOURCEFORGE:=wine/}
1.93      adam        8: EXTRACT_SUFX=  .tar.bz2
1.56      adam        9:
                     10: MAINTAINER=    adam@NetBSD.org
                     11: HOMEPAGE=      http://www.winehq.com/
1.143     dholland   12: COMMENT=       Free implementation of Windows on Unix
1.161     adam       13: LICENSE=       gnu-lgpl-v2.1
1.56      adam       14:
1.77      adam       15: BUILD_DEPENDS+=        fontforge-[0-9]*:../../fonts/fontforge
1.1       mycroft    16:
1.161     adam       17: ONLY_FOR_PLATFORM+=    *-*-i386
                     18: #ONLY_FOR_PLATFORM+=   *-*-x86_64
1.154     joerg      19:
1.105     adam       20: USE_LANGUAGES=         c
1.88      adam       21: USE_LIBTOOL=           yes
1.90      adam       22: USE_NCURSES=           yes
1.142     tnn        23: USE_TOOLS+=            bison flex gmake mktemp
1.163     hans       24: FLEX_REQD=             2.5.33
1.78      adam       25: GNU_CONFIGURE=         yes
1.69      abs        26: UNLIMIT_RESOURCES=     datasize
1.31      wiz        27:
1.96      adam       28: REPLACE_PERL+=         tools/winemaker tools/winedump/function_grep.pl
1.48      wiz        29:
1.33      jlam       30: # The Wine configure script has problems locating the libraries in the
                     31: # buildlink directory, so prepend all of the LDFLAGS necessary to link
                     32: # against the libraries.
1.99      adam       33: CONFIGURE_ENV+=                X_LIBS=${LDFLAGS:M*:Q}
1.109     rillig     34: CONFIGURE_ENV+=                CFLAGS=${CFLAGS:M*:Q}\ -DDEVOSSAUDIO="\"${DEVOSSAUDIO}\""
1.151     adam       35: CONFIGURE_ENV+=                LDD=${LDD:Q}
1.25      junyoung   36: LIBS+=                 ${LDFLAGS}
1.32      zuntum     37:
1.161     adam       38: # If we're doing a 32-bit build, make sure that the appropriate multilib
                     39: # options are passed through as these values are used with winegcc
                     40: # (which wrapper doesn't handle).
1.150     jmcneill   41: .include "../../mk/bsd.prefs.mk"
1.161     adam       42: .if !empty(MACHINE_ARCH:Mi386)
                     43: CONFIGURE_ENV+=                ac_cv_prog_CC=${CC:Q}\ -m32
                     44: CONFIGURE_ENV+=                ac_cv_prog_CXX=${CXX:Q}\ -m32
                     45: CONFIGURE_ENV+=                ac_cv_prog_AS=${AS:Q}\ --32
                     46: CONFIGURE_ENV+=                ac_cv_prog_LD=${LD:Q}\ -m\ elf_i386
1.150     jmcneill   47: .endif
1.161     adam       48: # Needs GCC >= 4.4
                     49: #.if !empty(MACHINE_ARCH:Mx86_64)
                     50: #CONFIGURE_ARGS+=      --disable-win16
                     51: #CONFIGURE_ARGS+=      --enable-win64
                     52: #.endif
1.150     jmcneill   53:
1.86      wiz        54: .include "options.mk"
1.1       mycroft    55:
1.98      wiz        56: post-install:
1.143     dholland   57: .for tool in fnt2bdf
1.99      adam       58:        ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} ${WRKSRC}/tools/${tool} \
1.144     dholland   59:                ${DESTDIR}${PREFIX}/bin
1.98      wiz        60: .endfor
                     61:
1.90      adam       62: .include "../../devel/ncurses/buildlink3.mk"
1.151     adam       63: .include "../../graphics/lcms/buildlink3.mk"
                     64: .include "../../graphics/png/buildlink3.mk"
1.161     adam       65: .include "../../graphics/tiff/buildlink3.mk"
                     66: .include "../../security/gnutls/buildlink3.mk"
1.92      adam       67: .include "../../textproc/libxslt/buildlink3.mk"
1.143     dholland   68: .include "../../textproc/libxml2/buildlink3.mk"
1.161     adam       69: .include "../../mk/giflib.buildlink3.mk"
                     70: .include "../../mk/jpeg.buildlink3.mk"
1.100     jlam       71: .include "../../mk/oss.buildlink3.mk"
1.70      adam       72: .include "../../mk/pthread.buildlink3.mk"
1.161     adam       73: .include "../../sysutils/desktop-file-utils/desktopdb.mk"
1.5       agc        74: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>