[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / emulators / wine-devel

Annotation of pkgsrc/emulators/wine-devel/Makefile, Revision 1.13

1.13    ! sno         1: # $NetBSD: Makefile,v 1.12 2009/07/22 09:01:26 wiz Exp $
1.1       adam        2:
1.11      adam        3: DISTNAME=      wine-1.1.16
1.13    ! sno         4: PKGREVISION=   1
1.1       adam        5: CATEGORIES=    emulators
                      6: MASTER_SITES=  http://ibiblio.org/pub/linux/system/emulators/wine/ \
                      7:                ${MASTER_SITE_SOURCEFORGE:=wine/}
                      8: EXTRACT_SUFX=  .tar.bz2
                      9:
                     10: MAINTAINER=    adam@NetBSD.org
                     11: HOMEPAGE=      http://www.winehq.com/
                     12: COMMENT=       Free implementation of Windows on Unix
                     13:
                     14: BUILD_DEPENDS+=        fontforge-[0-9]*:../../fonts/fontforge
                     15:
                     16: #ONLY_FOR_PLATFORM=    NetBSD-1.5Z*-i386 NetBSD-1.6*-i386 NetBSD-[2-9]*-i386
                     17: #ONLY_FOR_PLATFORM+=   FreeBSD-*-i386 Linux-*-i386 SunOS-*-i386 Darwin-*-i386
                     18: #ONLY_FOR_PLATFORM+=   *-*-x86_64
                     19:
                     20: PKG_DESTDIR_SUPPORT=   user-destdir
                     21:
                     22: USE_LANGUAGES=         c
                     23: USE_LIBTOOL=           yes
                     24: USE_NCURSES=           yes
                     25: USE_TOOLS+=            bison flex gmake mktemp
                     26: GNU_CONFIGURE=         yes
                     27: UNLIMIT_RESOURCES=     datasize
                     28:
                     29: REPLACE_PERL+=         tools/winemaker tools/winedump/function_grep.pl
                     30:
                     31: # The Wine configure script has problems locating the libraries in the
                     32: # buildlink directory, so prepend all of the LDFLAGS necessary to link
                     33: # against the libraries.
                     34: #
                     35: CONFIGURE_ENV+=                X_LIBS=${LDFLAGS:M*:Q}
                     36: CONFIGURE_ENV+=                CFLAGS=${CFLAGS:M*:Q}\ -DDEVOSSAUDIO="\"${DEVOSSAUDIO}\""
1.5       jmcneill   37: CONFIGURE_ENV+=                LDD=${LDD}
1.1       adam       38: LIBS+=                 ${LDFLAGS}
                     39:
1.5       jmcneill   40: # If we're doing a 32-bit build, make sure that the appropriate
                     41: # multilib options are passed through as these values are used
                     42: # with winegcc (which wrapper doesn't handle).
                     43: .include "../../mk/bsd.prefs.mk"
                     44: .if !empty(MACHINE_ARCH:Mi386)
                     45: CONFIGURE_ENV+=                ac_cv_prog_CC=${CC}\ -m32
                     46: CONFIGURE_ENV+=                ac_cv_prog_CXX=${CXX}\ -m32
                     47: CONFIGURE_ENV+=                ac_cv_prog_AS=${AS}\ --32
                     48: CONFIGURE_ENV+=                ac_cv_prog_LD=${LD}\ -m\ elf_i386
                     49: .endif
1.10      adam       50: .if !empty(MACHINE_ARCH:Mx86_64)
                     51: CONFIGURE_ARGS+=       --enable-win64
                     52: .endif
1.5       jmcneill   53:
1.1       adam       54: .include "options.mk"
                     55:
                     56: post-install:
                     57: .for tool in fnt2bdf
                     58:        ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} ${WRKSRC}/tools/${tool} \
                     59:                ${DESTDIR}${PREFIX}/bin
                     60: .endfor
                     61:
                     62: .include "../../devel/ncurses/buildlink3.mk"
                     63: .include "../../textproc/libxslt/buildlink3.mk"
                     64: .include "../../textproc/libxml2/buildlink3.mk"
                     65: .include "../../mk/oss.buildlink3.mk"
                     66: .include "../../mk/pthread.buildlink3.mk"
                     67: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>