Up to [cvs.NetBSD.org] / pkgsrc / emulators / unicorn
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.21 / (download) - annotate - [select for diffs], Thu May 11 06:47:11 2023 UTC (6 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
HEAD
Changes since 1.20: +3 -17
lines
Diff to previous 1.20 (colored)
unicorn py-unicorn: updated to 2.0.1.post1 Version 2.0.1 Features: - Support building & running on BE hosts. - Fix and support `clang-cl` on Windows. - Fix python `sdist` and add aarch64 Linux wheels. Note `pip` can build Unicorn2 on M1 now! - C# binding is refined and upgraded to .Net 6. Fix/Improvements: - Various bindings improvements. - Improvements for tests. - Fail explicitly when VEX.L is set. - Fix endianness when writing PPC32 CR register. - Fix a bug in `uc_ctl_set_cpu_model` check. - Fix Tricore PC not updating. - Fix the mapping not updated if users modify the mappings in the hooks. - Handle pathological cases consistently. - Fix memory leaks in PPC target. - Fix memory leaks in Tricore target. - Fix MSVC handling in cmake. - Fix PC sync-ing problems for `UC_HOOK_BLOCK` hooks. - Fix PC sync-ed twice when users request a soft restart. - Prevent overflow with pre-allocated RAM blocks. - Add FPCR and FPSR registers - Fix ARM CPU state not deep copied. - Fix PC not sync-ed for memory operation on aarch64. - Exit invalid store operations early to avoid the target registers being overwritten. - Improve the support for ARM BE32. Version 2.0.0 Features: - TriCore Support Fixes/Improvements: - Build both shared library and static archive as unicorn1 does. - Misc bindings improvements. - Make sure setjmp-setjmp-wrapper-win32 participates in the build. - Improve Rust bindings build logic. - Fix wrong python binding for UC_CTL_TB_REMOVE_CACHE - Flush translation blocks when the count hook is removed. - Fix unicorn crash when nested `uc_emu_start` deletes a hook - Fix CPU not fully resumed when writing PC. - Don't quit TB if `uc_mem_protect` doesn't change the protection of current TB memory. - Add type annotations for python bindings. - Add CPUID hook for python bindings. - Don't repeat memory hooks if there is already an unhandled error. - Support reads and writes over all Arm SIMD registers - Fix wrong registers range in python bindings. - Fix uc_mem_protect on mmio regions - Fix a UAF caused by hook cache. - Fix the value collision between UC_MODE_ARMBE8 and UC_MODE_ARM926
Revision 1.20 / (download) - annotate - [select for diffs], Wed May 10 19:14:50 2023 UTC (6 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.19: +8 -2
lines
Diff to previous 1.19 (colored)
unicorn py-unicorn: updated to 1.0.3 Version 1.0.3 Fix some building issues - Fix build with LLVM on Powerpc64(le) - cmake: enable UNICORN_HAS_ARMEB when ARM is on - Better support MingW building - Better support FreeBSD host - Better support VS2008/VS2010 Fix some issues in the core: - Fix wrong sync after UC_ERR_[READ, WRITE, FETCH]_[UNMAPPED, PROT] - Support querying architecture mode besides arm - Fix pausing within Thumb2 ITE blocks Arm: - Support Arm BE8 mode X86: - Fix FPIP & FTST instructions Bindings: - Java: remove deprecated javah and build with javac - Python: handle exceptions raised in hook functions - Rust binding
Revision 1.19 / (download) - annotate - [select for diffs], Thu Jun 30 11:18:22 2022 UTC (17 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3
Changes since 1.18: +2 -2
lines
Diff to previous 1.18 (colored)
*: Revbump packages that use Python at runtime without a PKGNAME prefix
Revision 1.18 / (download) - annotate - [select for diffs], Wed Dec 8 16:04:19 2021 UTC (23 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.17: +2 -1
lines
Diff to previous 1.17 (colored)
revbump for icu and libffi
Revision 1.17 / (download) - annotate - [select for diffs], Thu Oct 21 19:09:10 2021 UTC (2 years, 1 month ago) by jperkin
Branch: MAIN
Changes since 1.16: +2 -1
lines
Diff to previous 1.16 (colored)
unicorn: Fix build on SunOS.
Revision 1.16 / (download) - annotate - [select for diffs], Thu Feb 25 19:51:29 2021 UTC (2 years, 9 months ago) by leot
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1
Changes since 1.15: +1 -3
lines
Diff to previous 1.15 (colored)
unicorn: Remove commented out Python requirements
Revision 1.15 / (download) - annotate - [select for diffs], Thu Feb 25 19:47:50 2021 UTC (2 years, 9 months ago) by leot
Branch: MAIN
Changes since 1.14: +2 -3
lines
Diff to previous 1.14 (colored)
{,py-}unicorn: Update to 1.0.2 Changes: 1.0.2 ----- - Fix Java binding compilation - Enable building for ARM little-endian only (ignore big-endian) - Add uc_context_free() API - Fix context saving/retoring API (core & Python binding) - Add cmake option to build Unicorn as a static library - Fix error handling of mmap() - uc_emu_start() can be reentrant - Fix naming conflicts when built with systemd - Fix setjmp/longjmp on native Windows - Fix enabled hooks even after deleting them - X86: - Fix 64bit fstenv - Fix IP value of 16bit mode - ARM: - Fix APSR handling - Python: Remove UC_ERR_TIMEOUT - No longer require Python to build - Fix recursive UC_HOOK_MEM callbacks for cross pages access - Remove UC_ERR_TIMEOUT, so timeout on uc_emu_start() is not considered error - Added UC_QUERY_TIMEOUT to query exit reason - Fix UAF when deleting hook while in hook callback - Ensure that hooks are unaffected by a request to stop emulation. - Fix block hooks being called twice after an early exit from execution. - Fix binding install on python2 (MacOS) - X86: - Support read/write STn registers - Support read/write X64 base regs - ARM64: - Support some new registers
Revision 1.14 / (download) - annotate - [select for diffs], Fri Dec 4 20:45:17 2020 UTC (2 years, 11 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base,
pkgsrc-2020Q4
Changes since 1.13: +2 -2
lines
Diff to previous 1.13 (colored)
Revbump packages with a runtime Python dep but no version prefix. For the Python 3.8 default switch.
Revision 1.13 / (download) - annotate - [select for diffs], Sun Mar 8 16:49:29 2020 UTC (3 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1
Changes since 1.12: +2 -2
lines
Diff to previous 1.12 (colored)
*: recursive bump for libffi
Revision 1.12 / (download) - annotate - [select for diffs], Tue Dec 31 13:14:51 2019 UTC (3 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.11: +3 -2
lines
Diff to previous 1.11 (colored)
unicorn: update to 1.0.1nb2. Use LDFLAGS -- fixes RELRO build.
Revision 1.11 / (download) - annotate - [select for diffs], Sun Nov 3 19:24:34 2019 UTC (4 years ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base,
pkgsrc-2019Q4
Changes since 1.10: +2 -2
lines
Diff to previous 1.10 (colored)
emulators: align variable assignments pkglint -Wall -F --only aligned --only indent -r No manual corrections.
Revision 1.10 / (download) - annotate - [select for diffs], Mon Sep 2 13:19:59 2019 UTC (4 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base,
pkgsrc-2019Q3
Changes since 1.9: +2 -2
lines
Diff to previous 1.9 (colored)
Changed PYTHON_VERSIONS_INCOMPATIBLE to PYTHON_VERSIONS_ACCEPTED; needed for future Python 3.8
Revision 1.9 / (download) - annotate - [select for diffs], Fri Apr 26 13:13:56 2019 UTC (4 years, 7 months ago) by maya
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base,
pkgsrc-2019Q2
Changes since 1.8: +2 -2
lines
Diff to previous 1.8 (colored)
Omit mentions of python 34 and 35, after those were removed. - Includes some whitespace changes, to be handled in a separate commit.
Revision 1.8 / (download) - annotate - [select for diffs], Thu Apr 25 07:32:53 2019 UTC (4 years, 7 months ago) by maya
Branch: MAIN
Changes since 1.7: +2 -1
lines
Diff to previous 1.7 (colored)
PKGREVISION bump for anything using python without a PYPKGPREFIX. This is a semi-manual PKGREVISION bump.
Revision 1.7 / (download) - annotate - [select for diffs], Tue Jul 3 05:03:16 2018 UTC (5 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3
Changes since 1.6: +2 -2
lines
Diff to previous 1.6 (colored)
extend PYTHON_VERSIONS_ for Python 3.7
Revision 1.6 / (download) - annotate - [select for diffs], Mon Feb 26 02:25:28 2018 UTC (5 years, 9 months ago) by khorben
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1
Changes since 1.5: +1 -4
lines
Diff to previous 1.5 (colored)
Package the Python bindings for emulators/unicorn No functional change intended for Unicorn itself. Inspired by emulators/keystone and emulators/py-keystone. Tested on NetBSD/amd64.
Revision 1.5 / (download) - annotate - [select for diffs], Mon Feb 19 00:39:52 2018 UTC (5 years, 9 months ago) by kamil
Branch: MAIN
Changes since 1.4: +3 -3
lines
Diff to previous 1.4 (colored)
unicorn: Update to 1.0.1 upstream changelog ================== Version 1.0.1 April 20, 2017 Properly handle selected-architecture build. Fix compilation issues on PPC & S390x. Fix a memory leak on uc_mem_protect(). Support ARM big-endian. ARM: Correct instruction size of Thumb/Thumb2 code. Support read/write APSR register. ARM64: Support read/write NEON registers. Support read/write NZCV registers. Mips: Support read/write Mips64 registers. X86: Support read/write MSR. Haskell binding: update to the latest API. Python: allow not having PATH setup. Version 1.0 February 23, 2017 Lots of bugfixes in all architectures. Fix many memory leaking issues. New APIs: uc_query, uc_reg_write_batch, uc_reg_read_batch, uc_mem_map_ptr, uc_mem_regions, uc_free, uc_context_alloc, uc_context_save & uc_context_restore. New memory hook type: UC_HOOK_MEM_READ_AFTER. Add new version macros UC_VERSION_MAJOR, UC_VERSION_MINOR, UC_VERSION_EXTRA. Remove glib & pkconfig dependency. Windows: export a static lib that can be used outside of Mingw. ARM: Support MCLASS cpu (Cortex-M3). Better support for Thumb mode. uc_reg_write now can modify CPSR register. Add some ARM coproc registers. ARM64: uc_reg_read & uc_reg_write now handles W0-W31 registers. X86: Fix 16bit address computation. Fix initial state of segment registers. Windows: fix a double free bug in uc_close. 3 new bindings: Haskell, MSVC, VB6. Python: Better support for Python3 Fix memory leaking that prevents UC instances from being GC.
Revision 1.4 / (download) - annotate - [select for diffs], Sun Jan 1 14:43:39 2017 UTC (6 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1
Changes since 1.3: +2 -2
lines
Diff to previous 1.3 (colored)
Add python-3.6 to incompatible versions.
Revision 1.3 / (download) - annotate - [select for diffs], Sat Jul 9 13:03:47 2016 UTC (7 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3
Changes since 1.2: +2 -2
lines
Diff to previous 1.2 (colored)
Remove python33: adapt all packages that refer to it.
Revision 1.2 / (download) - annotate - [select for diffs], Sat Dec 12 23:23:46 2015 UTC (7 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base,
pkgsrc-2016Q2,
pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4
Changes since 1.1: +3 -1
lines
Diff to previous 1.1 (colored)
Mark as not ready for python-3.x.
Revision 1.1 / (download) - annotate - [select for diffs], Sat Dec 12 01:26:39 2015 UTC (7 years, 11 months ago) by kamil
Branch: MAIN
Import unicorn-0.9 as emulators/unicorn Unicorn is a lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU. Unicorn offers some unparalleled features: - Multi-architecture: ARM, AMM64 (ARMv8), M68K, MIPS, SPARC, and X86 (16, 32, 64-bit) - Clean/simple/lightweight/intuitive architecture-neutral API - Implemented in pure C language, with bindings for Python, Java, and Go - Native support for Windows & *nix (with Mac OSX, Linux, *BSD & Solaris confirmed) - High performance via Just-In-Time compilation - Support for fine-grained instrumentation at various levels - Thread-safety by design