[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / emulators / spim

File: [cvs.NetBSD.org] / pkgsrc / emulators / spim / Makefile (download)

Revision 1.28, Sat Mar 4 21:29:36 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.27: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.28 2006/03/04 21:29:36 jlam Exp $

DISTNAME=	spim-7.1
PKGREVISION=	1
CATEGORIES=	emulators
MASTER_SITES=	http://www.cs.wisc.edu/~larus/SPIM/ \
		ftp://ftp.cs.wisc.edu/pub/spim/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.cs.wisc.edu/~larus/spim.html
COMMENT=	MIPS R2000 Simulator

RESTRICTED=		"selling is not allowed"
NO_SRC_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_CDROM=	${RESTRICTED}

#DIST_SUBDIR=		${PKGNAME}

WRKSRC=			${WRKDIR}/${PKGNAME_NOREV}
HAS_CONFIGURE=		yes
CONFIGURE_SCRIPT=	./Configure
USE_IMAKE=		yes
USE_TOOLS+=		gzip lex
XMKMF=			${X11BASE}/bin/xmkmf # don't specify -a option

BUILD_TARGET=		y.tab.c depend spim xspim

pre-configure:
	@${RM} -f ${WRKSRC}/y.tab.*

pre-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/spim
	${CHMOD} a+rx ${PREFIX}/share/spim

post-install:
	@${ECHO} "Installing spim/xspim documentation"
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/spim \
		&& ${CHMOD} a+rx ${PREFIX}/share/doc/spim
	${INSTALL_DATA} ${WRKSRC}/Documentation/spim.tex \
		${PREFIX}/share/doc/spim
	${INSTALL_DATA} ${WRKSRC}/Documentation/*.id \
		${PREFIX}/share/doc/spim
	${INSTALL_DATA} ${WRKSRC}/Documentation/cycle.ps \
		${PREFIX}/share/doc/spim

.include "../../mk/bsd.pkg.mk"