The NetBSD Project

CVS log for pkgsrc/emulators/mednafen/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / emulators / mednafen

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2007Q4


Revision 1.2 / (download) - annotate - [select for diffs], Thu Nov 29 22:35:38 2007 UTC (16 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4
Changes since 1.1: +4 -4 lines
Diff to previous 1.1 (colored)

Update to 0.8.5:

0.8.5:

	Fixed a crashing bug when loading an uncompressed file and using the automatic IPS-patching feature when mmap() is available.

	PCE, PC-FX:  All SCSI CDROM commands are now logged in the debugger's log viewer(when logging is enabled, of course).

	Added group support to the debugger's log viewer.

	PC-FX:  Renamed the type of BIOS ROM font calls in the debugger's log viewer from "BIOS" to "ROMFONT".

	PC-FX:  BIOS filesystem syscall(for backup memory access) calls are now logged in the debugger's log viewer.

	PC-FX:  Added internal backup memory and external backup memory address spaces to the debugger's memory editor.

	PC-FX:  In the 263-line mode, line 262 is now reported as being during blanking time(as on a real PC-FX).  Fixes the annoying transparency layer
	flickering and other weird graphical glitches in Der Langrisser FX.

	Added setting "filesys.disablesavegz", to disable gzip compression when saving save states and backup memory.
	(In the case of backup memory, disabling gzip compression isn't supported for GB yet)

0.8.4:

	PC-FX:  Some RAINBOW registers weren't being reset on emulated system reset.  Fixed.

	PC-FX:  Added dummy support for the external bus reset register.

	PC-FX:  Altered the way garbage data is handled by RAINBOW to fix a graphics bug in the Tengai Makyu options screen.

	PC-FX:  Reworked a large part of the KING SCSI emulation code, and parts of the CDROM device emulation code.  Previously non-working-at-all games
	"Battle Heat" and "Tengai Makyu" work now.
	The non-anime game mode in "Tyoushin Heiki Zeroigar" works now.  "Der Langrisser FX" no longer locks up if you skip the intro movie.
	"Yuna FX" no longer locks up in one of the intro movies.
	These changes will cause some save state incompatibilities with previous versions of Mednafen.
	(Some of the SCSI changes also affect the PCE CDROM emulation, which may also result in save-state incompatibility issues, particularly if
	the save state occurred during a CDROM data transfer operation.)

	PC-FX:  Added setting "pcfx.cdspeed".  If you want to change this, read the documentation first!

	Cleaned up the video deinitialization code slightly, and fixed a few bugs in the OpenGL deinitialization code.

	PC-FX:  Reads from the dummy KING register 0x07 will now return 0xFF, per the devkit docs.

	PC-FX:  Reads from KING register 0x0B will now return the "DMA end" bit in D0 set correctly(at least, according to the developer docs).

	Fixed a compilation error after running configure with --disable-nes.

        PC-FX:  Reads from I/O port 0xFC0 will *now* return the current timer counter value.  The switch statement mask value was wrong...

	Removed the warning in the documentation about error correction of raw data track rips, as Mednafen will now perform simple correction
	using the EDC and L-EC data(since 0.8.4-rc3).  This could conceivably cause problems with naive hacks/translations/patches that neglect to update
	the EDC and L-EC data, so it can be disabled by setting the setting "cdrom.lec_eval" to 0.
	L-EC correction is based off code from dvdisaster(http://dvdisaster.net/).

	PCE, PC-FX:  Removed some debug printf()'s that were left in 0.8.4-rc3 by mistake.

0.8.4-rc3:

	PCE:  Added preliminary(it works, but the code needs to be cleaned) ADPCM support for HES rips.

	PCE:  Interrupts will be enabled with a CLI after a HES' init routine is called, to fix rips that neglect to do it themselves.

	PCE:  Added support for HES rips that try to write data where it really shouldn't be written(some CD-ROM game rips do this), though a warning
	will be printed the first time this occurs after loading.

	PCE:  Added sanity checks to the HES loader to prevent crashes if invalid data is present.

	PCE:  Reads from the I/O port will now return D7 as clear when emulating a PCE CD game.

	PCE:  ADPCM RAM is now reset(to 0) on emulated PCE reset.

	PCE:  Sprites trying to pull tile data from $8000-FFFF of VRAM will now be invisible(probably not correct, but trying to emulate indeterminate
	effects is too difficult :b).  Fixes a minor sprite garbage issue in Camp California.

	PCE, PC-FX:  Fixed VRAM DMA source/dest increment/decrement bits(the source and dest were flipped).  Fixes a problem with Fushigi no Yume no Alice.

	Moved some code in the source root directory to appropriate subdirectories.

	Added setting <system>.debugger.disfontsize, valid settings being "xsmall", "small"(default), "medium", and "large", to control the font
	size used to draw the disassembly text.  Note that there may be overlap with other parts of the debugger at font sizes larger than the default.

	Refactored a few address space and register group debugger support functions out of individual system code.

	Fixed various low-impact memory leaks.

	The version of Mednafen last run is now stored in the configuration file as a comment(this will be necessary for changes in 0.8.5 or later
	that will involve proper escaping/unescaping and quoting of strings, to prevent problems with extra whitespace added by manually editing
	the configuration file).

	Fixed state rewinding on big-endian machines, and removed some unnecessary operations from the state rewinding code path.

	Mednafen will now refuse to try to load ROM images larger than 64MiB, as a sanity check.

	mmap() and madvise() will now be used to load ROM images, assuming they're available(UN*X only, generally).

	Errors during automatic IPS patching are now fatal.

	Sped up loading gzip'ed ROM images.

	Removed a global variable from the NES emulation code that had invaded state.cpp.  Though, this makes the error message when trying to use
	save states with authentic Game Genie emulation very unhelpful...

	GBA:  Added support for loading a real GBA BIOS ROM image, using the setting "gba.bios".

	GBA:  Added the ability to specify the backup memory type for games by creating a file with the same name as the ROM image,
	with the extension replaced with "type", in the "sav" directory under the Mednafen base directory.
	 Example: SexyPlumbers.gba -> SexyPlumbers.type

	One or more of the following strings(on separate lines) may appear in the file:
		sram
		flash
		eeprom
		sensor

	Additionally, the flash size can be specified by specifying the size(real size, or divided by 1024) after the type, like "flash 128" or
	"flash 131072".

	PCE:  Improved noise LFSR and volume emulation, thanks to cgfm2 for the detailed information.

0.8.4-rc2:

	Added meaningful descriptions to the command.* settings.

	PC-FX:  Added an experimental feature to use mmap() to create a virtual 32-bit address space to speed up V810 instruction reads.
	Enable by setting "pcfx.use_mmap" to 1.  Of course, it won't work on 32-bit CPUs!  Please read the documentation, there are caveats!

	PC-FX:  Removed some redundant logic in the KING BG 8x1 drawing functions.

	PC-FX:  FX VCE and VDC port access are now emulated as 16-bit, as in the real PC-FX, instead of 8-bit.

	PC-FX:  Altered the debugger's memory peek and disassembly functions to not read the emulated memory map in the 0x80000000-0xEFFFFFFF region.
	(Reading those addresses can cause side effects, and this is a temporary workaround)

	PC-FX:  Changed the V810 memory read handlers to read RAM faster than BIOS ROM.  This will probably increase host CPU usage while in the BIOS
	loading screen, but decrease it in the actual game.

	PC-FX:  Altered the V810 opcode fetch logic to do 16-bit reads instead of 32-bit, fixing potential crash issues
	when Mednafen is run on CPUs that don't support unaligned memory accesses.

	PC-FX:  Factored-out a few address masks in the memory read and write handlers.

	PC-FX:  Replaced most of the V810 signed-variable bit-size converting code that uses conditional branches to code that uses 2 shifts,
	taking advantage of modern 2's-complement CPU's arithmetic right-shift capabilities.  It reduces generated machine code size slightly,
	and should provide a slight speed boost as well.

	PC-FX:  Optimized V810 address mode decoding by removing an unnecessary conditional jump.

	Added an important warning to the documentation regarding Mednafen's ripped CD image support:

		 Mednafen does *not* correct bit errors in the user data of "raw" data track rips.  It is strongly recommended to use
		 "cooked" data track rips(2048 bytes/sector for mode 1, not counting any subchannel data) with Mednafen.

	PC-FX:  Improved exception handling, and added untested emulation of the TRAP instruction.

	Debugger:  Rewrote the memory load and dump functions to be faster, and also to fix a bug in the load function that would
	trash memory if the user tried to load more data than the specified file contained.

	Debugger:  Using the Goto function will no longer cause memory edit mode to be exited.

	Debugger:  Fixed a bug that occurred when entering a prompt(goto, change charset, etc.) while in editing mode, that caused
	keyboard focus to be misdirected.

	SexyAL:  The ALSA driver will try to set smaller period sizes when lower playback rates are used.

	GBA:  Changed the heuristics used to detect SRAM/Flash usage, though they're still not perfect...if a game tries to use flash
	memory improperly, it could be detected as using SRAM instead, or silently corrupt parts of flash memory...

	GB:  Fixed sound register initialization on reset, fixes missing sound in A Boy and His Blob

	GB:  Slightly increased the contrast of GBC colors.

	GB:  Reworked blitting of mono GB colors for future features.

	GB:  Removed a redeclaration of a variable in the same scope in a function in gfx.cpp.

	Debugger:  Fixed PCE VRAM breakpoints to work with block memory transfer instructions.

	Debugger:  Fixed parsing of single-address breakpoints after range breakpoints.

	Mednafen will now print out SDL version information when it starts.

	(The Win32 build will now be distributed with SDL 1.2.12)

	Debugger:  Fixed -/+ opacity adjustment to not be done when entering text(such as in a dialog).

	Debugger:  Fixed null termination of the ASCII string buffer displayed in the memory watch section.

	PCE, PC-FX:  Fixed the frequency of the highest-frequency noise generation register setting, hopefully!

	PCE, PC-FX:  Changed the LFSR to 16-bit, and to use a maximized tap configuration, to make the noise sound a bit closer to a real
	PC Engine's(at least, in my opinion!  It still sounds slightly more bassy than a real PC Engine, but that might be due to filters
	on the PC Engine's sound output...).

	Non-power-of-2-sized-textures will not be used when a pixel shader is selected and enabled, to prevent a severe graphical corruption
	regression introduced in 0.8.3-beta.  I'm not sure if it's a problem with Mednafen's pixel shaders or the graphics card...

	SMS:  Fixed soft reset.

	SexyAL:  Removed smallc.c, and modified the OSS driver to use snprintf() instead of the single function smallc.c provided.

	SexyAL:  "sexyal.h" is now included before all other header files.

	SexyAL:  Revamped parts of the ALSA driver to fix reported lockup issues under certain conditions.

0.8.4-rc1:

	Added preliminary support for inputting text directly into the selected address space in the debugger's memory editor.

	Moved the temporal video blurring code in mednafen.cpp to vblur.cpp

	Added settings "filesys.snap_samedir", "filesys.sav_samedir", "filesys.state_samedir", and "filesys.movie_samedir", default 0, that when
	set to 1, will read/write the respective files from/to the same directory the game was loaded from.  If you want
	to use these, PLEASE read the documentation first, there are caveats!

	PCE CD, PC-FX:  Added support for MS WAV file offsets and lengths in TOC files.

	PCE CD, PC-FX:  Fixed a bug that caused CD-DA playback to be off by one sector(the first sector specified was being skipped).

	Began work to allow settings to be temporarily overridden during netplay and movie playback.

	PCE, PC-FX:  Added settings "pce.disable_softreset" and "pcfx.disable_softreset", default 0, which when set to 1 will disable
	simultaneous pressing of RUN and SEL.  The current implementation kind of abuses the driver-side code that disallows opposing diagonal buttons
	being pressed at the same time, so if we ever change that (undocumented) feature to go with the last-pressed direction rather than
	clearing both, the description of these settings in the documentation will need to be updated.

	PCE CD, PC-FX:  Read operations and CD-DA playback will now be stopped when the RST signal is asserted(fixes soft reset issues on PCE CD
	games).

0.8.3-beta:

	Fixed an OpenGL function typedef in drivers/opengl.h.

	PC-FX: Writes and reads to the KING and FXVCE chips "mapped" in parts of 0xA0000000 through 0xBFFFFFFF will now go through the respective
	data port write handlers, instead of directly to KRAM or palette RAM.

	If non-power-of-2-sized OpenGL textures are not available, and bilinear interpolation or a pixel shader is enabled, and the emulated
	system resolution changes(such as on the PCE), two lines of black pixels will be written to the texture buffer to prevent the display
	of multi-colored garbage at borders, though the right+bottom borders will still be slightly darker than they should be...

	PC-FX:  Added support for VDC data port writes via writes to 0xB4000000-0xB7FFFFFF and 0xB8000000-0xBBFFFFFF in the V810's
	memory map.  Fixes major graphical problems in "Super Power League FX".

	Updated the srwcompressor description in mednafen.cfg.

	PC-FX:  KING BG1-3 scroll registers are now emulated as 10-bit instead of 11-bit(BG0's are still 11-bit), and BG1-3 virtual
	screen size is now limited to 512x512(BG0 is still 1024x1024), per the official developer documents.

	Non-power-of-2-sized OpenGL textures will now be used if the "GL_ARB_texture_non_power_of_two" extension is detected.

	Fixed a bug that sometimes would cause black screens when using the "sdl"(non-default) video driver(SDL surface per-pixel alpha blending
	was enabled when it shouldn't have been).

	PCE:  Fixed a line clearing bug when BG is disabled that was causing some minor graphical garbage on some games that
	use multiple horizontal resolutions per frame.

	Changed some nonsensical #ifdef statements that were intended to always evaluate as false with "#if 0".

	Renamed SYSTEM_CLOCK to System_Clock in scsicd.cpp to work around a potential macro conflict on OSX.

	PC-FX:  Added partial support for NEC's "scan" SCSI command, used in the BIOS' CD-DA player screen.

	PC-FX, PCE CD:  Revamped parts of the subchannel emulation code.  The PC-FX BIOS CD player screen's time display works now.  Also, an important
	note regarding cdrdao "TOC" files and "RW_RAW" subchannel data was added to the documentation.

	PC-FX:  Fixed a bug in the KING BG0 scrolling+rotation code for 16-color and 4-color backgrounds with BATs that was causing graphical
	corruption in the PC-FX BIOS CD player screen.

	Fixed a compilation error when --disable-debugger was passed to the configure script.

0.8.2-beta:

	Added blargg's experimental blz compressor, for use with state rewinding(change the setting "srwcompressor" to use it).
	(This was added a while back, after 0.8.1, but I forgot to document it)

	SMS,GG:  Added missing default key configurations.

	PC-FX:  Added untested emulation of scaling+rotation in 4-color KING BG mode.

	PC-FX:  Added emulation of scaling+rotation in 16-color KING BG mode.  Fixes a problem with the background in the last stage of Zenki.

	PCE:  Added VRAM size constants to the beginning of vdc.cpp, and modified the code to use them, to allow a certain crazy person to compile
	a custom version of Mednafen which emulates extra VDC VRAM.

	PCE:  Removed 0xEB as SBC immediate in the disassembler(it was left over from the 6502 disassembler).

	Changed setting type of setting "vdriver" to a string, with possible values "opengl" and "sdl"(and "0" and "1" for backwards compatibility,
	of course).

	PCE:  Set the default char set in the debugger's memory viewer to shift_jis.

	PCE:  Fixed a missing #include <iconv.h> in debug.cpp.

2007-6-17:

	PC-FX:  Improved VCE<->VDC<->KING scanline timing to fix a lockup issue in Anime Freak Vol 4(polling the FX VCE raster counter register
	vs VDC VBlank IRQs).  Unforunately, this change has caused some 1-line graphical glitches in games that do "raster effects".  This
	may be solved once/if V810 emulation has accurate cycle counts, which would require emulating instruction cache and prefetch logic. -_-;

	Fixed branch traces display in the debugger, it was broken to only display half of them twice sometime since 0.8.1.

	PC-FX:  Optimized RAINBOW JPEG-like decoding by using a static implementation of bit fetching functions(instead of a class).

	PC-FX:  Added untested emulation of the CAXI V810 instruction.

	PC-FX:  The RAINBOW transfer block count register is now emulated as being 5-bits instead of 16-bits, fixes screen issues(blue blue!)
	after defeating the snake monster in Zenki.

	PC-FX:  If a KING BG is set to BAT+CG mode, but is missing a BAT fetch microprogram, it will now be drawn in CG mode(previously, the BAT
	data was simply being forced to 0, which was wrong). It's confirmed on a real system.  Fixes missing graphics in "Tonari Princess no Rolfee".

	PC-FX:  Fixed transparency testing with 16M color KING backgrounds(only 1 Y component of every 2 pixels was being checked, now
	both are checked).

        PC-FX:  Implemented back cellophane support.  Fixes fadeouts in "Lunatic Dawn", fadeins in "Team Innocent", and screen darkening issues
	during dialogue in "Last Imperial Prince"(and also exposes a bug that LIP probably has on a real system too, wherein CCR isn't reset
	to black after the dialogue is over, leaving the upper and lower parts of the screen outside the play area slightly dark greenish).
	The hindmost color when mixing the layers is now set to palette entry #0, except when all layers are disabled(set to black),
        or front cellophane(set to black) or back cellophane(set to value in CCR) is enabled.

	PC-FX:  Added emulation of the expansion backup RAM.  While not particularly necessary since Mednafen already emulated backup memory
	separately for each game, it does give a few extra save slots to some games(such as Miraculum ^_^).

	Added opacity control(-/+) to the debugger.

	Added an always-on zero page view to the CPU debugger for NES and PC Engine.

        Reduced the size of the game thread event queue to a somewhat saner size, and added extra buffering so that its mutex is only locked for
        a minimal amount of time to eliminate the chances of deadlock with this mutex.

	GBA:  Fixed a bug that caused only half of the legacy wave sound channel's sample data to be saved.

	GB:  Updated to Gb_Snd_Emu 0.1.5, fixes hanging note problems on some games, and cleaned up the sound save state code.

2007-5-30:

	Added preliminary Sega Master System and Game Gear emulation based off of SMS Plus.

	Factored the remaining state rewinding code out of the individual systems' code.

	Fixed a minor visual bug when using state rewinding(also with save states, but it's not really visible) with the NTSC blitter.

	Simplified how state rewind requests are passed to the emulation code, and fixed a small bug when using state rewinding with
	frame advance(now, a rewind will only occur if the state rewind button is held down while the frame advance button is pushed).

	Changed a local variable name in selblur.cpp to fix compilation on OS/X(and maybe PPC in general?), thanks to Matt Beaumont
	for pointing out the conflict with a definition in altivec.h.

	PCE:  Fixed cycle counts for BRA and BSR(they were 1 too high).

	PC-FX:  Reads from I/O port 0xFC0 now return the current timer counter value.

	Parameters to MDFNI_Emulate() and the internal system Emulate() functions are now passed through a structure, to allow
	for easier future expansion.

	PCE, PC-FX:  Fixed audio track reading from physical CDs on big-endian platforms.

	NES:  Fixed a bug that caused an emulator crash if Game Genie-style cheats were enabled at the same time as authentic Game Genie
	emulation was enabled.

	Added setting "srwframes", which controls the number of save states to keep when state rewinding is enabled.

	Debugger:  Fixed a bug that caused a crash if a PC breakpoint was triggered while the debugger screen was disabled.

	Added an experimental logging feature to the debugger, currently only used by the PC-FX emulation code, to log CD-ROM read commands
	and calls to the PC-FX BIOS' glyph bitmap address function, both of which should be quite helpful in translation work...

	PCE, PC-FX:  Moved the mouse sensitivity adjustments to the driver side to fix mouse emulation with network play and movies
	when using non-default pce.mouse_sensitivity/pcfx.mouse_sensitivity settings.

	Added a few more entries to the in-emulator help screen.

	PC-FX:  Increased the keyport latch delay, and added emulation of the PC-FX mouse.

	PC-FX:  The keyport data ready flag is now reset only on low reads from the keyport data registers.

	PCE:  Fixed disassembly of the BSR instruction.

	NGP:  Fixed Z80 emulation cycle counts(they were far too low), and fixed emulation of the EI delay.

	GB:  Reworked various things, including Z80 interrupt and HALT emulation.  GameBoy emulation will be a bit more CPU intensive now,
	and save states from older versions won't work with this version(sorry!).  These changes could easily break some games, but...at least
	"A Boy and His Blob" works now!

	GBA:  Changed the file type detection code to reduce the chance of false positives.

	PCE:  Files with the extension "sgx" will now be treated as raw SuperGrafx ROM image files(AKA SuperGrafx emulation will be enabled).

	NES:  Refactored the file type detection code, so that emulation data structures and memory won't be initialized unless it's
	a recognized file type.

	NES:  NSF(but not NSFE) game/album name, artist, and copyright strings are now trimmed of leading and trailing whitespace.

	Added MDFN_trim(), MDFN_rtrim(), and MDFN_ltrim() functions.

	WonderSwan:  Fixed a buffer overflow bug in the sprite drawing code.

	GBA:  Flash and SRAM save games are now stored gzip-compressed.

	PCE:  Fixed raw bytes display of relative branch instructions in the disassembler.

	PC-FX:  Added CD-ROM data tracks to the memory debugger/viewer, read-only, however.

	The selected character set in the memory debugger/viewer will now be saved for that emulated system when exiting.

	Fixed text search in the memory debugger/viewer(iconv() was being called before the variables passed to it were initialized, oopsie).

	Simplified the scrolling code in the memory debugger/viewer, the line containing the cursor will now always be centered vertically
	on the screen.

	PCE:  Fixed an ambiguous if() statement in huc.cpp in the BRAM emulation code.

	GB:  Fixed a semi-ambiguous boolean math statement in the cpu emulation code.

	Fixed an ambiguous else statement in the throttling code in drivers/main.cpp

	NGP:  Neo Geo Pocket emulation code is now compiled with -fno-strict-aliasing to work around issues in the TLCS-900h code.

	GBA:  Removed unused ELF code.

	Fixed some implicit conversions of const char * to char *. (stupid putenv() prototype grumble mumble)

	<stdlib.h> is now included in "mednafen.h", added notes to README about system header files automatically included,
	and removed inclusions of such header files in source code files that include mednafen.h(most do, and should).  This change
	was brought about by gcc 4.3...it may not be the best way in regards to compile-performance wise, but it is more convenient
	and safer than #include'ing the system headers manually(and forgetting to >_>).

	Modified instances of "Makefile.am" to stop including the top directory in the include search path, and removed the symlink of
	config.h to include/config.h, and fixed the references to "config.h" in intl/Makefile.in.

	PCE:  Made hes.cpp use MDFN_de32lsb() and MDFN_de16lsb() from endian.cpp.

	PCE:  Changed some instances of free() to MDFN_free().

	GBA:  Un-inlined the CPUWriteMemory() function.

	GBA:  Rewrote parts of the save-game(flash, eeprom, sram) code to make more sense!  EEPROM data is now stored with a file extension "eep".

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>