File:  [cvs.NetBSD.org] / pkgsrc / emulators / mame / Attic / Makefile.common
Revision 1.7: download - view: text, annotated - select for diffs
Wed Oct 3 12:55:15 2012 UTC (12 years, 6 months ago) by asau
Branches: MAIN
CVS tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4, HEAD
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

# $NetBSD: Makefile.common,v 1.7 2012/10/03 12:55:15 asau Exp $
#
# used by emulators/mame/Makefile
# used by emulators/mess/Makefile

CATEGORIES=		emulators
EXTRACT_SUFX=		.zip

MAINTAINER=		wiz@NetBSD.org
HOMEPAGE=		http://www.mamedev.org/
LICENSE=		mame-license

RESTRICTED=		selling is not allowed
NO_SRC_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_CDROM=	${RESTRICTED}

DEPENDS+=		liberation-ttf-[0-9]*:../../fonts/liberation-ttf

WRKSRC=			${WRKDIR}

# separate distinfos though, so don't forget 'make mdi' when
# adding or changing patches
#PATCHDIR=		${.CURDIR}/../../emulators/mame/patches

USE_LANGUAGES=		c c++
USE_TOOLS+=		gmake pkg-config
UNLIMIT_RESOURCES+=	datasize
MAKE_FILE=		makefile
# 0.141 has too many conversion warnings
MAKE_ENV=		NOWERROR=1

.  include "../../mk/endian.mk"
.if ${MACHINE_ENDIAN:Mbig}
MAKE_FLAGS+=	BIGENDIAN=true
.endif

SUBST_CLASSES+=		exe
SUBST_SED.exe=		-e 's,$$(PREFIX)$$(PREFIXSDL)$$(NAME)$$(SUFFIX)$$(SUFFIX64)$$(SUFFIXDEBUG)$$(SUFFIXPROFILE),$$(PREFIXSDL)$$(NAME)$$(SUFFIX)$$(SUFFIXDEBUG)$$(SUFFIXPROFILE),'
SUBST_FILES.exe=	makefile
SUBST_STAGE.exe=	post-patch
SUBST_MESSAGE.exe=	Fixing executable name.

.include "../../devel/GConf/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../devel/SDL_ttf/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../textproc/expat/buildlink3.mk"
.include "../../x11/libXinerama/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>