The NetBSD Project

CVS log for pkgsrc/emulators/libretro-desmume/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / emulators / libretro-desmume

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.12: download - view: text, markup, annotated - select for diffs
Sun May 31 20:35:55 2020 UTC (4 years, 7 months ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, HEAD
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +4 -17 lines
libretro-desmume: convert to core.mk

Revision 1.11: download - view: text, markup, annotated - select for diffs
Tue May 26 09:45:14 2020 UTC (4 years, 7 months ago) by nia
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +6 -2 lines
libretro-*: Support Darwin by cargo-culting SOEXT. Remove bsdtar hack.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Mon May 20 10:32:32 2019 UTC (5 years, 8 months ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +3 -5 lines
libretro-desmume: Don't define __STDC_FORMAT_MACROS, this uses C++11.

Set USE_LANGUAGES to the proper value instead, so redefining the macro
isn't needed.

Bump PKGREVISION.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Sun May 12 09:49:39 2019 UTC (5 years, 8 months ago) by nia
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -5 lines
libretro-desmume: Fix build with older libpcap, hopefully properly this time.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Thu May 9 14:39:09 2019 UTC (5 years, 8 months ago) by nia
Branches: MAIN
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +3 -3 lines
libretro-desmume: Update to 20190426

Changes include:

* Firmware: Fix various endianness issues.
* GPU: Do some code cleanup of the display capture code.
* Render 3D: Improve the overall rendering accuracy of Edge Mark.
* GPU: Fix a bug where using VRAM as a display capture source would
sometimes cause graphical glitches under certain conditions.
* OpenGL Renderer: Rework the rendering shaders so that the shader
program code is more dynamically generated.
* OpenGL Renderer: Replace the accuracy/performance tradeoff "Enable
Depth Equals Test Tolerance" with "Enable NDS-Style Depth Calculation",
where disabling this option allows the host GPU to natively calculate
depth which significantly improves performance in many games.
* OpenGL Renderer: Eliminate the requirement for 66 varying floats in
the Fog shader by replacing the varying floats with constants.
* OpenGL Renderer: Fix bug where the OpenGL renderer would completely
fail to run if the user's ancient GPU doesn't support shaders.
* OpenGL Renderer: Do some minor performance improving tweaks.
* OpenGL Renderer: Remove the material_6bit_to_float LUT, since we
already have an equivalent existing LUT -- divide6bitBy63_LUT.
* OpenGL Renderer: Mitigate some of the performance penalty of using
the NDS Style Depth Calculation option.
* OpenGL Renderer: Do some minor efficiency, stability, and
consistency tweaks.
* OpenGL Renderer: Do some minor shader efficiency tweaks.
* OpenGL Renderer: Fix some interactions between Edge Mark and the
Special Zero Alpha Blending option.
* OpenGL Renderer: More minor shader efficiency tweaks when using the
NDS Style Depth Calculation option.
* types.
* GPU: Working engine buffers are now set up in advance,
asynchronously, starting after line 191.
* GPU: Significantly improve the performance of HD rendering for many
3D games.
* GPU: Fix graphical glitch that can occur when frameskip is enabled,
running a custom resolution on a multicore CPU system.
* Video Filters: Fix an issue where the internal buffers were not
created using a guaranteed alignment, possibly causing a segfault on
AVX2-enabled systems.
* OpenGL Renderer: When rendering the main geometry, adjusts all
Z-positions in the vertex shader so that Z is more likely to naturally
fall between the depth range of 0.
* Render 3D: Simplify the code a little by removing the working
Polygon ID buffer for clear images.
* OpenGL Renderer: Fix a bug where Fog rendering would fail when used
with MSAA.
* OpenGL Renderer: Improve the overall reliability of CPU-to-GPU
buffer writes, fixing a bug where certain polygons would intermittently
flicker in some games.
* OpenGL Renderer: Fix a bug where the incorrect buffer would be
cleared when trying to clear the Fog attributes buffer while Edge Mark
is disabled.
* OpenGL Renderer: In an effort to try and reduce graphical glitches
whenever users try to run enhancements that were never native to the
NDS to begin with, the texture sampling method is now being forced to
clamp for polygons with texture coordinates of either 0.
* OpenGL Renderer: Reduce some buffer related synchronization in
BeginRender().
* OpenGL Renderer: Fix an occasional crashing bug that may occur when
initializing the Clear Image textures.
* OpenGL Renderer: Before rendering, determine the list of clipped
polygons, and then only render the clipped polygons, just like how
SoftRasterizer does it.
* OpenGL Renderer: Revert the texture sampling hack in commit 02cd950
-- it causes graphical glitches in Sands of Destruction, especially
visible within the Sky Gaol.
* GFX3D: The polygon clipping stage now occurs before any polygon
sorting, allowing for the sorting of smaller lists.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Thu May 9 14:17:02 2019 UTC (5 years, 8 months ago) by nia
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +5 -1 lines
libretro-desmume: Fix build with libpcap-1.8.1

Revision 1.6: download - view: text, markup, annotated - select for diffs
Thu Jan 3 21:51:52 2019 UTC (6 years ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -1 lines
libretro-desmume: include libpcap.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Dec 18 16:54:24 2018 UTC (6 years, 1 month ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +13 -12 lines
emulators/libretro-desmume: Update to 20181207.

No active changelog.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue Oct 2 21:09:29 2018 UTC (6 years, 3 months ago) by nia
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +5 -1 lines
emulators/libretro-*: SunOS linker fixes.

libretro makefiles pass flags to the linker that aren't understood by
SunOS ld. Add BUILDLINK_TRANSFORMs to remove those flags.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Thu Sep 27 20:22:26 2018 UTC (6 years, 3 months ago) by tnn
Branches: MAIN
CVS tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -1 lines
libretro-desmume: needs -D__STDC_FORMAT_MACROS

It tries to define it in the source code, but does so too late,
after inttypes.h has already been pulled in. Just define it in CXXFLAGS.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Tue Aug 14 13:08:57 2018 UTC (6 years, 5 months ago) by nia
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2 lines
Use "${MACHINE_ARCH} ==" for x86_64 and i386 instead of the :M pattern.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sat Aug 11 12:57:23 2018 UTC (6 years, 5 months ago) by nia
Branches: MAIN
libretro-desmume: add version 20180807.

Libretro is a simple but powerful development interface that allows for the
easy creation of emulators, games and multimedia applications that can plug
straight into any libretro-compatible frontend. This development interface is
open to others so that they can run these pluggable emulator and game cores
also in their own programs or devices.

DeSmuME is a Nintendo DS emulator.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>