[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / emulators / gns3-gui

File: [cvs.NetBSD.org] / pkgsrc / emulators / gns3-gui / Makefile (download)

Revision 1.4, Fri Dec 4 20:45:16 2020 UTC (3 years, 2 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.3: +2 -2 lines

Revbump packages with a runtime Python dep but no version prefix.

For the Python 3.8 default switch.

# $NetBSD: Makefile,v 1.4 2020/12/04 20:45:16 nia Exp $

DISTNAME=	gns3-gui-2.2.1
PKGREVISION=	2
CATEGORIES=	emulators
MASTER_SITES=	${MASTER_SITE_PYPI:=g/gns3-gui/}

MAINTAINER=	markd@NetBSD.org
HOMEPAGE=	https://github.com/GNS3/gns3-gui
COMMENT=	GNS3 network simulator - Graphical user interface package
LICENSE=	gnu-gpl-v3

PYTHON_VERSIONS_INCOMPATIBLE=	27

DEPENDS+=	${PYPKGPREFIX}-distro>=1.3.0:../../devel/py-distro
DEPENDS+=	${PYPKGPREFIX}-psutil>=2.2.1:../../sysutils/py-psutil
DEPENDS+=	${PYPKGPREFIX}-jsonschema>=2.6.0:../../textproc/py-jsonschema
DEPENDS+=	${PYPKGPREFIX}-raven>=5.23.0:../../www/py-raven
DEPENDS+=	${PYPKGPREFIX}-qt5-[0-9]*:../../x11/py-qt5

# we have newer jsonschema and it seems fine
SUBST_CLASSES+=		inst
SUBST_STAGE.inst=	pre-configure
SUBST_FILES.inst=	requirements.txt
SUBST_SED.inst=		-e "s:jsonschema==2.6.0:jsonschema:"

post-install:
	chmod go-w,a-x ${DESTDIR}${PREFIX}/${PYSITELIB}/gns3/ui/*.ui
	chmod go-w,a-x ${DESTDIR}${PREFIX}/${PYSITELIB}/gns3/modules/*/ui/*.ui

.include "../../lang/python/egg.mk"

.include "../../mk/bsd.pkg.mk"