The NetBSD Project

CVS log for pkgsrc/emulators/emulationstation/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / emulators / emulationstation

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2020Q1-base


Revision 1.25 / (download) - annotate - [select for diffs], Tue Mar 24 15:52:38 2020 UTC (4 years ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.24: +6 -7 lines
Diff to previous 1.24 (colored)

emulationstation: Update to 2.9.0

5schatten (2):
      CMakeList.txt: added CMAKE_FIND_ROOT_PATH to detect RPi & Mali OpenGLES libs & headers
      CMakeList.txt: added option to conditionally enable libCEC

Benjamin D (1):
      Add metadata from the detailed view to the grid view

Benjamin Sinkula (1):
      Update README to reflect Eigen3 dependency removal

Christopher Martin (1):
      fix audio mute during loop

Conn O'Griofa (6):
      InputManager: improve trigger axis calibration
      Implement filterTrigger for PS3 controllers
      filterTrigger: generalize for more controllers
      filterTrigger: filter negative trigger axis event after positive axis detection
      filterTrigger: filter negative trigger axis event after positive axis detection

Cristi Mitrana (16):
      Fix the `opacity` for the hold-to-skip message.
      Add ScreenScraper.fr as scraping source
      Fix UI Kiosk mode filters applying also to Kid mode. This fixes games marked both as hidden and kid not being shown in Kid mode.
      Add checks for the Scraper, when the settings no longer match the list of available scrapers.
      Remove the TGDB scraper from the list of enabled scrapers
      Fix ScreenScraper search by filename
      Fix getThumbnailPath ignoring the 'image' tag when 'LocalArt' is not set
      Minor documentation formatting and updates
      scraper: change ScreenScraper API URL
      Fix 'Last Played' collection crash.
      Makes the display of system's name in Collections configurable.
      Added an option to force the compilation of Raspberry Pi specific bits. Useful when the VC4 legacy driver is not used for GLES, but usage of 'omxplayer' is still desired.
      Eliminate duplicate requests when multiple platforms are present for a system
      Add scraping support for ChannelF, OpenBOR, Solarus and ZX81 Sinclair
      fix 'DateTimeEditComponent' output formatting.
      getGenericPath: don't remove trailing '/' when path is '/'.

Dan Leach (1):
      Add Game Info Font Settings to OMX Player

Fabrice CARUSO (2):
      Add --home command line to set custom home path + make windows version natively portable by detecting if .emulationstation is a subfolder of the exe.

Hanno Zulla (9):
      Fix SVG resize issue for option_arrow.svg.
      Updates artwork for input config, adds compass directions.
      Update artwork for busy indicator.
      Replace folder bitmap with svg artwork.
      Replace blank_game bitmap with svg cartridge artwork.
      Clean up checkbox svg artwork.
      Update svg artwork.
      Update star svg artwork.
      Add BigBen kid's PS3 gamepad 146b:0902 to filterTrigger()

Jacob Mullins (1):
      Fixed a quirk in the Clion PR

John Rassa (95):
      updated theme docs to add details about horizontal_wheel
      set default value for ImageDebug option
      fix platform name for game and watch
      fix git submodule command
      document color option for RatingComponent
      set curl to follow redirects to fix scraper error update to use legacy thegamesdb url
      add theme support for text and line spacing for logo text in system carousel
      create new DateTimeComponent
      allow variables in import elements
      add 'visible' theme element
      update nanosvg to latest version
      support for color gradients in drawRect and ImageComponent
      cleanup duplicate theme code in Image/Video components
      ensure change flag cleared for new FileData
      clean up opacity handling for ImageComponent, RatingComponent
      Grid updates. Animate scrolling option, autoLayout option, center selection option, scroll loop option, image source option
      initial github actions config.  runs basic build under ubuntu
      fix assignment of gridtile theme properties
      add 'animate' to theme properties for imagegrid; fix blurriness on image upscaling
      repopulate list after applying theme to ensure image source is updated

Jools Wills (93):
      cosmetic - indent
      add setting for searching for local game art - defaults to off
      Revert "Revert "Use local game art ( image, marquee and video ) from romfolder/images if the gamelist didn't specify a path""
      added ISSUE_TEMPLATE.md from RetroPie-Setup to direct users to the forum first

Justin Kinnaird (1):
      Use platform-specific methods for exePath

Keith F. Kelly (2):
      Clarify the DELETE button's warning text.
      Add support to built-in thegamesdb.net scraper for TurboGrafx CD platform.

Koerty (30):
      Rename gridSize to gridDimension in ImageGridComponent.h
      Add automatically generated Clion files to gitignore
      Enable the grid view for developers
      Use shoulder buttons for quick system swap in the grid view - Allow quick system swap using left/right shoulder in the grid view - Update the help prompt of the grid view accordingly
      Rewrite the grid display code
      Small fix to the populateList function of the GridGameListView
      Fix ImageComponent flipY
      Fix bad tile position when close to the last row and last row is full
      Update the grid's help prompt
      Add base theming syntax for the grid
      Disable random game selection in retropie settings menu
      Add GridTileComponent and base theming syntax
      Add cropping and minSize to ImageComponent
      Add scroll direction to the grid
      Clean ImageGridComponent code
      Fix calcGridDimension being called before mScrollDirection
      Add "origin" theming element for help prompt
      Add the new metadata field md_title to grid, video and detailed views
      Add grid default image and folder image
      Fix md_name not fading out
      Rewrite NinePatchComponent to handle images of all sizes
      Change grid creation flow
      Enable the grid view for everyone
      Partially display the last row if grid number of row isn't an integer
      NinePatch now position correctly when origin is different from 0 0
      Add 3 new theming properties to the grid tile background
      Add extra buffer rows to the grid to load images ahead
      Fix horizontal scrolling grid bugs
      Fix grid padding being 2 times smaller than it should be
      Grid fix freeze with big game collections

Lubosz Sarnecki (1):
      Loading screen: Be more verbose about what is happening.

Marian Flor (1):
      Fixed rounding.

Markus Pointner (1):
      extend list of mame bios files to hide

Mátyás Mustoha (1):
      Remove leftover debug code

Rael Gugelmin Cunha (5):
      More restriction on kids mode (#431)
      Skip mame bios/devices
      Removing no more used mameNameToRealName
      Work with dpad and analogs
      Fixing kids/unattended mode

Shanti Gilbert (1):
      Fixes compiling when Renderer_GLES10 is used

Spongman (1):
      Update GamesDBJSONScraper.cpp

Tomas Jakobsson (47):
      Replaced boost::posix_time with Utils::Time
      Implement --screensize and --screenoffset
      Eliminated the need for boost::xpressive, boost::algorithm and boost::variant
      Remove all namespace fs = boost::filesystem;
      Add getDirContent, getHomePath, getCWDPath, canonicalPath, absolutePath, resolvePath, resolveSymlink, getExtension, removeFile, isAbsolute, isRegularFile, isDirectory, isSymlink, isHidden and isEquivalent Rename makeGeneric to genericPath and escapePath to escapedPath
      Minor misc fixes and warning silencers
      Add support for --screenrotate
      Fix --screenrotate to work with --screensize and --screenoffset
      Fix omxplayer when using --screensize, --screenoffset and --screenrotate
      Update and rename some Utils::FileSystem functions
      Move more functionality from Util.cpp to utils/StringUtil.cpp in the quest too remove the need for boost
      Switched over the last functions in Utils.cpp to Utils::String, step 3 of 5 in the quest to remove boost::filesystem
      Remove the last traces of boost::filesystem::operational, this is PR 4 of 5 in the boost::filesystem removal quest
      The final traces of boost has been eliminated
      Fix thumbnail and image to be separated as I think it was originally meant to be.
      Fix mStaticImage to use setResize
      Fix start and offset not being reset for each invalidChar tested in Utils::FileSystem::GetEscapedPath
      Remove builtin resources
      Show build date and time when starting ES with --debug
      Move MameNameMap out of the source and into mamenames.xml
      Fix the Fedora instructions
      Fix double //
      Rename MameNames::names to MameNAmes::mNamePairs
      Add Utils::String::toLower and Utils::String::format
      Suggest vector access methods to be inlined
      Fix getHomePath crash when the environment variable isn't set
      Remove trailing '/' in getGenericPath
      Fixes for roms larger than 2GB
      Reset "StartupSystem" to "" if the requested system doesn't exist
      Fix missing / in custom collection path
      Silence warnings
      Add support for fullscreen borderless window
      Fix FilesystemUtil::isEquivalent by eliminating it entirely
      Fix Transform4x4f which was broken in many, many ways, but just out of pure luck worked anyway
      Add Transform4x4f::orthoProjection
      Redid the entire Renderer Made all components render using triangle strips
      Eliminate drawRect that takes int's and make sure everything uses the float version properly, this way everything is rounded the same way Only round the transforms when setting them on the GPU, to make sure everything is rounded the same, but only at the final moment
      Make sure all vertices are properly rounded

Zachary Burke (1):
      Majorly improved performance when fetching Mame names.

acrummyidea (1):
      Adding new scraper GamesDBJSONScraper. The scraper uses the new GamesDb JSON API. On the first run it downloads a few resource files needed to intepret the otput of game search api calls these resources go into ~/.emulatiostation/scrapers The resource files include the list of developers and the list of publishers. To update the lists simply delete the files and relaunch emulationstation. Searching a game by id (GamesDB id) is done as before by manually edit the search query and query for "id:<gameId>".

hissingshark (1):
      Vero4k autodetection and volume mixer fix

joemommasfat (1):
      add sortname to gamelist.xml to sort by a different name

jrassa (4):
      fix resolvePlaceholders to handle multiple variables in a single string
      implement debug rects for images similar to text components
      implement horizontal wheel for system carousel.  fix image rotation bug in carousel
      implement scripting support

pjft (16):
      Fixing first favorites not updating index
      Limiting last played count to 50
      Fixing common path detection
      Fix empty collections not showing up in Carousel for Full mode
      Fix crash when scraping folders
      Fixing path generation on the Pi for getDirContents
      Fix crash when changing theme from within a collection that'll no longer be present at the carousel level
      Fix for image resize flicker when using MaxSize
      Final Fix for resizing images
      Adjust mutex for SVG initialization and resizing
      Fix for unset AudioCard setting
      Change handling of screensaver to FileData only and respect UI Mode
      Fix jagged font in games list
      Fix Kiosk Favorites not registering

placroix74 (2):
      Code formatting
      [ScreenSaver] Consume input on cancel

tminit (1):
      Changed Audio settings to be much more flexible

verybadsoldier (2):
      save also metadata that have default values. they might not had default values on start so they have to be saved
      save also metadata that have default values. they might not had default values on start so they have to be saved

yodatak (1):
      Update instructions for Fedora compilation

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>