[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / emulators / compat51

File: [cvs.NetBSD.org] / pkgsrc / emulators / compat51 / Makefile (download)

Revision 1.1, Sun Feb 17 17:24:08 2013 UTC (10 years, 9 months ago) by spz
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1

NetBSD compat packages. They chain each other so if you're on NetBSD-6.0
and want NetBSD-5.0 compatibility, compat50 will depend on compat51 to
bridge the gap. There is currently no need for a compat52, nor for a
compat60-x11.

The compat tarballs may be larger than strictly necessary.
Testing was 'lightly', so there's probably Room for Improvement (tm).

# $NetBSD: Makefile,v 1.1 2013/02/17 17:24:08 spz Exp $

COMPAT_PKG=		compat51	# for compat_netbsd/Makefile.common
NETBSD_VERSION=		5.1

HOMEPAGE=		http://www.NetBSD.org/releases/formal-5/index.html
COMMENT=		Shared libraries for NetBSD 5.1 compatibility
LICENSE=		2-clause-bsd AND modified-bsd AND isc

EMUL_PLATFORMS=		netbsd-alpha netbsd-arm netbsd-i386 netbsd-m68k	\
			netbsd-mipseb netbsd-mipsel netbsd-powerpc	\
			netbsd-sparc netbsd-sparc64 netbsd-x86_64

ONLY_FOR_PLATFORM=	NetBSD-5.[3-9]*-* NetBSD-[6-9]*-* NetBSD-[1-9][0-9]*-*

.include "../../emulators/compat_netbsd/Makefile.common"

DISTNAME=		compat51-${EMUL_ARCH}-${COMPAT_VERSION}
COMPAT_VERSION=		5.1

# should we get a 5.10 this rule would need to be amended
.if empty(OS_VERSION:M[0-4].*) && empty(OS_VERSION:M5.[3-9].*)
DEPENDS+=	compat60>=6.0:../../emulators/compat60
.endif

.include "options.mk"

.include "../../mk/bsd.pkg.mk"