The NetBSD Project

CVS log for pkgsrc/emulators/compat15/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / emulators / compat15

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.7 / (download) - annotate - [select for diffs], Sat Jan 18 23:30:47 2020 UTC (3 years ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, HEAD
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.

Revision 1.6 / (download) - annotate - [select for diffs], Sun Nov 3 19:24:32 2019 UTC (3 years, 3 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

emulators: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.

Revision 1.5 / (download) - annotate - [select for diffs], Thu Sep 26 09:44:48 2019 UTC (3 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.4: +3 -1 lines
Diff to previous 1.4 (colored)

compat15: no point checking RELRO on these binaries

Revision 1.4 / (download) - annotate - [select for diffs], Tue Nov 27 19:20:42 2007 UTC (15 years, 2 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.3: +2 -1 lines
Diff to previous 1.3 (colored)

Prevent the compat15 and compat16 packages from building on amd64
because those NetBSD releases didn't yet support amd64.

Before this change, pkgsrc would still try to install these packages
on amd64 if you manually entered the package directory and ran "make
install" because amd64 supports netbsd-i386 emulation.

Revision 1.3 / (download) - annotate - [select for diffs], Sun Oct 7 12:59:12 2007 UTC (15 years, 4 months ago) by kano
Branch: MAIN
CVS Tags: pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

fix obsolete URLs for www.NetBSD.org

close PR pkg/37071
reviewd by xtraeme@

Revision 1.2 / (download) - annotate - [select for diffs], Thu Aug 30 16:54:07 2007 UTC (15 years, 5 months ago) by jlam
Branch: MAIN
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

Don't rely on differences in the value of DISTNAME that rely on
"immediate" versus "lazy" evaluation of the value.  Just explicitly
define a variable (COMPAT_PKG) that holds the value that's needed in
each of the compat* packages, and use it within Makefile.common.

This was an attempt to solve PR pkg/36863, but it doesn't look like
pkglint or lintpkgsrc understand this more straightforward variable
construction either.

Revision 1.1 / (download) - annotate - [select for diffs], Tue Aug 21 22:49:11 2007 UTC (15 years, 5 months ago) by jlam
Branch: MAIN

* Support netbsd-* as a valid platform in EMUL_PLATFORMS.  Use the
  pkgsrc/emulator/compat* and pkgsrc/emulator/netbsd32_compat* packages
  to provide the necessary shared libraries to run dynamically linked
  NetBSD binaries from the days of yore.

* Add some additional compat* packages for completeness:

	compat15, compat20, compat30

* Modify the compat* packages so that "compatNM" only provides files
  that aren't in "NetBSD-N.(M+1)".  For example, compat12 only provides
  files that don't exist in NetBSD-1.3.x, compat13 only provides files
  that don't exist in NetBSD-1.4.x, etc.

  As a result, if you are running NetBSD-3.0/alpha and want to run a
  1.3 dynamically linked binary, there is an automatic dependency
  chain that causes the following packages to be installed:

	compat13, compat14, compat15, compat16, compat20

  There are some deviations from this dependency chain on platforms
  that have changed executable formats, e.g. i386, m68, sparc, etc.
  However, in general pkgsrc will require that you have the necessary
  COMPAT_* options in your kernel to match the installed compat*
  packages.  This restriction is an artificial one imposed by pkgsrc,
  but allows for a single set of distfiles to be used on all versions
  of NetBSD.

* Provide compat* package support for every supported architecture
  of NetBSD.  Verily, it is now possible to run 1.2 binaries on
  NetBSD-1.5.3/pc532 by installing the compat12 package from pkgsrc.
  Rejoice, one and all!

* The netbsd32_compat* packages mirror the corresponding compat*
  packages for use by sparc64 and x86_64 to allow running 32-bit
  binaries with COMPAT_NETBSD32 kernel support.  The "extras" packages
  supply the additional shared libraries from the corresponding release
  of NetBSD so that the set of files in /emul/netbsd32 will be complete.

* pkgsrc/emulators/compat_netbsd contains infrastructure files shared
  by all of the compat* packages.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>