[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / editors / xfce4-mousepad

File: [cvs.NetBSD.org] / pkgsrc / editors / xfce4-mousepad / Makefile (download)

Revision 1.5, Wed Dec 17 12:50:03 2008 UTC (15 years, 4 months ago) by hira
Branch: MAIN
Changes since 1.4: +2 -2 lines

Update Xfce to 4.4.3.  This is bug fix release.
Changes since 4.4.2:

x11/xfce4-panel:
  * Quite a bit code changed in the dnd code. Mostly to fix a segfault
    in FreeBSD-amd64, but more problems were discovered and a lot of
    code was simplified.
  * Don't respond the uri drags, we don't use it and it only causes
    problems like hiding the panel when a file was dragged over the
    panel (Bug #3815).
  * Fix crash with xrandr 1.2 (Bug #3620)

x11/xfce4-desktop:
  * Make menu panel plugin honor CustomizeDesktopMenu kiosk setting
    (Bug #1026).
  * Fix incorrect initial desktop font size when setting custom font
    size if a custom font was never set before (Bug #3957).

wm/xfce4-wm:
  * Fix automaximize on move
  * Remove trailing \0 in UTF-8 strings, that causes libwnck to
    rightfully complain that NET_WM_NAME contains invalid UTF-8
  * Exit on SelectionClear event so that xfwm4 exits even with WM who
    do not send a ClientMessage event such as Openbox (Bug #2374)
  * Backport overlay and compositor support from trunk (Bug #3849)
  * Filter out grab/ungrab events so we don't end up redrawing the
    frame twice
  * Set monitor when positionning menu (Bug #4162)
  * Reduce flickering during resize (Bug #4283)
  * Fix NET_WM_STATE claiming maximization vertical and horizontal even
    if only horizontal of vertical is actually set (Should fix Bug #3969)
  * Loosen the rule that prevents an application from iconifying itself
    when skip_taskbar is set (Bug #4434)
  * Rework visual depth selection of the frame window (Bug #4452)
  * Add support for NET_MOVERESIZE_WINDOW
  * Take gravity bit into account in configure resize only requests to
    comply with standard (Bug #3634)
  * Add client windows to save set to avoid loosing all windows in case
    of crash
  * Use guint32 instead of Time internally to avoid potential issues in
    64bits
  * Add a "--replace" command line option to replace ICCCM2 compliant
    window managers (Bug #3731)

x11/libxfce4gui:
  * Fix format-string vulnerability in dialog code

x11/xfce4-terminal:
  * Update to latest trunk translations.

sysutils/xfce4-thunar:
  * Update to latest trunk translations.

editors/xfce4-mousepad:
  * Sort recent items by most recently used.

x11/xfce4-utils:
  * Fix missing translated chars (Bug #3543)

Updated translations:
  * Basque
  * Brazilian Portuguese
  * Catalan
  * Chinese Traditional
  * Danish
  * Estonian
  * Finnish
  * French
  * Galician
  * German
  * Indonesian
  * Japanese
  * Korean
  * Kurdish
  * Latvian
  * Norwegian
  * Polish
  * Sinhala
  * Slovak
  * Slovene
  * Spanish
  * Turkish
  * Urdu

# $NetBSD: Makefile,v 1.5 2008/12/17 12:50:03 hira Exp $

PKG_DESTDIR_SUPPORT=	user-destdir

.include "../../meta-pkgs/xfce4/Makefile.common"

XFCE4_VERSION=	0.2.14

DISTNAME=	mousepad-${XFCE4_VERSION}
PKGNAME=	xfce4-mousepad-${XFCE4_VERSION}
CATEGORIES=	editors
COMMENT=	Xfce text editor

.include "../../x11/libxfce4gui/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"