[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / editors / vim-share

File: [cvs.NetBSD.org] / pkgsrc / editors / vim-share / Makefile.common (download)

Revision 1.165, Thu Feb 6 21:52:58 2020 UTC (4 years, 1 month ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.164: +2 -2 lines

vim-share: Add "OR gnu-gpl-v2" to LICENSE.

The vim distribution terms indicate that modified versions of Vim can be
distributed "under the GNU GPL version 2 or any later version".

# $NetBSD: Makefile.common,v 1.165 2020/02/06 21:52:58 nia Exp $
# used by editors/vim/Makefile
# used by editors/vim-gtk2/Makefile
# used by editors/vim-gtk3/Makefile
# used by editors/vim-lang/Makefile
# used by editors/vim-motif/Makefile
# used by editors/vim-xaw/Makefile

.include "../../editors/vim-share/version.mk"

DISTNAME=		vim-${VIM_VERSION}.${VIM_PATCHLEVEL}
CATEGORIES=		editors
GITHUB_PROJECT=		vim
GITHUB_TAG=		v${VIM_VERSION}.${VIM_PATCHLEVEL}
MASTER_SITES=		${MASTER_SITE_GITHUB:=vim/}

# vim disables it, sometimes unsuccessfully.
FORTIFY_SUPPORTED=	no

.include "../../mk/bsd.prefs.mk"

MAINTAINER=		morr@NetBSD.org
HOMEPAGE=		https://www.vim.org/
LICENSE=		vim-license OR gnu-gpl-v2

CONFLICTS+=		vim-kde-[0-9]*

EXTRACT_USING=		gtar

WRKSRC=			${WRKDIR}/${DISTNAME}/src
GNU_CONFIGURE=		yes
USE_LANGUAGES+=		c99

# http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=38710
CHECK_INTERPRETER_SKIP=	share/vim/${VIM_SUBDIR}/tools/vim132

.include "options.mk"

CONFIGURE_ARGS+=	--with-modified-by=${MAINTAINER:Q}

# See "configure --help" extra options. These might affect the installed
# files (and PLIST might not include all files) so use at your own risk!
CONFIGURE_ARGS+=	${VIM_EXTRA_OPTS}
CONFIGURE_ARGS+=	--enable-multibyte
CONFIGURE_ARGS+=	--enable-cscope

PATCH_ARGS=		-d ${WRKDIR}/${DISTNAME} --forward --quiet \
				-E ${PATCH_STRIP:Q}
PATCH_DIST_ARGS=	-d ${WRKDIR}/${DISTNAME} --forward --quiet \
				-E ${PATCH_DIST_STRIP:Q}
PATCHDIR=		${.CURDIR}/../../editors/vim-share/patches
DISTINFO_FILE?=		${.CURDIR}/../../editors/vim-share/distinfo

.if ${OPSYS} == "Darwin" && exists(/Developer/Headers/FlatCarbon)
BUILDLINK_PASSTHRU_DIRS+=	/Developer/Headers/FlatCarbon
.endif

.if empty(PKGNAME:Mvim-share*)
ALTERNATIVES_SRC=	${.CURDIR}/../../editors/vim-share/ALTERNATIVES
.else
ALTERNATIVES_SRC=
.endif

SUBST_CLASSES+=		sysconfdir
SUBST_FILES.sysconfdir=	feature.h
SUBST_STAGE.sysconfdir=	pre-configure
SUBST_VARS.sysconfdir=	PKG_SYSCONFDIR

post-patch:
	find ${WRKDIR} -name '*.orig_dist' -exec rm -f {} \;