[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / editors / pico

File: [cvs.NetBSD.org] / pkgsrc / editors / pico / Makefile (download)

Revision 1.59, Tue Jan 25 10:07:56 2005 UTC (19 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.58: +6 -7 lines

Changes pine 4.62, pico 4.9:

   Additions include:

     * Enable-Newmail-in-Xterm-Icon now also sets the title bar text to
       indicate new mail
     * New feature Enable-Newmail-Short-Text-in-Icon
     * New UNIX Pine feature NewMail-FIFO-Path
     * New feature NewMail-Window-Width
     * Select command may use the pattern from an existing Rule (for
       example, an Indexcolor Rule) for its selection criteria
     * Beginning of Month and Beginning of Year options in Rules
     * Some additional tokens having to do with the current date may be
       used in the folder name that is used as a target in a Filter Rule.
       For example, you may filter messages to a folder named for the
       current month by using the _CURYEAR_ and _CURMONTH_ tokens in the
       folder name. The (long) list of all such tokens is here.
     * Three additional tokens for use with Keywords may be used in the
       Index-Format. They are SUBJKEYINIT, KEY, and KEYINIT (in addition
       to the old SUBJKEY).
     * Keywords may be displayed in color using Keyword Colors, available
       from the Setup/Kolor screen
     * The Keyword-Surrounding-Chars option may be used to slightly
       modify the display of SUBJKEYINIT and SUBJKEY tokens.
     * The Enable-Flag-Screen-Keyword-Shortcut option adds a shortcut
       method of setting keywords
     * When performing an aggregate reply (or forward), if the Role that
       would be selected when replying (or forwarding) to each individual
       message in the set is the same for all the messages, then that
       role is used just like it would be when replying (or forwarding)
       to any one of those messages.
     * Delete/No Delete prompt added to Save command so that the source
       message may be deleted or not on a Save-by-Save basis
     * Status-Message-Delay option now allows reducing the status message
       delays Pine sometimes adds
     * New feature Save-Partial-Msg-Without-Confirm
     * New feature Disable-Take-Fullname-in-Addresses
     * New feature Sort-Default-FCC-Alpha
     * New feature Sort-Default-Save-Alpha
     * For selecting messages by Status, add the possibility of selecting
       based on Recent or Unseen status
     * Allow Take command to take addresses from html and enriched text
       subtypes, as well as from plain text

   Bugs that have been addressed in this release include:

     * Crash when sending a message with a Role that sets the To header
       if the Empty-Header-Message is set to
     * Pine hangs in composer after alternate editor or speller is run
       and new mail arrives that causes an External Categorizer command
       to be executed
     * Crash in MESSAGE INDEX when using a threaded sort. The crash is
       most common when the sort is Reversed.
     * Pine could crash or hang when the window was resized down to 3
       lines or fewer while in the composer
     * In the Role editor the "To Folders" command for the "Set Fcc"
       action did not work
     * After running Pine for a long time, it would slow down until
       restarted
     * Export command in FOLDER LIST did not work with dual-use folders
     * When the Send-Without-Confirm option was turned on, flowed text
       was not produced and the Fcc-Without-Attachments feature did not
       work
     * Display bug, folder was not un-highlighted
     * When viewing a message from the separate thread index, new mail
       arrival could cause Pine to leave the MESSAGE TEXT screen and drop
       back to the MESSAGE INDEX screen on its own
     * When the UnDelete command was typed in the composer with the
       cursor in the middle of a header line, the text was inserted at
       the beginning of the line instead of at the location of the cursor
     * When some messages from a thread were selected (not including the
       top of the thread), the view was Zoomed, and the feature
       Slash-Collapses-Entire-Thread was turned on; the collapse command
       caused messages to disappear from the view entirely
     * Incorrect character conversions were possible when going from
       ISO-8859-X to ISO-8859-1
     * Quell-Charset-Warning will now also quell the short comment
       included in header lines about the charset being different from
       yours in addition to quelling the editorial comment at the top of
       a message. This is the stuff that looks like "[ISO-8859-2]" in a
       header line.
     * If the Down Arrow key was held down it caused Pine to do a new
       mail check for each repeated character, which caused a delay when
       the key was held down by mistake. Changed that so that it does at
       most one check per second.
     * An unnecessary sort of the folder (causing a delay) was happening
       when closing if a filter rule depended on message state
     * Mouse in xterm failed when clicking in the folder screen
     * Enable-Dot-Folders feature did not allow adding folders with names
       beginning with dot
     * When replying to a TEXT/ENRICHED message Pine was failing to
       filter out the ENRICHED markup
     * Crash caused by malformed ISO-2022-JP in header
     * Crash when changing Inbox-Path if INBOX was not the current folder
     * Adding a collection on a Cyrus server did not work if the folder
       already existed (Pine tried to create it and failed)
     * Pine gave incorrect messages when deleting dual-use
       folders/directories
     * Saving an attached message to INBOX from another collection did
       not work correctly (it tried to create INBOX in the collection
       instead)
     * In some circumstances, Pine could announce "No messages expunged
       from folder " after an expunge command that actually worked
       correctly
     * Allow alternate editor to use quoted arguments
     * News drop folders weren't using the correct newsrc with
       Enable-Multiple-Newsrcs enabled
     * Error decoding some 8-bit headers, typically showing up as a
       garbage character at the end of a name

# $NetBSD: Makefile,v 1.59 2005/01/25 10:07:56 adam Exp $

DISTNAME=	pine4.62
PKGNAME=	pico-4.9
CATEGORIES=	editors
MASTER_SITES=	ftp://ftp.cac.washington.edu/pine/ \
		ftp://ftp.fu-berlin.de/unix/mail/pine/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	tech-pkg@NetBSD.org
HOMEPAGE=	http://www.washington.edu/pine/
COMMENT=	Text editor (ships with Pine), and Pine's text editing lib

LICENSE=	pine-license

USE_BUILDLINK3=		yes
USE_LIBTOOL=		yes

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "Darwin"
BUILDNAME=	osx
LIBS+=		-lcurses
.elif ${OPSYS} == "IRIX"
.  if ${OS_VERSION} >= 6.5
BUILDNAME=	sg6
.  else
BUILDNAME=	sgi
.  endif
.elif ${OPSYS} == "Linux"
BUILDNAME=	lnx
.elif ${OPSYS} == "SunOS"
BUILDNAME=	so5
.else
BUILDNAME=	neb
.endif

MAKE_ENV+=	_STRIPFLAG_INSTALL=	# debug...

do-build:
	@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./build ${BUILDNAME} \
		CC="${LIBTOOL} ${CC}" \
		PREFIX=${PREFIX} OPTIMIZE="${CFLAGS}" \
		EXTRALDFLAGS="${LIBS}"

do-install:
	${LIBTOOL} --mode=install ${INSTALL_LIB} \
		${WRKSRC}/pico/libpico.la ${PREFIX}/lib
	${LIBTOOL} --mode=install ${INSTALL_PROGRAM} \
		${WRKSRC}/pico/pico ${WRKSRC}/pico/pilot ${PREFIX}/bin
	${INSTALL_MAN} ${WRKSRC}/doc/pico.1 ${PREFIX}/man/man1
	${INSTALL_MAN} ${WRKSRC}/doc/pilot.1 ${PREFIX}/man/man1
	${INSTALL_DATA_DIR} ${PREFIX}/include/pico
	cd ${WRKSRC}/pico && ${INSTALL_DATA} *.h ${PREFIX}/include/pico

.include "../../devel/ncurses/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"