[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / editors / pico

Annotation of pkgsrc/editors/pico/Makefile, Revision 1.80

1.80    ! nia         1: # $NetBSD: Makefile,v 1.79 2017/01/19 18:52:08 agc Exp $
1.60      tv          2: #
                      3: # NOTE:
                      4: # When updating, it is necessary to change the shlib version, located in
1.62      tv          5: # several files in patches/.  If you do not KNOW that the new version is
                      6: # backwards ABI compatible (usually not), bump the major version,
1.69      reed        7: # and then bump the BUILDLINK_API_DEPENDS in buildlink3.mk.
1.1       frueauf     8:
1.66      adam        9: DISTNAME=      pine4.64
1.65      tv         10: PKGNAME=       pico-4.10
1.72      jlam       11: PKGREVISION=   2
1.1       frueauf    12: CATEGORIES=    editors
1.79      agc        13: MASTER_SITES=  ftp://ftp.cac.washington.edu/pine/
                     14: MASTER_SITES+= ftp://ftp.fu-berlin.de/unix/mail/pine/
1.34      tron       15: EXTRACT_SUFX=  .tar.bz2
1.1       frueauf    16:
1.75      jwise      17: MAINTAINER=    pkgsrc-users@NetBSD.org
1.9       tsarna     18: HOMEPAGE=      http://www.washington.edu/pine/
1.24      wiz        19: COMMENT=       Text editor (ships with Pine), and Pine's text editing lib
1.26      jtb        20: LICENSE=       pine-license
1.1       frueauf    21:
1.59      adam       22: USE_LIBTOOL=           yes
1.20      jlam       23:
                     24: .include "../../mk/bsd.prefs.mk"
                     25:
1.72      jlam       26: OPSYSVARS+=            BUILDNAME
                     27: BUILDNAME.Darwin=      osx
                     28: .if ${OPSYS} == "IRIX"
1.58      jschauma   29: .  if ${OS_VERSION} >= 6.5
1.72      jlam       30: BUILDNAME.IRIX=                sg6
1.58      jschauma   31: .  else
1.72      jlam       32: BUILDNAME.IRIX=                sgi
1.58      jschauma   33: .  endif
1.20      jlam       34: .endif
1.72      jlam       35: BUILDNAME.Interix=     sfu
                     36: BUILDNAME.Linux=       lnx
                     37: BUILDNAME.SunOS=       so5
                     38: BUILDNAME.NetBSD=      neb
                     39: BUILDNAME.*=           neb
                     40:
                     41: # Let termcap.buildlink3.mk handle using the right termcap library.
                     42: LIBS+=                 ${BUILDLINK_LDADD.termcap}
1.21      hubertf    43:
1.30      yyamano    44: MAKE_ENV+=     _STRIPFLAG_INSTALL=     # debug...
1.1       frueauf    45:
1.74      joerg      46: INSTALLATION_DIRS=     bin include/pico lib ${PKGMANDIR}/man1
1.64      jlam       47:
1.72      jlam       48: # Create the OS-dependent files for Interix from the Solaris ones.
                     49: post-extract:
                     50:        ${CP} -f ${WRKSRC}/pico/osdep/os-sol.h ${WRKSRC}/pico/osdep/os-sfu.h
1.61      tv         51:        ${SED} -e 's,read.pol,read.sel,' \
                     52:                ${WRKSRC}/pico/osdep/os-sv4.ic >${WRKSRC}/pico/osdep/os-sfu.ic
1.72      jlam       53:        ${SED} -e 's,sv4,sfu,g' \
1.61      tv         54:                ${WRKSRC}/pico/makefile.sv4 >${WRKSRC}/pico/makefile.sfu
                     55:
1.1       frueauf    56: do-build:
1.55      grant      57:        @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./build ${BUILDNAME} \
1.77      joerg      58:                CC="${LIBTOOL} --mode=compile ${CC}" \
1.80    ! nia        59:                LDCC="${LIBTOOL} --mode=link ${CC} ${LDFLAGS}" \
1.54      grant      60:                PREFIX=${PREFIX} OPTIMIZE="${CFLAGS}" \
                     61:                EXTRALDFLAGS="${LIBS}"
1.1       frueauf    62:
                     63: do-install:
1.59      adam       64:        ${LIBTOOL} --mode=install ${INSTALL_LIB} \
1.71      jlam       65:                ${WRKSRC}/pico/libpico.la ${DESTDIR}${PREFIX}/lib
1.48      jlam       66:        ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} \
1.71      jlam       67:                ${WRKSRC}/pico/pico ${WRKSRC}/pico/pilot ${DESTDIR}${PREFIX}/bin
                     68:        ${INSTALL_MAN} ${WRKSRC}/doc/pico.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
                     69:        ${INSTALL_MAN} ${WRKSRC}/doc/pilot.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
                     70:        cd ${WRKSRC}/pico && ${INSTALL_DATA} *.h ${DESTDIR}${PREFIX}/include/pico
1.1       frueauf    71:
1.72      jlam       72: .include "../../mk/termcap.buildlink3.mk"
1.1       frueauf    73: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>