File:
[cvs.NetBSD.org] /
pkgsrc /
editors /
nedit /
Makefile
Revision
1.58:
download - view:
text,
annotated -
select for diffs
Thu Jan 19 18:52:08 2017 UTC (8 years, 2 months ago) by
agc
Branches:
MAIN
CVS tags:
pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
HEAD
Convert all occurrences (353 by my count) of
MASTER_SITES= site1 \
site2
style continuation lines to be simple repeated
MASTER_SITES+= site1
MASTER_SITES+= site2
lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.
# $NetBSD: Makefile,v 1.58 2017/01/19 18:52:08 agc Exp $
DISTNAME= nedit-${VERS}-src
PKGNAME= nedit-${VERS}
PKGREVISION= 9
CATEGORIES= editors
# @pkglint: MASTER_SITE_NEDIT is defined below
MASTER_SITES= ${MASTER_SITE_NEDIT:=v${VERS:S/./_/g}/}
MASTER_SITES+= ${MASTER_SITE_SOURCEFORGE:=nedit/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.nedit.org/
# Upstream "info@nedit.org" did not reply to a message send on 22 March 2014
# asking about patches for modern compilers.
COMMENT= Motif based standard GUI style text editor
LICENSE= gnu-gpl-v2
VERS= 5.5
MASTER_SITE_NEDIT= http://www.nedit.org/ftp/ \
http://nl.nedit.org/ftp/ \
ftp://nl.nedit.org/pub/NEdit/ \
ftp://ftp.fu-berlin.de/unix/editors/nedit/ \
http://gd.tuwien.ac.at/editors/nedit/NEdit/ \
ftp://cri.univ-tlse1.fr/pub/unix/nedit/NEdit/ \
ftp://ftp.chg.ru/pub/unix/editors/nedit/
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
BUILD_TARGET= netbsd
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1 ${PREFIX}/share/doc/nedit
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/source/nedit ${DESTDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/source/nc ${DESTDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/nedit.man \
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/nedit.1
${INSTALL_MAN} ${WRKSRC}/doc/nc.man \
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/nedit-nc.1
.for f in README ReleaseNotes
${INSTALL_DATA} ${WRKSRC}/${f} ${DESTDIR}${PREFIX}/share/doc/nedit
.endfor
.for f in faq.txt NEdit.ad
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DESTDIR}${PREFIX}/share/doc/nedit
.endfor
.include "../../x11/libXt/buildlink3.mk"
.include "../../x11/libXpm/buildlink3.mk"
.include "../../mk/motif.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
CVSweb <webmaster@jp.NetBSD.org>