[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / editors / nano

File: [cvs.NetBSD.org] / pkgsrc / editors / nano / Makefile (download)

Revision 1.98, Thu Apr 29 18:44:14 2021 UTC (2 years, 11 months ago) by wiedi
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.97: +2 -2 lines

nano: update to 5.7

2021.04.29 - GNU nano 5.7 "Toi ceilali arau câmpurile"
The output of --constantshow (without --minibar) is more stable.
When opening multiple buffers and there is an error message, this
  message is shown again upon first switch to the relevant buffer.
The position and size of the indicator now follow actual lines,
  instead of visual lines when in softwrap mode, meaning that the
  size of the indicator can change when scrolling in softwrap mode.

# $NetBSD: Makefile,v 1.98 2021/04/29 18:44:14 wiedi Exp $

DISTNAME=	nano-5.7
CATEGORIES=	editors
MASTER_SITES=	https://www.nano-editor.org/dist/v${PKGVERSION_NOREV:C/\..*$//}/
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	wiedi@frubar.net
HOMEPAGE=	https://www.nano-editor.org/
COMMENT=	Small and friendly text editor (a free replacement for Pico)
LICENSE=	gnu-gpl-v3

USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		msgfmt msgmerge xgettext gmake
USE_TOOLS+=		pkg-config
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--enable-color
CONFIGURE_ARGS+=	--enable-multibuffer
CONFIGURE_ARGS+=	--enable-nanorc
CONFIGURE_ARGS+=	--enable-extra

INFO_FILES=		yes

# Looks like that IRIX 5.x lacks vsnprintf() functions,
# which are required to make this work, so glib2 is used instead.
.include "../../mk/bsd.prefs.mk"

.if !empty(MACHINE_PLATFORM:MIRIX-5*)
.  include "../../devel/glib2/buildlink3.mk"
.endif

.include "options.mk"

INSTALLATION_DIRS+=	share/examples/nano
CONF_FILES+=		share/examples/nano/nanorc ${PKG_SYSCONFDIR}/nanorc

SUBST_CLASSES+=		man
SUBST_STAGE.man=	pre-configure
SUBST_MESSAGE.man=	Fixing paths in manpages.
SUBST_FILES.man=	doc/nano.1 doc/nanorc.5
SUBST_VARS.man=		PKG_SYSCONFDIR PREFIX

post-install:
	${INSTALL_DATA} ${WRKSRC}/doc/sample.nanorc ${DESTDIR}${PREFIX}/share/examples/nano/nanorc

.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../mk/curses.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"