[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / editors / nano

File: [cvs.NetBSD.org] / pkgsrc / editors / nano / Makefile (download)

Revision 1.92, Sun Jan 24 17:13:42 2021 UTC (3 years, 2 months ago) by nia
Branch: MAIN
Changes since 1.91: +2 -2 lines

nano: Update to 5.5

2021.01.14 - GNU nano 5.5 "Rebecca"
Option 'set minibar' makes nano suppress the title bar and instead
  show a bar with basic editing information at the bottom: file name
  (plus an asterisk when the buffer is modified), the cursor position
  (line,column), the character under the cursor (U+xxxx), the flags
  that --stateflags normally shows, plus the percentage of the buffer
  that is above the cursor.
With 'set promptcolor' the color combination of the prompt bar can
  be changed, to allow contrasting it with the mini bar (which always
  has the same color as the title bar).
Option 'set markmatch' highlights the result of a successful search
  by putting the mark at the end of the match, making the match more
  visible.  It also suppresses the cursor until the next keystroke.
  (If you dislike the hiding of the cursor, use 'set showcursor'.)
The bindable toggle 'nowrap' has been renamed to 'breaklonglines',
  to match the corresponding option, like for all other toggles.
Support for Slang has been removed.

# $NetBSD: Makefile,v 1.92 2021/01/24 17:13:42 nia Exp $

DISTNAME=	nano-5.5
CATEGORIES=	editors
MASTER_SITES=	https://www.nano-editor.org/dist/v${PKGVERSION_NOREV:C/\..*$//}/
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	wiedi@frubar.net
HOMEPAGE=	https://www.nano-editor.org/
COMMENT=	Small and friendly text editor (a free replacement for Pico)
LICENSE=	gnu-gpl-v3

USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		msgfmt msgmerge xgettext gmake
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--enable-color
CONFIGURE_ARGS+=	--enable-multibuffer
CONFIGURE_ARGS+=	--enable-nanorc
CONFIGURE_ARGS+=	--enable-extra

INFO_FILES=		yes

# Looks like that IRIX 5.x lacks vsnprintf() functions,
# which are required to make this work, so glib2 is used instead.
.include "../../mk/bsd.prefs.mk"

.if !empty(MACHINE_PLATFORM:MIRIX-5*)
.  include "../../devel/glib2/buildlink3.mk"
.endif

.include "options.mk"

INSTALLATION_DIRS+=	share/examples/nano
CONF_FILES+=		share/examples/nano/nanorc ${PKG_SYSCONFDIR}/nanorc

post-install:
	${INSTALL_DATA} ${WRKSRC}/doc/sample.nanorc ${DESTDIR}${PREFIX}/share/examples/nano/nanorc

.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../mk/curses.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"