[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / editors / gedit

File: [cvs.NetBSD.org] / pkgsrc / editors / gedit / Makefile (download)

Revision 1.160, Sun May 2 10:24:48 2021 UTC (2 years, 7 months ago) by nia
Branch: MAIN
Changes since 1.159: +2 -2 lines

*: Use the tools framework for itstool

Now it should be more obvious when a package needs it as a dependency,
as it will fail loudly if it isn't declared as a tool.

While here, some duplicate dependencies on itstool were removed from the
MATE packages

# $NetBSD: Makefile,v 1.160 2021/05/02 10:24:48 nia Exp $

DISTNAME=	gedit-3.36.2
PKGREVISION=	5
CATEGORIES=	editors gnome
MASTER_SITES=	${MASTER_SITE_GNOME:=sources/gedit/${PKGVERSION_NOREV:R}/}
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	prlw1@cam.ac.uk
HOMEPAGE=	https://wiki.gnome.org/Apps/Gedit
COMMENT=	Lightweight GNOME UTF-8 text editor
LICENSE=	gnu-gpl-v2

PREV_PKGPATH=	editors/gedit3

USE_TOOLS+=			gettext msgfmt perl pkg-config
USE_TOOLS+=			itstool
_TOOLS_USE_PKGSRC.msgfmt=	yes

PYTHON_VERSIONS_INCOMPATIBLE=	27
PY_PATCHPLIST=			yes
REPLACE_PYTHON+=		plugins/externaltools/data/send-to-fpaste.tool.in
REPLACE_PYTHON+=		build-aux/meson/post_install.py

MESON_ARGS+=	-Dvapi=false
MAKE_ENV+=	LD_LIBRARY_PATH=${WRKSRC}/output/gedit

DEPENDS+=	adwaita-icon-theme-[0-9]*:../../graphics/adwaita-icon-theme
DEPENDS+=	${PYPKGPREFIX}-gobject3-[0-9]*:../../devel/py-gobject3

pre-configure:
	${FIND} ${WRKSRC}/help -type f -exec ${CHMOD} 644 {} \;


.include "../../devel/gobject-introspection/buildlink3.mk"
BUILDLINK_API_DEPENDS.libpeas+=	libpeas>=1.14.1
.include "../../devel/libpeas/buildlink3.mk"
BUILDLINK_API_DEPENDS.glib2+=	glib2>=2.52
.include "../../devel/glib2/schemas.mk"
.include "../../devel/meson/build.mk"
.include "../../editors/tepl4/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../sysutils/gsettings-desktop-schemas/buildlink3.mk"
.include "../../textproc/gspell/buildlink3.mk"
BUILDLINK_API_DEPENDS.gtk3+=	gtk3+>=3.22
.include "../../x11/gtk3/buildlink3.mk"
BUILDLINK_API_DEPENDS.gtksourceview4+=	gtksourceview4>=4.0.2
.include "../../x11/gtksourceview4/buildlink3.mk"
.include "../../x11/libICE/buildlink3.mk"
.include "../../x11/libSM/buildlink3.mk"

.include "../../lang/python/application.mk"
.include "../../lang/python/extension.mk"
.include "../../mk/bsd.pkg.mk"